aboutsummaryrefslogtreecommitdiff
path: root/lang/python32
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-05-31 10:13:55 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-05-31 10:13:55 +0000
commit7e94fe3d3dc571a393df6de7de4b38829b4d5642 (patch)
tree41f506d31a4e74faed1b0394a2a3860eb9185707 /lang/python32
parent734ec74d08faf94051421612614a30ac4cbd2bc5 (diff)
downloadports-7e94fe3d3dc571a393df6de7de4b38829b4d5642.tar.gz
ports-7e94fe3d3dc571a393df6de7de4b38829b4d5642.zip
Notes
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 86c2fab26649..c0e33286ebcf 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -7,6 +7,7 @@
PORTNAME= python32
PORTVERSION= 3.2.3
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= ${PYTHON_MASTER_SITES}
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -50,12 +51,6 @@ BIN_FILES= python python-shared python-config python-shared-config \
BINLINKS_SUB= -e 's,(2to3|idle3|pydoc3),\1-${PYTHON_VER},' \
-e 's,(python-shared|python),\1${PYTHON_VER},'
-OPTIONS= THREADS "Enable thread support" on \
- UCS4 "Use UCS4 for unicode support" on \
- PYMALLOC "Use python's internal malloc" on \
- IPV6 "Enable IPv6 support" on \
- FPECTL "Enable floating point exception handling" off
-
OPTIONS_DEFINE= THREADS UCS4 PYMALLOC IPV6 FPECTL EXAMPLES
OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
@@ -83,7 +78,7 @@ CONFIGURE_ARGS+= --with-wide-unicode
PYABIVER:= ${PYABIVER}u
.endif
-.if ${PORT_OPTIONS:MPYMALLOC}
+.if empty(PORT_OPTIONS:MPYMALLOC)
CONFIGURE_ARGS+= --without-pymalloc
.else
PYABIVER:= m${PYABIVER}