aboutsummaryrefslogtreecommitdiff
path: root/lang/python32
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2014-07-11 18:09:01 +0000
committerSofian Brabez <sbz@FreeBSD.org>2014-07-11 18:09:01 +0000
commitb5d9bfb7a4aa74448310eb6f732369f376d05423 (patch)
tree54f8e56289136b2586222145558ebbda6542a04c /lang/python32
parented9d1b9bafa228d0d8a34c679a2143d047826177 (diff)
- Add CPE entries for python
- Remove NOPORTDATA as it's deprecated since r359061
Notes
Notes: svn path=/head/; revision=361574
Diffstat (limited to 'lang/python32')
-rw-r--r--lang/python32/Makefile28
1 files changed, 15 insertions, 13 deletions
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 6134138a4a23..a798a5ac79a4 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -1,30 +1,34 @@
# $FreeBSD$
-PORTNAME= python32
-PORTVERSION= 3.2.5
-PORTREVISION= 9
-CATEGORIES= lang python ipv6
-MASTER_SITES= PYTHON
+PORTNAME= python32
+PORTVERSION= 3.2.5
+PORTREVISION= 9
+CATEGORIES= lang python ipv6
+MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
-DISTNAME= ${PYTHON_DISTNAME}
-DIST_SUBDIR= python
+DISTNAME= ${PYTHON_DISTNAME}
+DIST_SUBDIR= python
MAINTAINER= python@FreeBSD.org
COMMENT= Interpreted object-oriented programming language
LICENSE= PSFL
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
CONFIGURE_SCRIPT= ../configure # must be relative
-CONFIGURE_ENV= OPT="" SVNVERSION="echo freebsd"
-MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
+CONFIGURE_ENV= OPT="" SVNVERSION="echo freebsd"
+MAKE_ENV= VPATH="${PYTHON_WRKSRC}"
INSTALL_TARGET= altinstall
-USES= readline tar:xz
+USES= readline tar:xz cpe
USE_LDCONFIG= yes
USE_PYTHON= yes
+CPE_VENDOR= python
+CPE_PRODUCT= ${CPE_VENDOR}
+CPE_VERSION= ${PORTVERSION}
+
PYTHON_VERSION= python3.2
PYTHON_NO_DEPENDS= yes
@@ -213,11 +217,9 @@ post-install:
${INSTALL_MAN} ${PYTHON_WRKSRC}/Misc/python.man \
${STAGEDIR}${MAN1PREFIX}/man/man1/${PYTHON_VERSION}.1
-.if !defined(NOPORTDATA)
@${MKDIR} ${STAGEDIR}${DATADIR}
@cd ${PYTHON_WRKSRC}; ${TAR} -cf - Tools | \
(cd ${STAGEDIR}${DATADIR}; ${TAR} -xf -)
-.endif
@${CAT} ${PKGMESSAGE}