aboutsummaryrefslogtreecommitdiff
path: root/lang/python34
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-06-16 17:46:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-06-16 17:46:41 +0000
commit53857e7276355d50ed71e4251e52d3af239dfbb3 (patch)
tree3c142e32a472e7d63d2ded6238de88c923ed013d /lang/python34
parent9bf9be990f64577f53ad4c932d28ac4fda95eecf (diff)
Notes
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile3
-rw-r--r--lang/python34/files/patch-Makefile.pre.in36
-rw-r--r--lang/python34/files/patch-issue2021010
-rw-r--r--lang/python34/pkg-plist2
4 files changed, 47 insertions, 4 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index 2d26bdb6d14f..8c73d5f9fad2 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,6 +3,7 @@
PORTNAME= python34
PORTVERSION= 3.4.1
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON
MASTER_SITE_SUBDIR= ${PYTHON_MASTER_SITE_SUBDIR}
@@ -80,6 +81,8 @@ ABIFLAGS:= d${ABIFLAGS}
.if !empty(ABIFLAGS)
PLIST_FILES+= bin/python%%VER%%%%ABI%%
+PLIST_FILES+= bin/python%%VER%%%%ABI%%-config
+PLIST_FILES+= libdata/pkgconfig/python-%%VER%%%%ABI%%.pc
.endif
.if ${ARCH} == sparc64
diff --git a/lang/python34/files/patch-Makefile.pre.in b/lang/python34/files/patch-Makefile.pre.in
index 2b820e254797..3d941d04e953 100644
--- a/lang/python34/files/patch-Makefile.pre.in
+++ b/lang/python34/files/patch-Makefile.pre.in
@@ -6,8 +6,12 @@
# Submitted by: antoine@ (r350207)
# TODO: Upstream
---- ./Makefile.pre.in.orig 2014-03-17 13:31:30.000000000 +1100
-+++ ./Makefile.pre.in 2014-04-06 18:21:28.147616242 +1000
+# Description: Create symlinks for non-ABI-suffixed python*-config and ABI-suffixed python-*.pc
+# Submitted by: antoine@ (r358029)
+# TODO: Upstream
+
+--- ./Makefile.pre.in.orig 2014-05-19 05:19:39.000000000 +0000
++++ ./Makefile.pre.in 2014-06-15 12:12:17.000000000 +0000
@@ -70,18 +70,15 @@
OPT= @OPT@
BASECFLAGS= @BASECFLAGS@
@@ -30,7 +34,20 @@
NO_AS_NEEDED= @NO_AS_NEEDED@
LDLAST= @LDLAST@
SGI_ABI= @SGI_ABI@
-@@ -1314,8 +1311,8 @@
+@@ -1065,12 +1062,6 @@
+ else true; \
+ fi
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) python3$(EXE))
+- -if test "$(VERSION)" != "$(LDVERSION)"; then \
+- rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
+- (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
+- rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
+- (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
+- fi
+ -rm -f $(DESTDIR)$(BINDIR)/python3-config
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python3-config)
+ -rm -f $(DESTDIR)$(LIBPC)/python3.pc
+@@ -1314,8 +1305,8 @@
if test "$(SHLIB_SUFFIX)" = .dll; then \
$(INSTALL_DATA) $(LDLIBRARY) $(DESTDIR)$(LIBPL) ; \
else \
@@ -40,3 +57,16 @@
fi; \
else \
echo Skip install of $(LIBRARY) - use make frameworkinstall; \
+@@ -1333,6 +1324,12 @@
+ $(INSTALL_SCRIPT) $(srcdir)/install-sh $(DESTDIR)$(LIBPL)/install-sh
+ $(INSTALL_SCRIPT) python-config.py $(DESTDIR)$(LIBPL)/python-config.py
+ $(INSTALL_SCRIPT) python-config $(DESTDIR)$(BINDIR)/python$(LDVERSION)-config
++ -if test "$(VERSION)" != "$(LDVERSION)"; then \
++ rm -f $(DESTDIR)$(BINDIR)/python$(VERSION)-config; \
++ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(LDVERSION)-config python$(VERSION)-config); \
++ rm -f $(DESTDIR)$(LIBPC)/python-$(LDVERSION).pc; \
++ (cd $(DESTDIR)$(LIBPC); $(LN) -s python-$(VERSION).pc python-$(LDVERSION).pc); \
++ fi
+ @if [ -s Modules/python.exp -a \
+ "`echo $(MACHDEP) | sed 's/^\(...\).*/\1/'`" = "aix" ]; then \
+ echo; echo "Installing support files for building shared extension modules on AIX:"; \
diff --git a/lang/python34/files/patch-issue20210 b/lang/python34/files/patch-issue20210
index 2f8bdda8ca35..40100a43f42e 100644
--- a/lang/python34/files/patch-issue20210
+++ b/lang/python34/files/patch-issue20210
@@ -42,6 +42,16 @@
# Check for use of the system expat library
AC_MSG_CHECKING(for --with-system-expat)
AC_ARG_WITH(system_expat,
+--- ./configure.orig 2014-05-19 05:19:40.000000000 +0000
++++ ./configure 2014-06-15 12:27:03.000000000 +0000
+@@ -650,6 +650,7 @@
+ TCLTK_LIBS
+ TCLTK_INCLUDES
+ LIBFFI_INCLUDEDIR
++DISABLED_EXTENSIONS
+ PKG_CONFIG
+ SHLIBS
+ CFLAGSFORSHARED
--- ./setup.py.orig 2014-03-24 22:48:48.495472513 +1100
+++ ./setup.py 2014-03-24 22:49:20.076122201 +1100
@@ -33,7 +33,10 @@
diff --git a/lang/python34/pkg-plist b/lang/python34/pkg-plist
index c5a86fa3a51a..6e5324dedc69 100644
--- a/lang/python34/pkg-plist
+++ b/lang/python34/pkg-plist
@@ -2,7 +2,7 @@ bin/2to3-%%VER%%
bin/idle%%VER%%
bin/pydoc%%VER%%
bin/python%%VER%%
-bin/python%%VER%%%%ABI%%-config
+bin/python%%VER%%-config
bin/pyvenv-%%VER%%
%%PYTHON_INCLUDEDIR%%%%ABI%%/Python-ast.h
%%PYTHON_INCLUDEDIR%%%%ABI%%/Python.h