aboutsummaryrefslogtreecommitdiff
path: root/lang/python34
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-01-08 16:45:09 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-01-08 16:45:09 +0000
commit474ff0ec6ac0f38e948e345cd9650ed808204dc2 (patch)
treeb14d8368654ff10811b2639080582589ce4e3316 /lang/python34
parentd00fd2e745869e25c02840168613563936749458 (diff)
downloadports-474ff0ec6ac0f38e948e345cd9650ed808204dc2.tar.gz
ports-474ff0ec6ac0f38e948e345cd9650ed808204dc2.zip
Notes
Diffstat (limited to 'lang/python34')
-rw-r--r--lang/python34/Makefile2
-rw-r--r--lang/python34/files/patch-Lib_distutils_command_install__lib.py35
2 files changed, 36 insertions, 1 deletions
diff --git a/lang/python34/Makefile b/lang/python34/Makefile
index b2c076e87f9d..e06ac3c486b3 100644
--- a/lang/python34/Makefile
+++ b/lang/python34/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python34
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PORTVERSION}
DISTNAME= Python-${PORTVERSION}
diff --git a/lang/python34/files/patch-Lib_distutils_command_install__lib.py b/lang/python34/files/patch-Lib_distutils_command_install__lib.py
new file mode 100644
index 000000000000..78b107068ec0
--- /dev/null
+++ b/lang/python34/files/patch-Lib_distutils_command_install__lib.py
@@ -0,0 +1,35 @@
+From 9934ce31b8447667f71c211e559a8de71e8263db Mon Sep 17 00:00:00 2001
+From: Brendan Molloy <brendan@bbqsrc.net>
+Date: Mon, 4 Jan 2016 23:14:06 +1100
+Subject: [PATCH] Check bytecode file actually exists and tests
+
+Should solve issue 20397, where using the --record argument results
+in files that failed to generate bytecode files are added to the
+record file nonetheless.
+
+--- Lib/distutils/command/install_lib.py.orig 2016-01-08 12:38:49 UTC
++++ Lib/distutils/command/install_lib.py
+@@ -165,11 +165,19 @@ class install_lib(Command):
+ if ext != PYTHON_SOURCE_EXTENSION:
+ continue
+ if self.compile:
+- bytecode_files.append(importlib.util.cache_from_source(
+- py_file, debug_override=True))
++ candidate = importlib.util.cache_from_source(
++ py_file, debug_override=True)
++
++ if os.path.isfile(candidate):
++ bytecode_files.append(candidate)
++
+ if self.optimize > 0:
+- bytecode_files.append(importlib.util.cache_from_source(
+- py_file, debug_override=False))
++ candidate = importlib.util.cache_from_source(
++ py_file, debug_override=False)
++
++ if os.path.isfile(candidate):
++ bytecode_files.append(candidate)
++
+
+ return bytecode_files
+