aboutsummaryrefslogtreecommitdiff
path: root/lang/python36
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2017-06-06 12:56:47 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2017-06-06 12:56:47 +0000
commit2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de (patch)
treedc349266ef50b39f1af7ccb996591cf377357316 /lang/python36
parent5a46ce779090dc0e6e32a02e0615d69310fee507 (diff)
downloadports-2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de.tar.gz
ports-2f6fe8dcec7d5bc9ac62ebe4ba2510257cb470de.zip
lang/python{27,33,34,35,36}: Install GDB debugging script
Users with a GDB that supports [1] Python extensions will automatically load the extra debugging extensions when debugging programs that are linked with libpythonX.Y.so.foo. This enables extensions like 'py-bt' and 'py-frame' as described in the Fedora Wiki Article: Easier Python Debugging [2], which can be useful for debugging Python program state from crashes in C extensions, for example. [1] PYTHON option enabled in devel/gdb [2] https://fedoraproject.org/wiki/Features/EasierPythonDebugging PR: 203021 Submitted by: cem Reviewed by: mat, koobs (python) Approved by: koobs (python) Differential Revision: D10398
Notes
Notes: svn path=/head/; revision=442759
Diffstat (limited to 'lang/python36')
-rw-r--r--lang/python36/Makefile4
-rw-r--r--lang/python36/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 4bcb9482ac15..b0e9aab414d6 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -3,7 +3,7 @@
PORTNAME= python
PORTVERSION= ${PYTHON_PORTVERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang python ipv6
MASTER_SITES= PYTHON/ftp/python/${PYTHON_PORTVERSION}
PKGNAMESUFFIX= ${PYTHON_SUFFIX}
@@ -131,5 +131,7 @@ post-install:
.endif
for i in ${STAGEDIR}${PREFIX}/lib/python${PYTHON_VER}/lib-dynload/*.so; do \
${STRIP_CMD} $$i; done # Strip shared extensions
+ ${INSTALL_DATA} ${WRKSRC}/Tools/gdb/libpython.py \
+ ${STAGEDIR}${PREFIX}/lib/libpython${PYTHON_VER}${ABIFLAGS}.so.1.0-gdb.py
.include <bsd.port.mk>
diff --git a/lang/python36/pkg-plist b/lang/python36/pkg-plist
index 678a0ae96588..5eec412f2737 100644
--- a/lang/python36/pkg-plist
+++ b/lang/python36/pkg-plist
@@ -106,6 +106,7 @@ include/python%%XYDOT%%%%ABI%%/warnings.h
include/python%%XYDOT%%%%ABI%%/weakrefobject.h
lib/libpython%%XYDOT%%%%ABI%%.so
lib/libpython%%XYDOT%%%%ABI%%.so.1.0
+lib/libpython%%XYDOT%%%%ABI%%.so.1.0-gdb.py
lib/python%%XYDOT%%/LICENSE.txt
lib/python%%XYDOT%%/__future__.py
lib/python%%XYDOT%%/__phello__.foo.py