aboutsummaryrefslogtreecommitdiff
path: root/lang/python36
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-26 16:45:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-12-26 16:45:31 +0000
commitf51c2f0758f127d367645c52ea1ac7ee27ac0b5c (patch)
tree7b2cdd5f60a85580178c0267113509e2666801b6 /lang/python36
parent353746450619f826fbceba1377900922ceabb168 (diff)
downloadports-f51c2f0758f127d367645c52ea1ac7ee27ac0b5c.tar.gz
ports-f51c2f0758f127d367645c52ea1ac7ee27ac0b5c.zip
- Remove TSC option
PR: 215580 Submitted by: Roland Smith <rsmith@xs4all.nl>
Notes
Notes: svn path=/head/; revision=429551
Diffstat (limited to 'lang/python36')
-rw-r--r--lang/python36/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/lang/python36/Makefile b/lang/python36/Makefile
index 393f988d2345..f3fa42a8f569 100644
--- a/lang/python36/Makefile
+++ b/lang/python36/Makefile
@@ -47,7 +47,7 @@ PLIST_SUB= XYDOT=${PYTHON_VER} XY=${PYTHON_SUFFIX} \
XYZDOT=${PYTHON_PORTVERSION} ABI=${ABIFLAGS} \
OSMAJOR=${OSVERSION:C/([0-9]*)[0-9]{5}/\1/} # For plat-freebsd* in pkg-plist. http://bugs.python.org/issue19554
-OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS TSC
+OPTIONS_DEFINE= DEBUG IPV6 LIBFFI NLS PYMALLOC THREADS
OPTIONS_DEFAULT= LIBFFI PYMALLOC THREADS
OPTIONS_RADIO= HASH
OPTIONS_RADIO_HASH= FNV SIPHASH
@@ -56,7 +56,6 @@ OPTIONS_SUB= yes
LIBFFI_DESC= Use libffi from ports instead of bundled version
NLS_DESC= Enable gettext support for the locale module
PYMALLOC_DESC= Enable specialized mallocs
-TSC_DESC= Enable processor timestamp counter profiling
HASH_DESC= Hash Algorithm (PEP-456)
FNV_DESC= Modified Fowler-Noll-Vo Algorithm
@@ -85,8 +84,6 @@ PYMALLOC_CONFIGURE_WITH= pymalloc
THREADS_CONFIGURE_WITH= threads
THREADS_LDFLAGS= -lpthread
-TSC_CONFIGURE_WITH= tsc
-
.include "${.CURDIR}/Makefile.version"
.include <bsd.port.options.mk>