aboutsummaryrefslogtreecommitdiff
path: root/lang/python
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-01-25 09:15:12 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-01-25 09:15:12 +0000
commita5ec92772407997fd607330266e6957ba5c595e2 (patch)
tree6a5600a7a78cee12084b4afcbf9ef39c8603bc99 /lang/python
parent8fd329e5dbc3a7d3bf1ff6186572f3604041e5da (diff)
downloadports-a5ec92772407997fd607330266e6957ba5c595e2.tar.gz
ports-a5ec92772407997fd607330266e6957ba5c595e2.zip
- Do not use absolute source paths for the symlinks to the stagedir
Noticed by: danfe
Notes
Notes: svn path=/head/; revision=340997
Diffstat (limited to 'lang/python')
-rw-r--r--lang/python/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 760d9b7766a8..4d5ee3d79e1a 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -36,27 +36,23 @@ RUN_DEPENDS+= python3:${PORTSDIR}/lang/python3
do-install:
.for file in python python-shared
- ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER} \
- ${STAGEDIR}${PREFIX}/bin/${file}
+ ${LN} -sf ${file}${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
- ${LN} -sf ${PREFIX}/bin/2to3-${PYTHON_MAJOR_VER} \
- ${STAGEDIR}${PREFIX}/bin/2to3
+ ${LN} -sf 2to3-${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/2to3
.if ${PYTHON_MAJOR_VER} == 2
- ${LN} -sf ${PREFIX}/bin/smtpd${PYTHON_MAJOR_VER}.py \
- ${STAGEDIR}${PREFIX}/bin/smtpd.py
+ ${LN} -sf smtpd${PYTHON_MAJOR_VER}.py ${STAGEDIR}${PREFIX}/bin/smtpd.py
.for file in idle pydoc
- ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER} \
- ${STAGEDIR}${PREFIX}/bin/${file}
+ ${LN} -sf ${file}${PYTHON_MAJOR_VER} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
.elif ${PYTHON_MAJOR_VER} == 3
.for file in idle pydoc
- ${LN} -sf ${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}-${PYTHON_VER} \
+ ${LN} -sf ${file}${PYTHON_MAJOR_VER}-${PYTHON_VER} \
${STAGEDIR}${PREFIX}/bin/${file}
.endfor
.endif
- ${LN} -sf ${PREFIX}/bin/python${PYTHON_MAJOR_VER}-config \
+ ${LN} -sf python${PYTHON_MAJOR_VER}-config \
${STAGEDIR}${PREFIX}/bin/python-config
- ${LN} -sf ${PREFIX}/bin/python-shared${PYTHON_MAJOR_VER}-config \
+ ${LN} -sf python-shared${PYTHON_MAJOR_VER}-config \
${STAGEDIR}${PREFIX}/bin/python-shared-config
# Major upgrade support