aboutsummaryrefslogtreecommitdiff
path: root/lang/qore/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2009-11-13 02:08:43 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2009-11-13 02:08:43 +0000
commit6e04f389d521a88949a2dc75e79663b55df60c16 (patch)
treed62fab10ac04a93751d548333045b222f0933960 /lang/qore/Makefile
parent7bdae62dced3495be686630b1ff2df39831c580e (diff)
Notes
Diffstat (limited to 'lang/qore/Makefile')
-rw-r--r--lang/qore/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/lang/qore/Makefile b/lang/qore/Makefile
new file mode 100644
index 000000000000..752880d8826f
--- /dev/null
+++ b/lang/qore/Makefile
@@ -0,0 +1,27 @@
+# Ports collection makefile for: qore
+# Date created: 12 November 2009
+# Whom: B. Estrade <estrabd@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qore
+PORTVERSION= 0.7.6
+CATEGORIES= lang
+MASTER_SITES= SF/qore/qore/${PORTVERSION}/
+
+MAINTAINER= estrabd@gmail.com
+COMMENT= The Qore Programming Language
+
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
+ xml2:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex \
+ ${LOCALBASE}/bin/bison:${PORTSDIR}/devel/bison
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debug --disable-static
+
+MAN1= qore.1
+
+.include <bsd.port.mk>