aboutsummaryrefslogtreecommitdiff
path: root/lang/qscheme
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-30 21:15:14 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-30 21:15:14 +0000
commit6c3d3edd5e501c67b203bcca7e4a6f93f7d016c3 (patch)
tree831f4f87f1a89d4a7be63bb700c41319ea70e1d2 /lang/qscheme
parentb8ce65474eb9ed725c225699258070149849748c (diff)
downloadports-6c3d3edd5e501c67b203bcca7e4a6f93f7d016c3.tar.gz
ports-6c3d3edd5e501c67b203bcca7e4a6f93f7d016c3.zip
Notes
Diffstat (limited to 'lang/qscheme')
-rw-r--r--lang/qscheme/Makefile43
-rw-r--r--lang/qscheme/files/patch-Makefile.in16
-rw-r--r--lang/qscheme/files/patch-doc__Makefile.in11
-rw-r--r--lang/qscheme/pkg-descr9
-rw-r--r--lang/qscheme/pkg-plist60
5 files changed, 70 insertions, 69 deletions
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 5dd1a1a4cf32..0a93f39f8a2d 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -3,23 +3,24 @@
PORTNAME= qscheme
PORTVERSION= 0.5.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= lang scheme
MASTER_SITES= http://www.sof.ch/dan/qscheme/files/
MAINTAINER= ports@FreeBSD.org
COMMENT= Small and fast Scheme interpreter
-BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall \
${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre \
${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/gmp
LIB_DEPENDS= libgetline.so:${PORTSDIR}/devel/libgetline
USES= gmake perl5
USE_PERL5= build
+USE_GCC= any
GNU_CONFIGURE= yes
-PLIST_SUB+= PORTVERSION="${PORTVERSION}"
-
CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
--with-pcre-inc=${LOCALBASE}/include \
--with-avcall-dir=${LOCALBASE}/lib \
@@ -27,20 +28,26 @@ CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
--with-gmp-dir=${LOCALBASE}/lib \
--with-gmp-inc=${LOCALBASE}/include
-NO_STAGE= yes
-post-patch:
- ${REINPLACE_CMD} \
- -e "s,^LIBS = @LIBS@,& ${PTHREAD_LIBS} -L${LOCALBASE}/lib -lgetline," \
- -e "s,^CFLAGS = @CFLAGS@,& ${PTHREAD_CFLAGS}," \
- ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} \
- -e "s,-lpthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lgetline
+
+PLIST_SUB= VERSION="${PORTVERSION}"
+PORTDOCS= *
-.include <bsd.port.pre.mk>
+# because it uses static pcre lib, which is compiled without -fPIC.
+# pcre problem likely.
+BROKEN_amd64= Does not build on ${ARCH}
+BROKEN_sparc64= Does not build on ${ARCH}
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lpthread|-pthread| ; \
+ /SCM_DEFAULT_LIB_PATH/s|$$datadir|$$prefix/lib|' \
+ ${WRKSRC}/configure
-.if ${ARCH} == "ia64" || ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-# because it uses static pcre lib, which is compiled without -fPIC. pcre problem likely.
-BROKEN= Does not build on amd64, ia64, or sparc64
-.endif
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/qscheme/*/*.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/qscheme/files/patch-Makefile.in b/lang/qscheme/files/patch-Makefile.in
index 2a1ff648ec27..f78872f20c3a 100644
--- a/lang/qscheme/files/patch-Makefile.in
+++ b/lang/qscheme/files/patch-Makefile.in
@@ -1,6 +1,6 @@
--- Makefile.in.orig 2000-06-23 02:10:21.000000000 +0300
+++ Makefile.in 2009-03-03 18:30:51.000000000 +0200
-@@ -111,7 +111,7 @@
+@@ -111,11 +111,11 @@
EXTRA_DIST = mkoptable mkwhatis $(modsrc) $(scmsrc) CHANGES LICENCE_EXCEPTION
# other directories
@@ -9,6 +9,11 @@
noinst_LIBRARIES = libqs.a
+-shared_dir = $(prefix)/share/qscheme/$(VERSION)
++shared_dir = $(prefix)/lib/qscheme/$(VERSION)
+
+ scmobjdir = $(shared_dir)
+ scmobj_DATA = $(modobj) $(scmsrc)
@@ -578,12 +578,12 @@
$(COMPILE) -o $@ -shared -fPIC -I$(incpcre) $(srcdir)/regex.c $(PCRE_LIB)
@@ -27,3 +32,12 @@
# force sproto.h to be up to date. Otherwise compilation of
# distribution may fail, because sproto.h can trigger the cfunction
+@@ -594,7 +594,7 @@
+
+ # force the x bit on the shared libraries
+ install-data-local:
+- chmod +x $(shared_dir)/*.so
++ chmod +x $(DESTDIR)$(shared_dir)/*.so
+
+ whatis: whatis.qs
+
diff --git a/lang/qscheme/files/patch-doc__Makefile.in b/lang/qscheme/files/patch-doc__Makefile.in
new file mode 100644
index 000000000000..124dd11bd55c
--- /dev/null
+++ b/lang/qscheme/files/patch-doc__Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig
++++ doc/Makefile.in
+@@ -71,7 +71,7 @@
+ #
+ #
+ #
+-docdir=$(DESTDIR)$(pkgdatadir)/$(VERSION)/doc
++docdir=$(DESTDIR)$(datadir)/doc/@PACKAGE@
+
+ HTMLDIR=$(srcdir)/html
+
diff --git a/lang/qscheme/pkg-descr b/lang/qscheme/pkg-descr
index 7cdac23ef041..2ab4bb51d460 100644
--- a/lang/qscheme/pkg-descr
+++ b/lang/qscheme/pkg-descr
@@ -1,8 +1,9 @@
-QScheme is a fast and small implementation of Scheme written in C. QScheme is
-easy to interface and should be easy to use as an extension language.
+QScheme is a fast and small implementation of Scheme written in C.
+QScheme is easy to interface and should be easy to use as an extension
+language.
-QScheme currently supports foreign function call and dynamic library. A perl
-like regular expression module is provided as example.
+QScheme currently supports foreign function call and dynamic library. A
+perl like regular expression module is provided as example.
QScheme is really fast: benchmarks (still a little old) shows that it is
generaly between 2 and 70 times faster than other scheme interpreters.
diff --git a/lang/qscheme/pkg-plist b/lang/qscheme/pkg-plist
index 2c9bddb65197..e6ce2e30fdc0 100644
--- a/lang/qscheme/pkg-plist
+++ b/lang/qscheme/pkg-plist
@@ -1,47 +1,15 @@
bin/qscheme
-share/qscheme/%%PORTVERSION%%/regex.so
-share/qscheme/%%PORTVERSION%%/object.so
-share/qscheme/%%PORTVERSION%%/process.so
-share/qscheme/%%PORTVERSION%%/struct.so
-share/qscheme/%%PORTVERSION%%/socket.so
-share/qscheme/%%PORTVERSION%%/unix.so
-share/qscheme/%%PORTVERSION%%/s.scm
-share/qscheme/%%PORTVERSION%%/macro.scm
-share/qscheme/%%PORTVERSION%%/loop.scm
-share/qscheme/%%PORTVERSION%%/wloop.scm
-share/qscheme/%%PORTVERSION%%/fib.scm
-share/qscheme/%%PORTVERSION%%/cat.scm
-share/qscheme/%%PORTVERSION%%/doc/s.dvi
-share/qscheme/%%PORTVERSION%%/doc/s.ps
-share/qscheme/%%PORTVERSION%%/doc/html/WARNINGS
-share/qscheme/%%PORTVERSION%%/doc/html/footnode.html
-share/qscheme/%%PORTVERSION%%/doc/html/images.aux
-share/qscheme/%%PORTVERSION%%/doc/html/images.log
-share/qscheme/%%PORTVERSION%%/doc/html/images.pl
-share/qscheme/%%PORTVERSION%%/doc/html/images.tex
-share/qscheme/%%PORTVERSION%%/doc/html/img1.png
-share/qscheme/%%PORTVERSION%%/doc/html/img2.png
-share/qscheme/%%PORTVERSION%%/doc/html/index.html
-share/qscheme/%%PORTVERSION%%/doc/html/internals.pl
-share/qscheme/%%PORTVERSION%%/doc/html/labels.pl
-share/qscheme/%%PORTVERSION%%/doc/html/node1.html
-share/qscheme/%%PORTVERSION%%/doc/html/node10.html
-share/qscheme/%%PORTVERSION%%/doc/html/node11.html
-share/qscheme/%%PORTVERSION%%/doc/html/node12.html
-share/qscheme/%%PORTVERSION%%/doc/html/node13.html
-share/qscheme/%%PORTVERSION%%/doc/html/node14.html
-share/qscheme/%%PORTVERSION%%/doc/html/node15.html
-share/qscheme/%%PORTVERSION%%/doc/html/node2.html
-share/qscheme/%%PORTVERSION%%/doc/html/node3.html
-share/qscheme/%%PORTVERSION%%/doc/html/node4.html
-share/qscheme/%%PORTVERSION%%/doc/html/node5.html
-share/qscheme/%%PORTVERSION%%/doc/html/node6.html
-share/qscheme/%%PORTVERSION%%/doc/html/node7.html
-share/qscheme/%%PORTVERSION%%/doc/html/node8.html
-share/qscheme/%%PORTVERSION%%/doc/html/node9.html
-share/qscheme/%%PORTVERSION%%/doc/html/s.css
-share/qscheme/%%PORTVERSION%%/doc/html/s.html
-@dirrm share/qscheme/%%PORTVERSION%%/doc/html
-@dirrm share/qscheme/%%PORTVERSION%%/doc
-@dirrm share/qscheme/%%PORTVERSION%%
-@dirrm share/qscheme
+lib/qscheme/%%VERSION%%/regex.so
+lib/qscheme/%%VERSION%%/object.so
+lib/qscheme/%%VERSION%%/process.so
+lib/qscheme/%%VERSION%%/struct.so
+lib/qscheme/%%VERSION%%/socket.so
+lib/qscheme/%%VERSION%%/unix.so
+lib/qscheme/%%VERSION%%/s.scm
+lib/qscheme/%%VERSION%%/macro.scm
+lib/qscheme/%%VERSION%%/loop.scm
+lib/qscheme/%%VERSION%%/wloop.scm
+lib/qscheme/%%VERSION%%/fib.scm
+lib/qscheme/%%VERSION%%/cat.scm
+@dirrm lib/qscheme/%%VERSION%%
+@dirrm lib/qscheme