aboutsummaryrefslogtreecommitdiff
path: root/lang/qt5-qml
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-03-18 09:37:42 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-03-18 09:37:42 +0000
commitccb075974927198585d93f60042a06c3956c5e70 (patch)
treec0c66b80a92a56c0bc2bea93add708c3873588aa /lang/qt5-qml
parent0c32a35808299997c3c6f75123e4f3ee3560b904 (diff)
downloadports-ccb075974927198585d93f60042a06c3956c5e70.tar.gz
ports-ccb075974927198585d93f60042a06c3956c5e70.zip
Notes
Diffstat (limited to 'lang/qt5-qml')
-rw-r--r--lang/qt5-qml/Makefile1
-rw-r--r--lang/qt5-qml/files/patch-git_b84f08c823
-rw-r--r--lang/qt5-qml/files/patch-src__qml__jit__qv4assembler.cpp11
-rw-r--r--lang/qt5-qml/pkg-plist2
4 files changed, 2 insertions, 35 deletions
diff --git a/lang/qt5-qml/Makefile b/lang/qt5-qml/Makefile
index 1b178ddfaab5..f9f495c44958 100644
--- a/lang/qt5-qml/Makefile
+++ b/lang/qt5-qml/Makefile
@@ -2,7 +2,6 @@
PORTNAME= qml
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= lang
PKGNAMEPREFIX= qt5-
diff --git a/lang/qt5-qml/files/patch-git_b84f08c8 b/lang/qt5-qml/files/patch-git_b84f08c8
deleted file mode 100644
index 1a632b140f27..000000000000
--- a/lang/qt5-qml/files/patch-git_b84f08c8
+++ /dev/null
@@ -1,23 +0,0 @@
-Fixes the build with base GCC.
-
-commit b84f08c8b7c91a979bd74840561af2391ef20666
-Author: Lars Knoll <lars.knoll@digia.com>
-Date: Tue May 6 13:30:31 2014 +0200
-
- Fix compiler warning
-
- Change-Id: I26df4f1b8417c6b075d81eaf118669a4103503e2
- Reviewed-by: Simon Hausmann <simon.hausmann@digia.com>
-
---- src/qml/jsruntime/qv4object_p.h
-+++ src/qml/jsruntime/qv4object_p.h
-@@ -168,7 +168,8 @@ struct Q_QML_EXPORT Object: Managed {
- void defineReadonlyProperty(const StringRef name, ValueRef value);
-
- void insertMember(const StringRef s, const ValueRef v, PropertyAttributes attributes = Attr_Data) {
-- insertMember(s, Property(*v), attributes);
-+ Property p(*v);
-+ insertMember(s, p, attributes);
- }
- void insertMember(const StringRef s, const Property &p, PropertyAttributes attributes);
-
diff --git a/lang/qt5-qml/files/patch-src__qml__jit__qv4assembler.cpp b/lang/qt5-qml/files/patch-src__qml__jit__qv4assembler.cpp
deleted file mode 100644
index ecc5d0572282..000000000000
--- a/lang/qt5-qml/files/patch-src__qml__jit__qv4assembler.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/qml/jit/qv4assembler.cpp
-+++ src/qml/jit/qv4assembler.cpp
-@@ -96,7 +96,7 @@ QV4::ExecutableAllocator::ChunkOfPages *CompilationUnit::chunkForFunction(int fu
- /* Platform/Calling convention/Architecture specific section */
-
- #if CPU(X86_64)
--# if OS(LINUX) || OS(MAC_OS_X)
-+# if OS(UNIX)
- static const Assembler::RegisterID calleeSavedRegisters[] = {
- JSC::X86Registers::ebx,
- JSC::X86Registers::r12, // LocalsRegister
diff --git a/lang/qt5-qml/pkg-plist b/lang/qt5-qml/pkg-plist
index 7d51e93f4513..5c2660163aa5 100644
--- a/lang/qt5-qml/pkg-plist
+++ b/lang/qt5-qml/pkg-plist
@@ -178,6 +178,7 @@
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4regalloc_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4regexp_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4regexpobject_p.h
+%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4registerinfo_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4runtime_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4scopedvalue_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4script_p.h
@@ -188,6 +189,7 @@
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4ssa_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4string_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4stringobject_p.h
+%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4targetplatform_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4unop_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4util_p.h
%%QT_INCDIR%%/QtQml/%%FULLVER%%/QtQml/private/qv4value_inl_p.h