aboutsummaryrefslogtreecommitdiff
path: root/lang/qt5-qml
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-01-29 02:11:00 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-01-29 02:11:00 +0000
commit48f147ecf1f5bc844c218ebd290c2e247f9c994e (patch)
tree07618f49de1ac33f4b49352fed691bc34edc3ea7 /lang/qt5-qml
parent024e852a6d54c3dc77608106577412bf935a25cf (diff)
downloadports-48f147ecf1f5bc844c218ebd290c2e247f9c994e.tar.gz
ports-48f147ecf1f5bc844c218ebd290c2e247f9c994e.zip
Notes
Diffstat (limited to 'lang/qt5-qml')
-rw-r--r--lang/qt5-qml/Makefile1
-rw-r--r--lang/qt5-qml/files/patch-git_cf6e971126
2 files changed, 27 insertions, 0 deletions
diff --git a/lang/qt5-qml/Makefile b/lang/qt5-qml/Makefile
index f9f495c44958..1b178ddfaab5 100644
--- a/lang/qt5-qml/Makefile
+++ b/lang/qt5-qml/Makefile
@@ -2,6 +2,7 @@
PORTNAME= qml
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= lang
PKGNAMEPREFIX= qt5-
diff --git a/lang/qt5-qml/files/patch-git_cf6e9711 b/lang/qt5-qml/files/patch-git_cf6e9711
new file mode 100644
index 000000000000..54a4b13f6c9b
--- /dev/null
+++ b/lang/qt5-qml/files/patch-git_cf6e9711
@@ -0,0 +1,26 @@
+commit cf6e97119df5bf17b4a952b257d05d43b7d6ca26
+Author: Alex Richardson <arichardson.kde@gmail.com>
+Date: Wed Jan 21 09:10:01 2015 +0000
+
+ Don't crash on FreeBSD when computing stack limits
+
+ On FreeBSD pthread_attr_t is a pointer and is dereferenced when calling
+ pthread_attr_get_np() so if we don't initialize it will probably crash.
+ This is not a problem on glibc systems since there pthread_attr_t is an
+ opaque union an doesn't need to be allocated using malloc().
+
+ Change-Id: I227685ddf9981974ade08aee8917f7262c301787
+ Reviewed-by: Simon Hausmann <simon.hausmann@theqtcompany.com>
+
+--- src/qml/jsruntime/qv4engine.cpp
++++ src/qml/jsruntime/qv4engine.cpp
+@@ -112,7 +112,8 @@ quintptr getStackLimit()
+ void* stackBottom = 0;
+ pthread_attr_t attr;
+ #if HAVE(PTHREAD_NP_H) && OS(FREEBSD)
+- if (pthread_attr_get_np(pthread_self(), &attr) == 0) {
++ // on FreeBSD pthread_attr_init() must be called otherwise getting the attrs crashes
++ if (pthread_attr_init(&attr) == 0 && pthread_attr_get_np(pthread_self(), &attr) == 0) {
+ #else
+ if (pthread_getattr_np(pthread_self(), &attr) == 0) {
+ #endif