aboutsummaryrefslogtreecommitdiff
path: root/lang/racket-minimal
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-14 09:39:22 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-14 09:39:22 +0000
commit35e442c46bc47ec31cca9516637e7bbf911bb358 (patch)
tree11345c97c3144af3df3c652fcd6b7a2dbe9a88a2 /lang/racket-minimal
parent8e7375545891431952aad133f283f15140030cc8 (diff)
downloadports-35e442c46bc47ec31cca9516637e7bbf911bb358.tar.gz
ports-35e442c46bc47ec31cca9516637e7bbf911bb358.zip
Notes
Diffstat (limited to 'lang/racket-minimal')
-rw-r--r--lang/racket-minimal/Makefile27
1 files changed, 9 insertions, 18 deletions
diff --git a/lang/racket-minimal/Makefile b/lang/racket-minimal/Makefile
index 11361f1ffb88..5a9d863fe36c 100644
--- a/lang/racket-minimal/Makefile
+++ b/lang/racket-minimal/Makefile
@@ -4,6 +4,7 @@
PORTNAME= racket
PKGNAMESUFFIX= -minimal
PORTVERSION= 6.1
+PORTREVISION= 1
CATEGORIES= lang scheme
MASTER_SITES= http://mirror.racket-lang.org/installers/${PORTVERSION}/ \
http://www.cs.utah.edu/plt/installers/${PORTVERSION}/ \
@@ -18,31 +19,21 @@ DIST_SUBDIR= ${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Interactive, integrated, graphical Scheme programming environment
+LIB_DEPENDS= libffi.so:${PORTSDIR}/devel/libffi
+
MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= RACKET_PLACES
-RACKET_PLACES_DESC= Enable Places
OPTIONS_DEFAULT= RACKET_PLACES
+RACKET_PLACES_DESC= Enable Places
+RACKET_PLACES_CONFIGURE_ENABLE= places
CONFLICTS= racket-[0-9]*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --enable-pthread \
- --enable-lt=${LIBTOOL}
-
-.include <bsd.port.options.mk>
-
-LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
-
-.if ${PORT_OPTIONS:MRACKET_PLACES}
-CONFIGURE_ARGS+= --enable-places
-.else
-CONFIGURE_ARGS+= --disable-places
-.endif
-
-# Force the "configure" script to look in $LOCALBASE for -lpng and -ljpeg
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ARGS= --disable-lt --enable-shared --enable-pthread
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/racket-${PORTVERSION}/src
USES= iconv libtool tar:tgz
@@ -50,10 +41,10 @@ USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386 amd64
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "amd64"
CPPFLAGS+= -DLONG64
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>