aboutsummaryrefslogtreecommitdiff
path: root/lang/rexx-imc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:47:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:47:53 +0000
commitf55985d860b2db3a4b5d333e44b823619ca83162 (patch)
tree5256761fdd1f97e373e348f0b00e63c5f579493b /lang/rexx-imc
parentcfbe36e19761f0c9be67ce69617e5a7a3b1cbd70 (diff)
downloadports-f55985d860b2db3a4b5d333e44b823619ca83162.tar.gz
ports-f55985d860b2db3a4b5d333e44b823619ca83162.zip
Notes
Diffstat (limited to 'lang/rexx-imc')
-rw-r--r--lang/rexx-imc/Makefile39
-rw-r--r--lang/rexx-imc/files/patch-Make2
-rw-r--r--lang/rexx-imc/pkg-descr2
-rw-r--r--lang/rexx-imc/pkg-plist12
4 files changed, 27 insertions, 28 deletions
diff --git a/lang/rexx-imc/Makefile b/lang/rexx-imc/Makefile
index 5f39945dcce3..fae9bf0619d7 100644
--- a/lang/rexx-imc/Makefile
+++ b/lang/rexx-imc/Makefile
@@ -5,11 +5,13 @@ PORTNAME= rexx-imc
PORTVERSION= 1.76
PORTREVISION= 2
CATEGORIES= lang
-MASTER_SITES= http://users.comlab.ox.ac.uk/ian.collier/distribution/ \
+MASTER_SITES= http://www.cs.ox.ac.uk/people/ian.collier/distribution/ \
ftp://ftp.sai.msu.su/pub/unix/rexx/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A procedural programming language designed by IBM's UK Laboratories
+COMMENT= Procedural programming language designed by IBM's UK Laboratories
+
+OPTIONS_DEFINE= DOCS EXAMPLES
CONFLICTS= rexx-regina-* oorexx-[0-9]*
@@ -29,11 +31,7 @@ DOCFILES= rexx.info rexx.ref rexx.summary rexx.tech
RMEFILES= README README.Y2K README.bugreport README.docs \
README.files README.make README.news README.platforms
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
+.include <bsd.port.options.mk>
post-patch:
# CFLAGS safeness for ARCHs other than i386
@@ -44,30 +42,31 @@ post-patch:
do-install:
# install interpreter and daemon helpers
.for prog in rexx rxque rxstack
- @${INSTALL_PROGRAM} ${WRKSRC}/${prog} ${PREFIX}/bin
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} ${prog} ${PREFIX}/bin)
.endfor
# install shared libraries, include file, and rxlib
+ (cd ${WRKSRC} && ${INSTALL_DATA} rexxsaa.h ${PREFIX}/include)
# DO NOT delete rxlib or you will lose ability to call mathlib!!
-.for lib in librexx.so.2 rxmathfn.rxfn
- @${INSTALL_PROGRAM} ${WRKSRC}/${lib} ${PREFIX}/lib
+.for lib in librexx.so.2 rxmathfn.rxfn rxmathfn.rxlib
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${lib} ${PREFIX}/lib)
.endfor
- @${LN} -sf ${PREFIX}/lib/librexx.so.2 ${PREFIX}/lib/librexx.so
- @${INSTALL_DATA} ${WRKSRC}/rexxsaa.h ${PREFIX}/include
- @${INSTALL_DATA} ${WRKSRC}/rxmathfn.rxlib ${PREFIX}/lib
+ @${LN} -sf librexx.so.2 ${PREFIX}/lib/librexx.so
# install man pages
.for man in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/${man} ${PREFIX}/man/man1
+ (cd ${WRKSRC} && ${INSTALL_MAN} ${man} ${MANPREFIX}/man/man1)
.endfor
# install documenation and examples
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCFILES} ${RMEFILES}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.for doc in ${DOCFILES} ${RMEFILES}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${doc} ${DOCSDIR})
.endfor
- @${MKDIR} ${PREFIX}/share/examples/rexx-imc
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
.for ex in box rexxcps.rexx rexxtest.rexx rxmathfn.rexx shell.rexx
- @${INSTALL_SCRIPT} ${WRKSRC}/${ex} ${PREFIX}/share/examples/rexx-imc
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} ${ex} ${EXAMPLESDIR})
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/rexx-imc/files/patch-Make b/lang/rexx-imc/files/patch-Make
index 0bdc4741d87b..e6a3548e5cdb 100644
--- a/lang/rexx-imc/files/patch-Make
+++ b/lang/rexx-imc/files/patch-Make
@@ -61,7 +61,7 @@
+ ;;
+ esac
+ ;;
-+ FreeBSD:5.*|FreeBSD:6.*|FreeBSD:7.*|FreeBSD:8.*)
++ FreeBSD:[5-9].*|FreeBSD:[1-9][0-9].*)
+ REXXLIB="librexx.so"
+ SOLINK="librexx.so"
+ RANLIB=ranlib
diff --git a/lang/rexx-imc/pkg-descr b/lang/rexx-imc/pkg-descr
index bbebe9acada9..f600a1b9f9db 100644
--- a/lang/rexx-imc/pkg-descr
+++ b/lang/rexx-imc/pkg-descr
@@ -4,4 +4,4 @@ and has a partial implementation of the SAA API allowing applications
to call Rexx programs and to register addressing environments, Rexx
functions, and exit handlers.
-WWW: http://users.comlab.ox.ac.uk/ian.collier/Rexx/rexximc.html
+WWW: http://www.cs.ox.ac.uk/people/ian.collier/Rexx/rexximc.html
diff --git a/lang/rexx-imc/pkg-plist b/lang/rexx-imc/pkg-plist
index d457f72fbeea..e235023b5674 100644
--- a/lang/rexx-imc/pkg-plist
+++ b/lang/rexx-imc/pkg-plist
@@ -18,10 +18,10 @@ lib/rxmathfn.rxlib
%%PORTDOCS%%%%DOCSDIR%%/rexx.ref
%%PORTDOCS%%%%DOCSDIR%%/rexx.summary
%%PORTDOCS%%%%DOCSDIR%%/rexx.tech
-%%PORTDOCS%%share/examples/rexx-imc/box
-%%PORTDOCS%%share/examples/rexx-imc/rexxcps.rexx
-%%PORTDOCS%%share/examples/rexx-imc/rexxtest.rexx
-%%PORTDOCS%%share/examples/rexx-imc/rxmathfn.rexx
-%%PORTDOCS%%share/examples/rexx-imc/shell.rexx
-%%PORTDOCS%%@dirrm share/examples/rexx-imc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/box
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rexxcps.rexx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rexxtest.rexx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rxmathfn.rexx
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shell.rexx
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%