aboutsummaryrefslogtreecommitdiff
path: root/lang/rhino/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2009-05-30 07:41:06 +0000
committerNicola Vitale <nivit@FreeBSD.org>2009-05-30 07:41:06 +0000
commit860735b7adf3d44170c4e603d76db0cd6523bee8 (patch)
treecea34a54030baa6774ab884385946763cae8c9fc /lang/rhino/Makefile
parent372eb252aee49b329beaeace16777fac1e1aff87 (diff)
downloadports-860735b7adf3d44170c4e603d76db0cd6523bee8.tar.gz
ports-860735b7adf3d44170c4e603d76db0cd6523bee8.zip
Notes
Diffstat (limited to 'lang/rhino/Makefile')
-rw-r--r--lang/rhino/Makefile22
1 files changed, 16 insertions, 6 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index 6f1b2be5db7d..35e61d122aa4 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -6,14 +6,13 @@
#
PORTNAME= rhino
-DISTVERSION= 1_7R1
-#PORTREVISION= 0
+DISTVERSION= 1_7R2
+PORTREVISION= 0
#PORTEPOCH= 0
-PORTREVISION= 1
CATEGORIES= lang java
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla.org/js/:rhino \
http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/:swingex \
- ${MASTER_SITE_APACHE}:xmlbeans
+ http://www.apache.org/dist/xmlbeans/binaries/:xmlbeans
MASTER_SITE_SUBDIR= xmlbeans/binaries/:xmlbeans
DISTFILES= ${PORTNAME}${DISTVERSION}.zip:rhino \
src.zip:swingex \
@@ -24,6 +23,8 @@ EXTRACT_ONLY= ${PORTNAME}${DISTVERSION}.zip
MAINTAINER= nivit@FreeBSD.org
COMMENT= An implementation of JavaScript written in Java
+OPTIONS= LINEDIT "Enable line editing in the Rhino shell" on
+
ALL_TARGET= jar
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
@@ -36,7 +37,7 @@ MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.2.0.zip \
RHINOJAR= ${DATADIR}/${PORTNAME}.jar
SUB_FILES= rhinoc rhinodbg rhinosh
-SUB_LIST= RHINOJAR=${RHINOJAR}
+SUB_LIST= RHINOJAR=${RHINOJAR} JLINEJAR=":${JLINEJAR}"
USE_ANT= yes
USE_JAVA= yes
@@ -52,4 +53,13 @@ do-install:
${INSTALL_SCRIPT} ${WRKDIR}/$${RHINOSCRIPT} ${PREFIX}/bin/; \
done
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_LINEDIT)
+JLINEJAR= ${JAVAJARDIR}/jline.jar
+RUN_DEPENDS+= ${JLINEJAR}:${PORTSDIR}/devel/jline
+.else
+JLINEJAR=""
+.endif
+
+.include <bsd.port.post.mk>