aboutsummaryrefslogtreecommitdiff
path: root/lang/rhino
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2014-06-11 05:12:13 +0000
committerNicola Vitale <nivit@FreeBSD.org>2014-06-11 05:12:13 +0000
commit2b9c49917153fb62cfc9f03ab8af131db1e140d9 (patch)
tree161fc33ef1f8db7e14843768063dc0a47c277a34 /lang/rhino
parent3ba2f4ed71e11dc953193ec4c26cd3e28be5eb29 (diff)
downloadports-2b9c49917153fb62cfc9f03ab8af131db1e140d9.tar.gz
ports-2b9c49917153fb62cfc9f03ab8af131db1e140d9.zip
Notes
Diffstat (limited to 'lang/rhino')
-rw-r--r--lang/rhino/Makefile37
-rw-r--r--lang/rhino/pkg-descr2
2 files changed, 17 insertions, 22 deletions
diff --git a/lang/rhino/Makefile b/lang/rhino/Makefile
index 2136c4fc2a14..00ae267d21f1 100644
--- a/lang/rhino/Makefile
+++ b/lang/rhino/Makefile
@@ -15,7 +15,7 @@ DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${PORTNAME}${DISTVERSION}.zip
MAINTAINER= nivit@FreeBSD.org
-COMMENT= An implementation of JavaScript written in Java
+COMMENT= Implementation of JavaScript written in Java
LICENSE= MPL
@@ -25,44 +25,39 @@ DATADIR= ${JAVASHAREDIR}/${PORTNAME}
JAVA_VERSION= 1.6+
+LINEDIT_DESC= Enable line editing in the Rhino shell
+LINEDIT_RUN_DEPENDS= ${JLINEJAR}:${PORTSDIR}/devel/jline
+LINEDIT_USE= java=yes ant=yes
+
MAKE_ARGS= -Dxmlbeans.url=file://${DISTDIR}/${DIST_SUBDIR}/xmlbeans-2.5.0.zip \
-Dswing-ex-url=file://${DISTDIR}/${DIST_SUBDIR}/src.zip
-OPTIONS_DEFINE= LINEDIT
-LINEDIT_DESC= Enable line editing in the Rhino shell
-
OPTIONS_DEFAULT= LINEDIT
+OPTIONS_DEFINE= LINEDIT
USES= zip
-NO_STAGE= yes
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MLINEDIT}
+JLINEJAR= ${JAVAJARDIR}/jline.jar
+.else
+JLINEJAR=""
+.endif
+
RHINOJAR= ${DATADIR}/${PORTNAME}.jar
SUB_FILES= rhinoc rhinodbg rhinosh
SUB_LIST= RHINOJAR=${RHINOJAR} JLINEJAR="${JLINEJAR}"
-USE_ANT= yes
-USE_JAVA= yes
-
WRKSRC= ${WRKDIR}/${PORTNAME}${DISTVERSION}
do-install:
- @${MKDIR} ${DATADIR}; \
- ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}${DISTVERSION}/js.jar ${RHINOJAR}; \
+ @${MKDIR} ${STAGEDIR}${DATADIR}; \
+ ${INSTALL_DATA} ${WRKSRC}/build/${PORTNAME}${DISTVERSION}/js.jar ${STAGEDIR}${RHINOJAR}; \
RHINOSCRIPTS="${SUB_FILES}"; \
for RHINOSCRIPT in $${RHINOSCRIPTS}; do \
- ${INSTALL_SCRIPT} ${WRKDIR}/$${RHINOSCRIPT} ${PREFIX}/bin/; \
+ ${INSTALL_SCRIPT} ${WRKDIR}/$${RHINOSCRIPT} ${STAGEDIR}${PREFIX}/bin/; \
done
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MLINEDIT}
-JLINEJAR= ${JAVAJARDIR}/jline.jar
-RUN_DEPENDS+= ${JLINEJAR}:${PORTSDIR}/devel/jline
-.else
-JLINEJAR=""
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/rhino/pkg-descr b/lang/rhino/pkg-descr
index 6310e14d3a64..a05137226f8c 100644
--- a/lang/rhino/pkg-descr
+++ b/lang/rhino/pkg-descr
@@ -14,4 +14,4 @@ Rhino contains
into Java class files
* A JavaScript debugger for scripts executed with Rhino
-WWW: http://www.mozilla.org/rhino/
+WWW: https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino