aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby-js/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-02-26 19:58:22 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-02-26 19:58:22 +0000
commite699572f1b62dbaa62a479ddd5f5e658990684ca (patch)
tree3d879c4064ba5437c62c96a63d3b912581b61350 /lang/ruby-js/Makefile
parenta0d87e8d2c4c23fb7d1a6a3de217f3d06b4759f6 (diff)
downloadports-e699572f1b62dbaa62a479ddd5f5e658990684ca.tar.gz
ports-e699572f1b62dbaa62a479ddd5f5e658990684ca.zip
Notes
Diffstat (limited to 'lang/ruby-js/Makefile')
-rw-r--r--lang/ruby-js/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/lang/ruby-js/Makefile b/lang/ruby-js/Makefile
index 73b4c5124793..ad254a44b804 100644
--- a/lang/ruby-js/Makefile
+++ b/lang/ruby-js/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= js
-PORTVERSION= 0.0.2
+PORTVERSION= 0.0.3
CATEGORIES= lang ruby
-MASTER_SITES= http://www.ruby-lang.org/~tamura/ruby/
+MASTER_SITES= http://www.ruby-lang.org/~tamura/ruby/ruby-js/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
@@ -21,9 +21,12 @@ LIB_DEPENDS= js.0:${PORTSDIR}/lang/njs
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+WRKSRC= ${WRKDIR}/JS
INSTALL_TARGET= site-install
-EXAMPLES= html_ssi_lua.rb test_*
+EXAMPLES= classtest.rb
+DOCS_EN= README.rd
+DOCS_JA= README.rd.ja
post-install:
.if !defined(NOPORTDOCS)
@@ -31,8 +34,13 @@ post-install:
.for f in ${EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODEXAMPLESDIR}/
.endfor
- ${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/rubylua.txt ${RUBY_MODDOCDIR}/
+ ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+.endfor
.endif
.include <bsd.port.mk>