aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby-perl
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-11 10:57:44 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-11 10:57:44 +0000
commiteeef61ccb34305b569ff9e3da785ca1c4aac650e (patch)
treeb6c4a548def2c978aba7fbfbc6c9e7b8b0f24b9c /lang/ruby-perl
parentb109c0ee3ac30101acf34bf40c4ba61caa13c19d (diff)
downloadports-eeef61ccb34305b569ff9e3da785ca1c4aac650e.tar.gz
ports-eeef61ccb34305b569ff9e3da785ca1c4aac650e.zip
Notes
Diffstat (limited to 'lang/ruby-perl')
-rw-r--r--lang/ruby-perl/Makefile56
-rw-r--r--lang/ruby-perl/distinfo1
-rw-r--r--lang/ruby-perl/pkg-comment1
-rw-r--r--lang/ruby-perl/pkg-descr5
-rw-r--r--lang/ruby-perl/pkg-plist16
5 files changed, 79 insertions, 0 deletions
diff --git a/lang/ruby-perl/Makefile b/lang/ruby-perl/Makefile
new file mode 100644
index 000000000000..26f55eabef9e
--- /dev/null
+++ b/lang/ruby-perl/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: Ruby-perl
+# Date created: 11 Aug 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perl
+PORTVERSION= 0.2.5
+CATEGORIES= lang # ruby
+MASTER_SITES= http://www.bekkoame.ne.jp/~yoshidam/
+PKGNAMEPREFIX= ruby-
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+INSTALL_TARGET= site-install
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+USE_PERL5= yes
+
+RUBY= ${LOCALBASE}/bin/ruby
+RUBY_VER= 1.4
+RUBY_ARCH= ${ARCH}-freebsd${OSREL}
+
+EXAMPLES= htmlparse.rb http.rb perllib.rb ping.rb \
+ test.rb xmlparser.rb
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
+ @cd ${WRKSRC}/Ruby; \
+ ${PERL} Makefile.PL
+
+post-build:
+ @cd ${WRKSRC}/Ruby; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
+
+post-install:
+ @cd ${WRKSRC}/Ruby; \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} install
+ ${MKDIR} ${PREFIX}/share/examples/ruby/perl
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/samples/${f} ${PREFIX}/share/examples/ruby/perl/
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/ruby/perl/ja
+ ${INSTALL_DATA} ${WRKSRC}/README.ja ${PREFIX}/share/doc/ruby/perl/ja/
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/ruby-perl/distinfo b/lang/ruby-perl/distinfo
new file mode 100644
index 000000000000..96c28dea7d12
--- /dev/null
+++ b/lang/ruby-perl/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/perl-0.2.5.tar.gz) = e559aefca3e8a24475351e4df0be6232
diff --git a/lang/ruby-perl/pkg-comment b/lang/ruby-perl/pkg-comment
new file mode 100644
index 000000000000..3892e5de95ef
--- /dev/null
+++ b/lang/ruby-perl/pkg-comment
@@ -0,0 +1 @@
+A Ruby extension module to use the functions of Perl from Ruby
diff --git a/lang/ruby-perl/pkg-descr b/lang/ruby-perl/pkg-descr
new file mode 100644
index 000000000000..e9217e272b31
--- /dev/null
+++ b/lang/ruby-perl/pkg-descr
@@ -0,0 +1,5 @@
+This is a Ruby extension module to use the functions of Perl from Ruby.
+
+You can also call Ruby functions back from within the Perl code.
+
+WWW: http://www.bekkoame.ne.jp/~yoshidam/Ruby.html#perl
diff --git a/lang/ruby-perl/pkg-plist b/lang/ruby-perl/pkg-plist
new file mode 100644
index 000000000000..159092d0ea78
--- /dev/null
+++ b/lang/ruby-perl/pkg-plist
@@ -0,0 +1,16 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/perl.so
+share/examples/ruby/perl/htmlparse.rb
+share/examples/ruby/perl/http.rb
+share/examples/ruby/perl/perllib.rb
+share/examples/ruby/perl/ping.rb
+share/examples/ruby/perl/test.rb
+share/examples/ruby/perl/xmlparser.rb
+@dirrm share/examples/ruby/perl
+share/doc/ruby/perl/ja/README.ja
+@dirrm share/doc/ruby/perl/ja
+@dirrm share/doc/ruby/perl
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Ruby.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ruby/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ruby/Ruby.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ruby/Ruby.so
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Ruby