aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby-python
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-07 07:43:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-07 07:43:29 +0000
commitd5769b206fbb9de50356197d9530e02b1e17a5ed (patch)
tree9b881c91f4ee67dff185a93001a9c5f7b38230d2 /lang/ruby-python
parent1fa355ad263385a73305e7a1b85ce06f4b39bcda (diff)
downloadports-d5769b206fbb9de50356197d9530e02b1e17a5ed.tar.gz
ports-d5769b206fbb9de50356197d9530e02b1e17a5ed.zip
Notes
Diffstat (limited to 'lang/ruby-python')
-rw-r--r--lang/ruby-python/Makefile36
-rw-r--r--lang/ruby-python/pkg-plist52
2 files changed, 43 insertions, 45 deletions
diff --git a/lang/ruby-python/Makefile b/lang/ruby-python/Makefile
index 0c05374cb976..fe38d9675df5 100644
--- a/lang/ruby-python/Makefile
+++ b/lang/ruby-python/Makefile
@@ -9,37 +9,35 @@ PORTNAME= python
PORTVERSION= 0.3.2
CATEGORIES= lang ruby python
MASTER_SITES= http://www.goto.info.waseda.ac.jp/~fukusima/ruby/
-PKGNAMEPREFIX= ruby-
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
-BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
- python:${PORTSDIR}/lang/python
-RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby \
- python:${PORTSDIR}/lang/python
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
-WRKSRC= ${WRKDIR}/${PORTNAME}
-PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
-RUBY?= ${LOCALBASE}/bin/ruby
-RUBY_VER?= 1.4
-RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_TARGET= site-install
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb; \
- ${PERL} -i -pe 's/-lc\b/-lc_r/g' Makefile
+post-configure:
+ ${PERL} -i -pe 's/-lc\b/-lc_r/g' ${WRKSRC}/Makefile
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/examples/ruby/python/Lib
- ${MKDIR} ${PREFIX}/share/doc/ruby/python/ja
- cd ${WRKSRC}/examples; find . -exec ${INSTALL_DATA} {} ${PREFIX}/share/examples/ruby/python/{} \;
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/python/Lib
+ ${MKDIR} ${RUBY_DOCDIR}/python/ja
+ cd ${WRKSRC}/examples; find . -exec ${INSTALL_DATA} {} ${RUBY_EXAMPLESDIR}/python/{} \;
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README ${WRKSRC}/doc/* \
- ${PREFIX}/share/doc/ruby/python/
+ ${RUBY_DOCDIR}/python/
${INSTALL_DATA} ${WRKSRC}/README.ja ${WRKSRC}/doc-ja/* \
- ${PREFIX}/share/doc/ruby/python/ja/
+ ${RUBY_DOCDIR}/python/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.ruby.mk"
+.include <bsd.port.post.mk>
diff --git a/lang/ruby-python/pkg-plist b/lang/ruby-python/pkg-plist
index 142c1bb3d3c3..b702d7191efa 100644
--- a/lang/ruby-python/pkg-plist
+++ b/lang/ruby-python/pkg-plist
@@ -1,26 +1,26 @@
-lib/ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/python.so
-share/examples/ruby/python/Lib/BaseHTTPServer.rb
-share/examples/ruby/python/Lib/README
-share/examples/ruby/python/Lib/base64.rb
-share/examples/ruby/python/Lib/rfc822.rb
-share/examples/ruby/python/Lib/urllib.rb
-share/examples/ruby/python/hello.rb
-share/examples/ruby/python/html.py
-share/examples/ruby/python/html.rb
-share/doc/ruby/python/ja/README.ja
-share/doc/ruby/python/ja/Mapping.html
-share/doc/ruby/python/ja/Object.html
-share/doc/ruby/python/ja/Py.html
-share/doc/ruby/python/ja/Sequence.html
-share/doc/ruby/python/ja/index.html
-share/doc/ruby/python/ChangeLog
-share/doc/ruby/python/README
-share/doc/ruby/python/Mapping.html
-share/doc/ruby/python/Object.html
-share/doc/ruby/python/Py.html
-share/doc/ruby/python/Sequence.html
-share/doc/ruby/python/index.html
-@dirrm share/examples/ruby/python/Lib
-@dirrm share/examples/ruby/python
-@dirrm share/doc/ruby/python/ja
-@dirrm share/doc/ruby/python
+%%RUBY_SITEARCHLIBDIR%%/python.so
+%%RUBY_EXAMPLESDIR%%/python/Lib/BaseHTTPServer.rb
+%%RUBY_EXAMPLESDIR%%/python/Lib/README
+%%RUBY_EXAMPLESDIR%%/python/Lib/base64.rb
+%%RUBY_EXAMPLESDIR%%/python/Lib/rfc822.rb
+%%RUBY_EXAMPLESDIR%%/python/Lib/urllib.rb
+%%RUBY_EXAMPLESDIR%%/python/hello.rb
+%%RUBY_EXAMPLESDIR%%/python/html.py
+%%RUBY_EXAMPLESDIR%%/python/html.rb
+%%RUBY_DOCDIR%%/python/ja/README.ja
+%%RUBY_DOCDIR%%/python/ja/Mapping.html
+%%RUBY_DOCDIR%%/python/ja/Object.html
+%%RUBY_DOCDIR%%/python/ja/Py.html
+%%RUBY_DOCDIR%%/python/ja/Sequence.html
+%%RUBY_DOCDIR%%/python/ja/index.html
+%%RUBY_DOCDIR%%/python/ChangeLog
+%%RUBY_DOCDIR%%/python/README
+%%RUBY_DOCDIR%%/python/Mapping.html
+%%RUBY_DOCDIR%%/python/Object.html
+%%RUBY_DOCDIR%%/python/Py.html
+%%RUBY_DOCDIR%%/python/Sequence.html
+%%RUBY_DOCDIR%%/python/index.html
+@dirrm %%RUBY_EXAMPLESDIR%%/python/Lib
+@dirrm %%RUBY_EXAMPLESDIR%%/python
+@dirrm %%RUBY_DOCDIR%%/python/ja
+@dirrm %%RUBY_DOCDIR%%/python