aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby16_static
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-11-18 12:02:29 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-11-18 12:02:29 +0000
commitae6dcb78fd1aa71840b40b56f6622f44dc213237 (patch)
treea2173fc80df951c850d38e436c1a3dd095dfdf27 /lang/ruby16_static
parent1cf467c8c2b56b26f2d056624e16288f9ee311ef (diff)
downloadports-ae6dcb78fd1aa71840b40b56f6622f44dc213237.tar.gz
ports-ae6dcb78fd1aa71840b40b56f6622f44dc213237.zip
Notes
Diffstat (limited to 'lang/ruby16_static')
-rw-r--r--lang/ruby16_static/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 70c60180121b..478be452c035 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -46,7 +46,8 @@ WRKSRC= ${RUBY_WRKSRC}
DESCR= ${_RUBY_PORTDIR}/pkg-descr
# You can build a totally statically linked binary by defining STATIC,
-# although it is not capable of loading dynamic modules.
+# although the resulted interpreter is not capable of loading dynamic
+# modules.
CONFIGURE_ENV= XLDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS!= cd ${_RUBY_PORTDIR} && ${MAKE} -V CONFIGURE_ARGS
@@ -59,7 +60,11 @@ CONFIGURE_ARGS:= ${CONFIGURE_ARGS:M-*} \
--with-opt-dir="${LOCALBASE}"
.endif
-MAKE_ENV= LANG=C # prevent bison 1.33 w/ gettext 0.10.35 from coredumping
+.if defined(DEBUG)
+CFLAGS+= -g
+STRIP= # none
+.endif
+
MAKE_ARGS= -j3
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}