aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby16_static
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-04-26 21:17:35 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-04-26 21:17:35 +0000
commita23c4abe670c55f33412c7bd281917d81b213a55 (patch)
treebde2a6ad07b32274bae928df62c950c23278fdc1 /lang/ruby16_static
parentf7bdeed669c88aedec1451a4d02f30118462cf45 (diff)
downloadports-a23c4abe670c55f33412c7bd281917d81b213a55.tar.gz
ports-a23c4abe670c55f33412c7bd281917d81b213a55.zip
Notes
Diffstat (limited to 'lang/ruby16_static')
-rw-r--r--lang/ruby16_static/Makefile1
-rw-r--r--lang/ruby16_static/files/patch-ext+bdb1+extconf.rb25
-rw-r--r--lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb11
3 files changed, 37 insertions, 0 deletions
diff --git a/lang/ruby16_static/Makefile b/lang/ruby16_static/Makefile
index 1c5afd093bda..e9670bebc1f0 100644
--- a/lang/ruby16_static/Makefile
+++ b/lang/ruby16_static/Makefile
@@ -33,6 +33,7 @@ LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
.if ${RUBY_VER} < 1.7
EXT_PORTS+= ${RUBY_SHIM18_PORT}
+EXTRA_PATCHES= ${PATCHDIR}/ruby16-patch-*
.else
EXT_PORTS+= converters/ruby-iconv
.endif
diff --git a/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb b/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb
new file mode 100644
index 000000000000..b49410f5700c
--- /dev/null
+++ b/lang/ruby16_static/files/patch-ext+bdb1+extconf.rb
@@ -0,0 +1,25 @@
+--- ext/bdb1/extconf.rb.orig Fri Dec 27 22:32:58 2002
++++ ext/bdb1/extconf.rb Sun Apr 27 05:35:25 2003
+@@ -1,9 +1,10 @@
+ #!/usr/bin/ruby
+ require 'mkmf'
++require 'rbconfig'
+
+-$stat_lib = if CONFIG.key?("LIBRUBYARG_STATIC")
++$stat_lib = if Config::CONFIG.key?("LIBRUBYARG_STATIC")
+ $LDFLAGS += " -L#{CONFIG['libdir']}"
+- CONFIG["LIBRUBYARG_STATIC"]
++ Config::CONFIG["LIBRUBYARG_STATIC"]
+ else
+ "-lruby"
+ end
+@@ -40,8 +41,7 @@
+
+ unknown: $(DLLIB)
+ \t@echo "main() {}" > /tmp/a.c
+-\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{CONFIG["LIBS"
+-]} $(LIBS) $(LOCAL_LIBS)
++\t$(CC) -static /tmp/a.c $(OBJS) $(CPPFLAGS) $(DLDFLAGS) #$stat_lib #{Config::CONFIG["LIBS"]} $(LIBS) $(LOCAL_LIBS)
+ \t@-rm /tmp/a.c a.out
+
+ test: $(DLLIB)
diff --git a/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb b/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb
new file mode 100644
index 000000000000..3ff097f28f02
--- /dev/null
+++ b/lang/ruby16_static/files/ruby16-patch-ext+zlib+extconf.rb
@@ -0,0 +1,11 @@
+--- ext/zlib/extconf.rb.orig Fri Mar 28 11:24:47 2003
++++ ext/zlib/extconf.rb Sun Apr 27 05:56:22 2003
+@@ -24,7 +24,7 @@
+ oldlibs = $libs
+ oldlibpath = $LIBPATH
+ $libs += " " + Config::CONFIG['LIBRUBYARG']
+- $LIBPATH = [$libdir, $archdir] | $LIBPATH
++ $LIBPATH = [$libdir, $archdir || Config::CONFIG["compile_dir"]] | $LIBPATH
+ begin
+ have_func s, 'ruby.h'
+ rescue ArgumentError # for ruby-1.4