aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-05-05 23:20:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-05-05 23:20:12 +0000
commit90d3bb570de87ad7dfa62408de29ed73f269148d (patch)
tree05f6956383a16ce5b8208855f5dd2ef2c5627310 /lang/ruby18/Makefile
parenta0d1a4b8f09149f6d427b8367394a412f02e0482 (diff)
downloadports-90d3bb570de87ad7dfa62408de29ed73f269148d.tar.gz
ports-90d3bb570de87ad7dfa62408de29ed73f269148d.zip
Notes
Diffstat (limited to 'lang/ruby18/Makefile')
-rw-r--r--lang/ruby18/Makefile102
1 files changed, 102 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
new file mode 100644
index 000000000000..a3adc82061b9
--- /dev/null
+++ b/lang/ruby18/Makefile
@@ -0,0 +1,102 @@
+# New ports collection makefile for: ruby-devel
+# Date created: 6 May 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ruby
+PORTVERSION= ${RUBY_PORTVERSION}
+CATEGORIES= lang ruby ipv6
+MASTER_SITES= http://www.ruby-lang.org/~knu/ # ${MASTER_SITE_RUBY}
+MASTER_SITE_SUBDIR= ${RUBY_VER}
+DISTNAME= ${RUBY_DISTNAME}
+DIST_SUBDIR= ruby
+
+PATCH_SITES= http://www.ruby-lang.org/~knu/
+PATCHFILES= ${RUBY_DISTNAME}-${RUBY_PATCHLEVEL}.patch.gz
+PATCH_DIST_STRIP= -p1
+
+MAINTAINER= knu@FreeBSD.org
+
+RUBY_VER= 1.7
+
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+RUBY_NO_RUN_DEPENDS= yes
+
+USE_AUTOCONF= yes
+INSTALLS_SHLIB= yes
+WRKSRC= ${RUBY_WRKSRC}
+CONFIGURE_ARGS= --enable-shared
+MAN1= ruby${_RUBY_SUFFIX}.1
+MLINKS= ruby${_RUBY_SUFFIX}.1 ruby.1
+
+.include <bsd.port.pre.mk>
+
+.if !empty(RUBY_SUFFIX)
+CONFIGURE_ARGS+= --program-suffix="${RUBY_SUFFIX}"
+.endif
+
+.if ${OSVERSION} >= 400014
+CONFIGURE_ARGS+= --enable-ipv6
+.endif
+
+IRB= ${LOCALBASE}/bin/irb
+
+post-patch:
+ find ${WRKSRC} -name '*.orig' -delete
+.for d in Win32API
+ ${RM} -rf ${WRKSRC}/ext/${d}
+.endfor
+.for d in gdbm tcltklib tk
+ ${MV} ${WRKSRC}/ext/${d} ${WRKDIR}/
+.endfor
+
+post-install:
+.if ${STRIP} == -s
+ strip ${RUBY}
+.endif
+.if empty(RUBY_SUFFIX)
+ ${MV} -f ${RUBY} ${RUBY_WITH_SUFFIX}
+ ${LN} -fs ${RUBY_WITH_SUFFIX} ${RUBY}
+ ${MV} ${PREFIX}/man/man1/ruby.1 ${PREFIX}/man/man1/ruby${_RUBY_SUFFIX}.1
+.else
+ ${LN} -fs ${RUBY} ${PREFIX}/bin/ruby
+.endif
+ ${RUBY} ${RUBY_FLAGS} -i -p \
+ -e 'if $$. == 1; ' \
+ -e ' if /^#!/; ' \
+ -e ' sub /^#!\s*\S*(\benv\s+)?\bruby/, "#!${RUBY_WITH_SUFFIX}";' \
+ -e ' else;' \
+ -e ' $$_ = "#!${RUBY_WITH_SUFFIX}\n" + $$_;' \
+ -e ' end;' \
+ -e 'end' \
+ ${IRB}
+ ${MV} -f ${IRB} ${IRB}${_RUBY_SUFFIX}
+ ${LN} -fs ${IRB}${_RUBY_SUFFIX} ${IRB}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/curses
+ ${INSTALL_DATA} ${WRKSRC}/ext/curses/hello.rb ${WRKSRC}/ext/curses/rain.rb ${WRKSRC}/ext/curses/view.rb ${RUBY_EXAMPLESDIR}/curses
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/pty
+ ${INSTALL_DATA} ${WRKSRC}/ext/pty/expect_sample.rb ${WRKSRC}/ext/pty/script.rb ${WRKSRC}/ext/pty/shl.rb ${RUBY_EXAMPLESDIR}/pty
+ ${MKDIR} ${RUBY_DOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README* ${RUBY_DOCDIR}
+ ${MKDIR} ${RUBY_DOCDIR}/etc
+ ${INSTALL_DATA} ${WRKSRC}/ext/etc/etc.txt* ${RUBY_DOCDIR}/etc
+ ${MKDIR} ${RUBY_DOCDIR}/md5
+ ${INSTALL_DATA} ${WRKSRC}/ext/md5/md5.txt* ${RUBY_DOCDIR}/md5
+ ${MKDIR} ${RUBY_DOCDIR}/pty
+ ${INSTALL_DATA} ${WRKSRC}/ext/pty/README* ${RUBY_DOCDIR}/pty
+ ${MKDIR} ${RUBY_DOCDIR}/readline
+ ${INSTALL_DATA} ${WRKSRC}/ext/readline/README ${RUBY_DOCDIR}/readline
+ ${CP} -R ${WRKSRC}/doc/irb ${RUBY_DOCDIR}/
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+test:
+ @(cd ${WRKSRC}; ${MAKE} test)
+
+.include <bsd.port.post.mk>