aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2006-11-19 23:39:00 +0000
committerStanislav Sedov <stas@FreeBSD.org>2006-11-19 23:39:00 +0000
commit45a7b73bebaa845b54169a68c1989c575b17c422 (patch)
tree1500af3a9d6653ba6d6e0faabb47fe6d4f70a935 /lang/ruby18/Makefile
parent0637d1df991ef736be8d2fbcb3f3318d6f574a36 (diff)
downloadports-45a7b73bebaa845b54169a68c1989c575b17c422.tar.gz
ports-45a7b73bebaa845b54169a68c1989c575b17c422.zip
Notes
Diffstat (limited to 'lang/ruby18/Makefile')
-rw-r--r--lang/ruby18/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 25d24c70c8dd..6d73963f6b94 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -40,10 +40,11 @@ OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
.include <bsd.port.pre.mk>
PKGNAMESUFFIX= #empty
+CFLAGS+= ${PTHREAD_CFLAGS} # Keep this, else ruby will fail to load
+LDFLAGS+= ${PTHREAD_LIBS} # libraries dependent op libpthread.
+
.if defined(WITH_PTHREADS)
CONFIGURE_ARGS+=--enable-pthread
-CFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+pthreads
.else
CONFIGURE_ARGS+=--disable-pthread