aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-01-12 11:19:20 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-01-12 11:19:20 +0000
commitac4392578ecdf28b0ad5223e3521cf51af50db1e (patch)
tree31b6928ae3c87885ebed3cd6a2f2d2b16f2984e3 /lang/ruby18
parent9f0ecef3ca9f773bbfc21d9a01540041039e5abd (diff)
downloadports-ac4392578ecdf28b0ad5223e3521cf51af50db1e.tar.gz
ports-ac4392578ecdf28b0ad5223e3521cf51af50db1e.zip
Notes
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile4
-rw-r--r--lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h13
2 files changed, 17 insertions, 0 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 546233d2a967..ec8154bdb83f 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -34,6 +34,10 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
_RUBY_SYSLIBDIR= ${PREFIX}/lib
+.ifdef(WITH_OPENSSL_PORT)
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ext_openssl_openssl_missing.h
+.endif
+
OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
ONIGURUMA "Build with oniguruma regular expressions lib" off \
GCPATCH "Build with GC performance statistics collector" off \
diff --git a/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h b/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h
new file mode 100644
index 000000000000..06cf6959223e
--- /dev/null
+++ b/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h
@@ -0,0 +1,13 @@
+--- ext/openssl/openssl_missing.h.orig 2009-01-11 20:16:56.000000000 -0500
++++ ext/openssl/openssl_missing.h 2009-01-11 20:17:30.000000000 -0500
+@@ -120,8 +120,8 @@
+ int BN_mod_sqr(BIGNUM *r, const BIGNUM *a, const BIGNUM *m, BN_CTX *ctx);
+ int BN_mod_add(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
+ int BN_mod_sub(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
+-int BN_rand_range(BIGNUM *r, BIGNUM *range);
+-int BN_pseudo_rand_range(BIGNUM *r, BIGNUM *range);
++int BN_rand_range(BIGNUM *r, const BIGNUM *range);
++int BN_pseudo_rand_range(BIGNUM *r, const BIGNUM *range);
+ char *CONF_get1_default_config_file(void);
+ int PEM_def_callback(char *buf, int num, int w, void *key);
+