aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby18
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-12 17:54:27 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-12 17:54:27 +0000
commita9c25292b7f66e04413943c96c84d68707101c0d (patch)
tree98f1b4515dafba02f3810f2a21a3aa935660ab24 /lang/ruby18
parent8605363e105abd4a638eecf4872d8dedf5b86d58 (diff)
downloadports-a9c25292b7f66e04413943c96c84d68707101c0d.tar.gz
ports-a9c25292b7f66e04413943c96c84d68707101c0d.zip
Notes
Diffstat (limited to 'lang/ruby18')
-rw-r--r--lang/ruby18/Makefile6
-rw-r--r--lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h13
2 files changed, 0 insertions, 19 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index 2fbdf8fe324a..90d8f3412547 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -34,12 +34,6 @@ RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
_RUBY_SYSLIBDIR= ${PREFIX}/lib
-.ifdef(WITH_OPENSSL_PORT)
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-ext_openssl_openssl_missing.h
-.else
-WITH_OPENSSL_BASE= yes # prefer base openssl
-.endif
-
OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
ONIGURUMA "Build with oniguruma regular expressions lib" off \
GCPATCH "Build with GC performance statistics collector" off \
diff --git a/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h b/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h
deleted file mode 100644
index 06cf6959223e..000000000000
--- a/lang/ruby18/files/extra-patch-ext_openssl_openssl_missing.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- ext/openssl/openssl_missing.h.orig 2009-01-11 20:16:56.000000000 -0500
-+++ ext/openssl/openssl_missing.h 2009-01-11 20:17:30.000000000 -0500
-@@ -120,8 +120,8 @@
- int BN_mod_sqr(BIGNUM *r, const BIGNUM *a, const BIGNUM *m, BN_CTX *ctx);
- int BN_mod_add(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
- int BN_mod_sub(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
--int BN_rand_range(BIGNUM *r, BIGNUM *range);
--int BN_pseudo_rand_range(BIGNUM *r, BIGNUM *range);
-+int BN_rand_range(BIGNUM *r, const BIGNUM *range);
-+int BN_pseudo_rand_range(BIGNUM *r, const BIGNUM *range);
- char *CONF_get1_default_config_file(void);
- int PEM_def_callback(char *buf, int num, int w, void *key);
-