aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby19/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-02-09 17:49:51 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-02-09 17:49:51 +0000
commitffe7a6123957624b12dfcc9429855fe9271e2a72 (patch)
tree0cf78d1ff1f42d5ab3b9359816e6739a6b194528 /lang/ruby19/Makefile
parentf35b39863aef0ecfeaacc983cca41d91ebd53170 (diff)
Notes
Diffstat (limited to 'lang/ruby19/Makefile')
-rw-r--r--lang/ruby19/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/ruby19/Makefile b/lang/ruby19/Makefile
index f8e9a3686ae8..9df2fe1ecebf 100644
--- a/lang/ruby19/Makefile
+++ b/lang/ruby19/Makefile
@@ -23,7 +23,10 @@ WRKSRC= ${RUBY_WRKSRC}
CONFIGURE_ARGS= ${RUBY_CONFIGURE_ARGS} \
--enable-shared \
--enable-pthread \
- --with-openssl-include=${OPENSSLINC}
+ --with-openssl-include=${OPENSSLINC} \
+ --with-ruby-version=minor \
+ --with-sitedir="${PREFIX}/lib/ruby/site_ruby" \
+ --with-vendordir="${PREFIX}/lib/ruby/vendor_ruby"
USE_OPENSSL= yes
USE_LDCONFIG= yes
@@ -102,7 +105,8 @@ EXTDOCS= bigdecimal/bigdecimal_*.html \
syslog/syslog.txt \
zlib/doc/zlib.rd
-MAN1= ${RUBY_NAME}.1
+MAN1= ${RUBY_NAME}.1 erb${RUBY_SUFFIX}.1 irb${RUBY_SUFFIX}.1 \
+ rake${RUBY_SUFFIX}.1 ri${RUBY_SUFFIX}.1
# Macros to change variables in rbconfig.rb
RB_SET_CONF_VAR=${SH} -c '${REINPLACE_CMD} -E -e "s,(CONFIG\[\"$$0\"\][[:space:]]*=[[:space:]]*)(\(?)(.*)(\)?),\1\2$$1\4," ${WRKSRC}/rbconfig.rb' --
@@ -223,9 +227,9 @@ plist::
# Includes
#
@${FIND} -ds ${PREFIX}/include/ruby-${RUBY_VER} ! -type d | \
- ${SED} 's,^${PREFIX},,' >> pkg-plist
+ ${SED} 's,^${PREFIX}/*,,' >> pkg-plist
@${FIND} -ds ${PREFIX}/include/ruby-${RUBY_VER} -type d | \
- ${SED} 's,^${PREFIX},@dirrm ,' >> pkg-plist
+ ${SED} 's,^${PREFIX}/*,@dirrm ,' >> pkg-plist
#
# Vendor and site libs