aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby23/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2017-10-13 20:32:20 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2017-10-13 20:32:20 +0000
commit08b84627d6c7969de8fbde8e9eff37cafa725a77 (patch)
tree3dc12b8daa9154a3a26ce086f19a157b83cb95e2 /lang/ruby23/Makefile
parenta9fdad69d9d5dcc660877d9f014de30ec58b1351 (diff)
Mark MAKE_JOBS_UNSAFE
- - - loadpath.o --- loadpath.c:30:2: error: RUBY_EXEC_PREFIX must be defined #error RUBY_EXEC_PREFIX must be defined ^ loadpath.c:41:50: error: use of undeclared identifier 'RUBY_LIB_VERSION' typedef char ruby_lib_version_string[(int)sizeof(RUBY_LIB_VERSION) - 2]; ^ loadpath.c:59:33: error: use of undeclared identifier 'RUBY_EXEC_PREFIX' const char ruby_exec_prefix[] = RUBY_EXEC_PREFIX; ^ loadpath.c:68:5: error: use of undeclared identifier 'RUBY_EXEC_PREFIX' RUBY_SITE_LIB2 "\0" ^ loadpath.c:46:37: note: expanded from macro 'RUBY_SITE_LIB2' #define RUBY_SITE_LIB2 RUBY_SITE_LIB "/"RUBY_LIB_VERSION ^ loadpath.c:35:23: note: expanded from macro 'RUBY_SITE_LIB' #define RUBY_SITE_LIB RUBY_LIB_PREFIX"/site_ruby" ^ loadpath.c:32:25: note: expanded from macro 'RUBY_LIB_PREFIX' #define RUBY_LIB_PREFIX RUBY_EXEC_PREFIX"/lib/ruby" ^ loadpath.c:68:5: error: expected ';' after top level declarator loadpath.c:46:37: note: expanded from macro 'RUBY_SITE_LIB2' #define RUBY_SITE_LIB2 RUBY_SITE_LIB "/"RUBY_LIB_VERSION ^ loadpath.c:35:23: note: expanded from macro 'RUBY_SITE_LIB' #define RUBY_SITE_LIB RUBY_LIB_PREFIX"/site_ruby" ^ loadpath.c:32:41: note: expanded from macro 'RUBY_LIB_PREFIX' #define RUBY_LIB_PREFIX RUBY_EXEC_PREFIX"/lib/ruby" ^ 5 errors generated. *** [loadpath.o] Error code 1
Notes
Notes: svn path=/head/; revision=452030
Diffstat (limited to 'lang/ruby23/Makefile')
-rw-r--r--lang/ruby23/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/lang/ruby23/Makefile b/lang/ruby23/Makefile
index 6c1fb05c19f6..b43c65e37feb 100644
--- a/lang/ruby23/Makefile
+++ b/lang/ruby23/Makefile
@@ -73,6 +73,10 @@ CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}
CPE_UPDATE= p${RUBY_PATCHLEVEL}
+# --- loadpath.o ---
+# loadpath.c:30:2: error: RUBY_EXEC_PREFIX must be defined
+MAKE_JOBS_UNSAFE=yes
+
.include <bsd.port.pre.mk>
# PORTREVISION/PORTEPOCH hack