aboutsummaryrefslogtreecommitdiff
path: root/lang/ruby_static
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-03-30 10:10:36 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-03-30 10:10:36 +0000
commit9477c6e16cf2fd0918ee65ae1843d1c6235f47a4 (patch)
tree193e8ea92ee9e3165ddd5bef24c5dcc7c09fe7e8 /lang/ruby_static
parent0be35ce44505a21d95e2cc5621c0cb62dafa3b54 (diff)
downloadports-9477c6e16cf2fd0918ee65ae1843d1c6235f47a4.tar.gz
ports-9477c6e16cf2fd0918ee65ae1843d1c6235f47a4.zip
Notes
Diffstat (limited to 'lang/ruby_static')
-rw-r--r--lang/ruby_static/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/lang/ruby_static/Makefile b/lang/ruby_static/Makefile
index 7932ed5e6c15..f4cdcba1620a 100644
--- a/lang/ruby_static/Makefile
+++ b/lang/ruby_static/Makefile
@@ -18,8 +18,6 @@ BUILD_DEPENDS= ${NONEXISTENT}:${.CURDIR}/../../${RUBY_PORT}:patch
USE_RUBY= yes
-USE_AUTOCONF= yes
-
# Beware, because gdbm is under GPL, you must treat the whole binary
# as GPL says if you include gdbm in it.
EXT_PORTS= archivers/ruby-zlib \
@@ -36,6 +34,19 @@ EXT_PORTS+= devel/ruby-fnmatch
BUILD_DEPENDS+= ${NONEXISTENT}:${_PORTSDIR}/${p}:patch
.endfor
+.if defined(RUBY_VER)
+.if ${RUBY_VER} > 1.6
+NEWAUTOCONF= yes
+.endif
+.endif
+
+.if defined(NEWAUTOCONF)
+BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
+GNU_CONFIGURE= yes
+.else
+USE_AUTOCONF= yes
+.endif
+
WRKSRC= ${RUBY_WRKSRC}
DESCR= ${_RUBY_PORTDIR}/pkg-descr
@@ -95,6 +106,11 @@ do-extract:
(cd ${WRKSRC}/ext && \
for x in *; do [ -d $$x ] && echo $$x >> Setup; done)
+.if defined(NEWAUTOCONF)
+pre-configure:
+ cd ${WRKSRC}; autoconf
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${RUBY_NAME} ${RUBY_WITH_SUFFIX}_s
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}