aboutsummaryrefslogtreecommitdiff
path: root/lang/rust-bootstrap
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-09-02 18:15:58 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-09-02 18:15:58 +0000
commitcd8ca9f2f5c5a2cf85e0ab43ffe64c08aeef7433 (patch)
tree279c5fc62f940096d70ad8ce99990218851e112d /lang/rust-bootstrap
parent3a2ec6d49129f2abf1b9d9ef1341e75d0fd93ced (diff)
Notes
Diffstat (limited to 'lang/rust-bootstrap')
-rw-r--r--lang/rust-bootstrap/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 1a9077113b4b..1491d472ff22 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -146,6 +146,8 @@ do-configure:
.else
@${ECHO_CMD} 'ccache=false' >> ${WRKSRC}/config.toml
.endif
+# https://github.com/rust-lang/rust/pull/72696#issuecomment-641517185
+ @${ECHO_CMD} 'ldflags="-lz"' >> ${WRKSRC}/config.toml
# we need to make sure to always build llvm with X86 support to get a
# host compiler that can build the host->target compiler
@${ECHO_CMD} 'targets="${_RUST_LLVM_TARGET};X86"' >> ${WRKSRC}/config.toml