aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-03-19 07:05:29 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-03-19 07:05:29 +0000
commit95ebc1c533e70edc269d17b11eaddf61cda1d4ff (patch)
tree0718a25685618d94fc564055ab8cbef88c8d8a30 /lang/rust
parent8b695b5c536ee871be831eb5536b5fbe8bae47e9 (diff)
downloadports-95ebc1c533e70edc269d17b11eaddf61cda1d4ff.tar.gz
ports-95ebc1c533e70edc269d17b11eaddf61cda1d4ff.zip
lang/rust-nightly: Update to 1.44.0.20200319
Go back to system libgit2 now that it was updated to 0.99.0. Changes: https://github.com/rust-lang/rust/compare/96bb8b31c8...f509b26a77
Notes
Notes: svn path=/head/; revision=528690
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 14be62ffa02f..490ef8afde26 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -29,20 +29,16 @@ ONLY_FOR_ARCHS?= aarch64 amd64 armv6 armv7 i386 powerpc64
ONLY_FOR_ARCHS_REASON?= requires prebuilt bootstrap compiler
BUILD_DEPENDS= cmake:devel/cmake
-LIB_DEPENDS= libcurl.so:ftp/curl
-.if !defined(NIGHTLY_DATE)
-LIB_DEPENDS+= libgit2.so:devel/libgit2 \
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libgit2.so:devel/libgit2 \
libssh2.so:security/libssh2
-.endif
USES= pkgconfig python:3.3+,build ssl tar:xz
-MAKE_ENV= OPENSSL_DIR="${OPENSSLBASE}" \
+MAKE_ENV= LIBGIT2_SYS_USE_PKG_CONFIG=1 \
+ LIBSSH2_SYS_USE_PKG_CONFIG=1 \
+ OPENSSL_DIR="${OPENSSLBASE}" \
RUST_BACKTRACE=1
-.if !defined(NIGHTLY_DATE)
-MAKE_ENV+= LIBGIT2_SYS_USE_PKG_CONFIG=1 \
- LIBSSH2_SYS_USE_PKG_CONFIG=1
-.endif
TEST_ENV= ${MAKE_ENV} \
ALLOW_NONZERO_RLIMIT_CORE=1