aboutsummaryrefslogtreecommitdiff
path: root/lang/rust
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-06-08 23:31:35 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-06-08 23:31:35 +0000
commit8a62f1221efa3f8edde5c96ddeaebd7e9b7958ba (patch)
treeb64274e57e9fbbd1b2567462c7f9dd42bef30347 /lang/rust
parentb36f1444881739301c40ea16f84744ce6e039ba2 (diff)
downloadports-8a62f1221efa3f8edde5c96ddeaebd7e9b7958ba.tar.gz
ports-8a62f1221efa3f8edde5c96ddeaebd7e9b7958ba.zip
Notes
Diffstat (limited to 'lang/rust')
-rw-r--r--lang/rust/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 83df9263217a..755388539c7b 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -333,6 +333,14 @@ do-test:
--config ./config.toml \
--jobs ${MAKE_JOBS_NUMBER}
+makesum-all-archs:
+ ${MAKE} makesum ARCH=${ONLY_FOR_ARCHS:[1]}
+.for arch in ${ONLY_FOR_ARCHS:[2..-1]}
+ ${MAKE} makesum ARCH=${arch} DISTINFO_FILE=${DISTINFO_FILE}.${arch}
+ ${GREP} ${RUST_ARCH_${arch}} ${DISTINFO_FILE}.${arch} >> ${DISTINFO_FILE}
+ ${RM} ${DISTINFO_FILE}.${arch}
+.endfor
+
BOOTSTRAPS_SOURCE_PKG_FBSDVER= 10
BOOTSTRAPS_SOURCE_PKG_FBSDVER_aarch64= 11
BOOTSTRAPS_SOURCE_PKG_REV=