aboutsummaryrefslogtreecommitdiff
path: root/lang/sbcl/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-10-14 22:02:54 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-10-14 22:02:54 +0000
commit4669a758ce48f578e194c19fc000247abe98f9b3 (patch)
treeb2efce27d16885b35b579de6502ee0f47497e470 /lang/sbcl/Makefile
parent35e9ecb58e1e15c78fe247871b6f4dc2c0386471 (diff)
downloadports-4669a758ce48f578e194c19fc000247abe98f9b3.tar.gz
ports-4669a758ce48f578e194c19fc000247abe98f9b3.zip
Notes
Diffstat (limited to 'lang/sbcl/Makefile')
-rw-r--r--lang/sbcl/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/lang/sbcl/Makefile b/lang/sbcl/Makefile
index 7bfd3fdec10d..57f491b6118e 100644
--- a/lang/sbcl/Makefile
+++ b/lang/sbcl/Makefile
@@ -9,13 +9,13 @@
#
PORTNAME= sbcl
-PORTVERSION= 1.0.30.0
+PORTVERSION= 1.0.31.0
PORTREVISION= 0
CATEGORIES= lang lisp
-#MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
-# ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
-MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R} \
ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
+#MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/ \
+# ftp://ftp.SpringDaemons.com/soft/sbcl-binary/:binaries
#MASTER_SITE_SUBDIR= sbcl/${PORTVERSION:R}
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-source${SBCLPATCHLEVEL}
@@ -38,6 +38,7 @@ INFO= asdf sbcl
INFODIR= ${PREFIX}/${INFO_PATH}
OSVER_MAJOR= ${OSVERSION:C/([0-9]).*/\1/}
+NEWBOOTNAME= ${PORTNAME}-${PORTVERSION:R}-${ARCH}-freebsd${OSVER_MAJOR}
.if ${PORTVERSION:E} == 0
SBCLPATCHLEVEL= #empty
@@ -71,7 +72,11 @@ BOOT_VERSION= 1.0.17
BOOT_ARCH_OS_LIST= amd64-freebsd8 amd64-freebsd7 amd64-freebsd6 \
i386-freebsd8 i386-freebsd7 i386-freebsd6
. else
+. if ${OSVER_MAJOR} == 9 # We'll use 8.x bootstrap for now
+BOOT_ARCH_OS_LIST= ${ARCH}-freebsd8
+. else
BOOT_ARCH_OS_LIST= ${ARCH}-freebsd${OSVER_MAJOR}
+. endif
. endif
. if ${ARCH} == "i386"
@@ -128,4 +133,10 @@ post-install:
test: build
(cd ${WRKSRC}/tests && ${SH} run-tests.sh)
+bootstrap:
+ ${CP} -r ${WRKSRC} ${WRKDIR}/${NEWBOOTNAME}
+ (cd ${WRKDIR}/ && \
+ ${WRKDIR}/${NEWBOOTNAME}/binary-distribution.sh ${NEWBOOTNAME})
+ (cd ${WRKDIR}/ && ${BZIP2_CMD} ${NEWBOOTNAME}-binary.tar)
+
.include <bsd.port.post.mk>