aboutsummaryrefslogtreecommitdiff
path: root/lang/scriba
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 19:45:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 19:45:31 +0000
commit17ef39558429b0639cea497bc22a6ab877d62447 (patch)
tree0b4b4698fd52f9b91863a0c20590da3a7a3123a0 /lang/scriba
parentf3395d96cc0fc5264a9d43cb66758dbc6445e78c (diff)
downloadports-17ef39558429b0639cea497bc22a6ab877d62447.tar.gz
ports-17ef39558429b0639cea497bc22a6ab877d62447.zip
Notes
Diffstat (limited to 'lang/scriba')
-rw-r--r--lang/scriba/Makefile45
-rw-r--r--lang/scriba/distinfo1
-rw-r--r--lang/scriba/files/patch-aa29
-rw-r--r--lang/scriba/files/patch-ab11
-rw-r--r--lang/scriba/files/patch-ac11
-rw-r--r--lang/scriba/files/patch-ad11
-rw-r--r--lang/scriba/files/patch-ae28
-rw-r--r--lang/scriba/files/patch-af58
-rw-r--r--lang/scriba/files/patch-ag11
-rw-r--r--lang/scriba/pkg-comment1
-rw-r--r--lang/scriba/pkg-descr14
-rw-r--r--lang/scriba/pkg-plist23
12 files changed, 243 insertions, 0 deletions
diff --git a/lang/scriba/Makefile b/lang/scriba/Makefile
new file mode 100644
index 000000000000..3db33cb988c7
--- /dev/null
+++ b/lang/scriba/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: scriba
+# Date created: 07 January 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scriba
+PORTVERSION= 10b21
+CATEGORIES= lang
+MASTER_SITES= http://www.scriptbasic.com/
+DISTNAME= ${PORTNAME}-v${PORTVERSION}
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+PRFXFILES= variations/standard/basiccmd.c \
+ variations/standalone/basicc.c \
+ configurer.c scriba.c scriba.conf.unix.lsp \
+ testconf.c
+
+WRKSRC= ${WRKDIR}
+
+post-patch:
+.for P in ${PRFXFILES}
+ @(cd ${WRKSRC} && ${SED} -e 's,%%PREFIX%%,${PREFIX},g' $P > foo && \
+ ${MV} foo $P)
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/scriba
+ ${MKDIR} ${PREFIX}/include/scriba
+ ${MKDIR} ${PREFIX}/lib/scriba
+ ${CHMOD} 1666 ${PREFIX}/lib/scriba
+ ${INSTALL_PROGRAM} ${WRKSRC}/scriba ${PREFIX}/bin
+.for M in cgi hash re
+ ${INSTALL_PROGRAM} ${WRKSRC}/$M.so ${PREFIX}/lib/scriba
+.endfor
+.for I in bdb cgi error gd hash heb md5 mysql re test time trial zlib ../heber
+ ${INSTALL_DATA} ${WRKSRC}/include/$I.bas ${PREFIX}/include/scriba
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/basicc.a ${PREFIX}/lib/scriba
+ ${WRKSRC}/cftc ${WRKSRC}/scriba.conf.unix.lsp \
+ ${PREFIX}/etc/scriba/basic.conf
+
+.include <bsd.port.mk>
diff --git a/lang/scriba/distinfo b/lang/scriba/distinfo
new file mode 100644
index 000000000000..f84480b0560c
--- /dev/null
+++ b/lang/scriba/distinfo
@@ -0,0 +1 @@
+MD5 (scriba-v10b21.tar.gz) = d4098436120d030dead170804b8d2f03
diff --git a/lang/scriba/files/patch-aa b/lang/scriba/files/patch-aa
new file mode 100644
index 000000000000..39b61b4e0528
--- /dev/null
+++ b/lang/scriba/files/patch-aa
@@ -0,0 +1,29 @@
+--- Makefile.orig Wed Dec 27 19:52:16 2000
++++ Makefile Fri Jan 12 18:34:19 2001
+@@ -1,8 +1,8 @@
+ CC=cc
+ LDOPTIONS=-shared
+ LD=ld
+-CCFLAGS=
+-LIBS=-lm -ldl -lpthread
++CCFLAGS=$(CFLAGS)
++LIBS=-lm -lc_r
+ OBJS=builder.o conftree.o dynlolib.o execute.o\
+ expression.o filesys.o getopt.o lexer.o match.o\
+ memory.o myalloc.o options.o reader.o report.o sym.o\
+@@ -20,7 +20,6 @@
+ .PHONY: headers clean install all
+
+ all: headers scriba cftc cgi.so hash.so re.so basicc.a
+- sh install.sh
+
+ clean :
+ rm *.so *.o *.h ./scriba
+@@ -39,7 +38,6 @@
+
+ scriba : $(OBJS) $(COBJS) scribacmd.o
+ $(CC) -o scriba $(LIBS) $(OBJS) $(COBJS) scribacmd.o
+- scriba -v
+
+ cftc : cftc.o confpile.o conftree.o lsp.o
+ $(CC) -o cftc $(LIBS) cftc.o confpile.o conftree.o lsp.o
diff --git a/lang/scriba/files/patch-ab b/lang/scriba/files/patch-ab
new file mode 100644
index 000000000000..139618510cad
--- /dev/null
+++ b/lang/scriba/files/patch-ab
@@ -0,0 +1,11 @@
+--- variations/standard/basiccmd.c.orig Sun Jan 7 19:39:44 2001
++++ variations/standard/basiccmd.c Sun Jan 7 19:35:07 2001
+@@ -186,7 +186,7 @@
+ "WINNT\\SCRIBA.INI",
+ #else
+ "SCRIBACONF",
+- "/etc/scriba/basic.conf",
++ "%%PREFIX%%/etc/scriba/basic.conf",
+ #endif
+ pszForcedConfigurationFileName);
+
diff --git a/lang/scriba/files/patch-ac b/lang/scriba/files/patch-ac
new file mode 100644
index 000000000000..a05783da776c
--- /dev/null
+++ b/lang/scriba/files/patch-ac
@@ -0,0 +1,11 @@
+--- variations/standalone/basicc.c.orig Fri Dec 29 11:23:20 2000
++++ variations/standalone/basicc.c Sun Jan 7 19:35:17 2001
+@@ -57,7 +57,7 @@
+ "SCRIBA.INI",
+ #else
+ "SCRIBACONF",
+- "/etc/scriba/basic.conf",
++ "%%PREFIX%%/etc/scriba/basic.conf",
+ #endif
+ NULL);
+
diff --git a/lang/scriba/files/patch-ad b/lang/scriba/files/patch-ad
new file mode 100644
index 000000000000..f4546dde4160
--- /dev/null
+++ b/lang/scriba/files/patch-ad
@@ -0,0 +1,11 @@
+--- configurer.c.orig Wed Dec 27 11:52:15 2000
++++ configurer.c Sun Jan 7 19:34:59 2001
+@@ -130,7 +130,7 @@
+ #else
+ char *s;
+ #define SCRIBACONF "SCRIBACONF"
+-#define DEFAULTCONF "/etc/scriba/basic.conf"
++#define DEFAULTCONF "%%PREFIX%%/etc/scriba/basic.conf"
+
+ s = getenv(SCRIBACONF);
+
diff --git a/lang/scriba/files/patch-ae b/lang/scriba/files/patch-ae
new file mode 100644
index 000000000000..bf1e31fe91c1
--- /dev/null
+++ b/lang/scriba/files/patch-ae
@@ -0,0 +1,28 @@
+--- scriba.c.orig Wed Dec 27 11:52:17 2000
++++ scriba.c Sun Jan 7 20:30:15 2001
+@@ -518,16 +518,12 @@
+ "SCRIBA.INI",
+ #else
+ "SCRIBACONF",
+- "/etc/scriba/basic.conf",
++ "/usr/local/etc/scriba/basic.conf",
+ #endif
+ pszForcedConfigurationFileName);
+ /*DEBUG*/
+- fp = fopen("e:\\MyProjects\\sb\\isapi.log","a");
+- if( fp ){
+- fprintf(fp,"LoadConfiguration returned %d.\n",iError);
+- fclose(fp);
+- fp = NULL;
+- }
++ if(iError)
++ fprintf(stderr,"LoadConfiguration returned %d.\n",iError);
+
+ return iError;
+ }
+@@ -1900,4 +1896,4 @@
+
+ default: return SCRIBA_ERROR_FAIL;
+ }
+- }
++ }
diff --git a/lang/scriba/files/patch-af b/lang/scriba/files/patch-af
new file mode 100644
index 000000000000..2b37a1f7ad2a
--- /dev/null
+++ b/lang/scriba/files/patch-af
@@ -0,0 +1,58 @@
+--- scriba.conf.unix.lsp.orig Wed Dec 27 19:52:17 2000
++++ scriba.conf.unix.lsp Mon Jan 15 03:34:09 2001
+@@ -8,11 +8,11 @@
+ dll ".so"
+
+ ; where the modules are to be loaded from
+-module "/etc/scriba/modules/"
++module "/usr/local/lib/scriba/"
+
+ ; where to search system and module include files
+ ; trailing / or / is needed
+-include "/etc/scriba/include/"
++include "/usr/local/include/scriba/"
+
+ ;
+ ; define external preprocessors
+@@ -29,8 +29,8 @@
+ ; the external preprocessors
+ external (
+ heb (
+- executable "/usr/bin/scriba /etc/scriba/source/heber.bas"
+- directory "/etc/scriba/hebtemp/"
++ executable "/usr/local/bin/scriba /usr/local/include/scriba/heber.bas"
++ directory "/usr/local/etc/scriba/hebtemp/"
+ )
+ )
+ )
+@@ -67,13 +67,13 @@
+ ; This is the directory where we store the compiled code
+ ; to automatically avoid recompilation
+ ;
+-cache "/etc/scriba/cache/"
++cache "/usr/local/lib/scriba/cache/"
+
+ cgi (
+ ;
+ ; These are the keys used by the CGI module
+ ;
+- debugfile "/etc/scriba/cgidebug.txt"
++ debugfile "/usr/local/etc/scriba/cgidebug.txt"
+ )
+
+ ;
+@@ -83,7 +83,7 @@
+
+ ; directories where to store the
+ dir (
+- home "/etc/scriba/sampledb" ; the home directory of operation of the Berkerley DB
++ home "/usr/local/etc/scriba/sampledb" ; the home directory of operation of the Berkerley DB
+ data "db" ; database files
+ log "log" ; log files
+ temp "tmp" ; temporary files
+@@ -115,4 +115,4 @@
+ )
+ )
+
+-;break
++;break
diff --git a/lang/scriba/files/patch-ag b/lang/scriba/files/patch-ag
new file mode 100644
index 000000000000..6da84312fce6
--- /dev/null
+++ b/lang/scriba/files/patch-ag
@@ -0,0 +1,11 @@
+--- testconf.c.orig Wed Dec 27 11:52:17 2000
++++ testconf.c Sun Jan 7 19:34:59 2001
+@@ -15,7 +15,7 @@
+ "WINNT\\SCRIBA.INI",
+ #else
+ "SCRIBACONF",
+- "/etc/scriba/basic.conf",
++ "%%PREFIX%%/etc/scriba/basic.conf",
+ #endif
+ NULL));
+
diff --git a/lang/scriba/pkg-comment b/lang/scriba/pkg-comment
new file mode 100644
index 000000000000..c0bd9131b360
--- /dev/null
+++ b/lang/scriba/pkg-comment
@@ -0,0 +1 @@
+A scripting implementation of the BASIC language
diff --git a/lang/scriba/pkg-descr b/lang/scriba/pkg-descr
new file mode 100644
index 000000000000..38d8d9ccf5ef
--- /dev/null
+++ b/lang/scriba/pkg-descr
@@ -0,0 +1,14 @@
+ScriptBasic is a scripting implementation of the BASIC language. The
+aim of this implementation is to provide a general and widely used
+tool for the simple programmer. One of the reason behind the success
+of the Microsoft operating systems is VisualBasic, which is built into
+many of the applications Microsoft delivers. Why are UNIX and other
+non-Microsoft operating system users prohibited to use the simplest
+programming language?
+
+ScriptBasic is a BASIC implementation, which aims not less than
+becoming the most widely used scripting tool on UNIX systems. It is
+portable, it is BASIC, it is a scripting tool and it is GNU LGPL.
+
+- George Reid
+greid@ukug.uk.freebsd.org
diff --git a/lang/scriba/pkg-plist b/lang/scriba/pkg-plist
new file mode 100644
index 000000000000..155992188c71
--- /dev/null
+++ b/lang/scriba/pkg-plist
@@ -0,0 +1,23 @@
+bin/scriba
+etc/scriba/basic.conf
+include/scriba/bdb.bas
+include/scriba/cgi.bas
+include/scriba/error.bas
+include/scriba/gd.bas
+include/scriba/hash.bas
+include/scriba/heb.bas
+include/scriba/heber.bas
+include/scriba/md5.bas
+include/scriba/mysql.bas
+include/scriba/re.bas
+include/scriba/test.bas
+include/scriba/time.bas
+include/scriba/trial.bas
+include/scriba/zlib.bas
+lib/scriba/basicc.a
+lib/scriba/cgi.so
+lib/scriba/hash.so
+lib/scriba/re.so
+@dirrm etc/scriba
+@dirrm include/scriba
+@dirrm lib/scriba