aboutsummaryrefslogtreecommitdiff
path: root/lang/sdcc-devel/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-22 21:59:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-22 21:59:48 +0000
commitb77bd2c353af2e5321399c5d6efdd394558910f8 (patch)
tree9f04b99a4f460a0570bd1645b8268fe2513e3354 /lang/sdcc-devel/Makefile
parentfc0ebd7e02a8e79a807ab5064d1071453b209d7d (diff)
downloadports-b77bd2c353af2e5321399c5d6efdd394558910f8.tar.gz
ports-b77bd2c353af2e5321399c5d6efdd394558910f8.zip
Notes
Diffstat (limited to 'lang/sdcc-devel/Makefile')
-rw-r--r--lang/sdcc-devel/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/lang/sdcc-devel/Makefile b/lang/sdcc-devel/Makefile
index ba2ec1932965..12a23b6748de 100644
--- a/lang/sdcc-devel/Makefile
+++ b/lang/sdcc-devel/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= sdcc
-PORTVERSION= 2.8.5.2008.12.05
+PORTVERSION= 2.9.1.2009.05.18
CATEGORIES= lang
MASTER_SITES= http://sdcc.sourceforge.net/snapshots/sdcc-src/ \
http://tijl.ulyssis.be/mirror/
-DISTNAME= ${PORTNAME}-src-20081205-5276
+DISTNAME= ${PORTNAME}-src-20090518-5457
MAINTAINER= tijl@ulyssis.org
COMMENT= Small Device C Compiler
@@ -36,7 +36,7 @@ OPTIONS= MCS51 "Intel 8051 port" on \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --datarootdir=${DATADIR} \
--docdir=${DOCSDIR} \
include_dir_suffix=include \
@@ -45,8 +45,7 @@ CONFIGURE_ARGS= --datarootdir=${DATADIR} \
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-CFLAGS+= -O0
-CXXFLAGS+= -O0
+USE_GCC= 4.3+
BROKEN= Does not compile on sparc64
.endif