aboutsummaryrefslogtreecommitdiff
path: root/lang/sdcc-devel/Makefile
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-02-02 17:13:13 +0000
committerMichael Scheidell <scheidell@FreeBSD.org>2012-02-02 17:13:13 +0000
commite7176b22cfaa5d6a1554a1557777bd21c431558f (patch)
tree2b978d4f2392828baa5a84743e0c2e0816c79371 /lang/sdcc-devel/Makefile
parent401d6fa5c794c3b10ffb9446b65dd876462cd95c (diff)
downloadports-e7176b22cfaa5d6a1554a1557777bd21c431558f.tar.gz
ports-e7176b22cfaa5d6a1554a1557777bd21c431558f.zip
Notes
Diffstat (limited to 'lang/sdcc-devel/Makefile')
-rw-r--r--lang/sdcc-devel/Makefile61
1 files changed, 18 insertions, 43 deletions
diff --git a/lang/sdcc-devel/Makefile b/lang/sdcc-devel/Makefile
index 0a753bed3e94..137a045924fb 100644
--- a/lang/sdcc-devel/Makefile
+++ b/lang/sdcc-devel/Makefile
@@ -6,15 +6,19 @@
#
PORTNAME= sdcc
-PORTVERSION= 3.0.2.2011.03.21
+PORTVERSION= 3.1.2.2012.01.22
CATEGORIES= lang
MASTER_SITES= SF/sdcc/snapshot_builds/sdcc-src/ \
http://tijl.fastmail.fm/mirror/
-DISTNAME= ${PORTNAME}-src-20110321-6331
+DISTNAME= ${PORTNAME}-src-20120122-7247
MAINTAINER= tijl@coosemans.org
COMMENT= Small Device C Compiler
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:${PORTSDIR}/devel/boost-libs
+
WRKSRC= ${WRKDIR}/sdcc
GNU_CONFIGURE= yes
@@ -23,27 +27,21 @@ USE_BZIP2= yes
USE_GMAKE= yes
OPTIONS= MCS51 "Intel 8051 port" on \
- Z80 "Zilog Z80 port" on \
- AVR "AVR port" on \
+ Z80 "Zilog Z80/Z180, Rabbit 2000 port" on \
DS390 "Maxim 80DS390/DS400 port" on \
- PIC "Microchip PIC16 series port" on \
+ PIC14 "Microchip PIC16 series port" on \
PIC16 "Microchip PIC18 series port" on \
- XA51 "Philips XA51 port" on \
HC08 "Motorola 68HC08 port" on \
DEVLIB "Device libraries" on \
- UCSIM "The ucSim simulator" on \
- PACKIHX "A tool to pack (compress) Intel hex files" on
+ UCSIM "The ucSim simulator" on
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --disable-avr --docdir=${DOCSDIR} --enable-new-pics
+CONFIGURE_ENV= ARCH=""
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
.if defined(WITHOUT_MCS51) && defined(WITHOUT_DS390)
CONFIGURE_ARGS+= --disable-51
PLIST_SUB+= MCS51DS390="@comment "
@@ -60,20 +58,13 @@ PLIST_SUB+= MCS51=""
.endif
.if defined(WITHOUT_Z80)
-CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port --disable-z80
+CONFIGURE_ARGS+= --disable-gbz80-port --disable-r2k-port \
+ --disable-z180-port --disable-z80-port --disable-z80
PLIST_SUB+= Z80="@comment "
.else
PLIST_SUB+= Z80=""
.endif
-.if defined(WITHOUT_AVR)
-CONFIGURE_ARGS+= --disable-avr
-PLIST_SUB+= AVR="@comment "
-.else
-CONFIGURE_ARGS+= --enable-avr-port
-PLIST_SUB+= AVR=""
-.endif
-
.if defined(WITHOUT_DS390)
CONFIGURE_ARGS+= --disable-ds390-port --disable-ds400-port
PLIST_SUB+= DS390="@comment "
@@ -81,11 +72,12 @@ PLIST_SUB+= DS390="@comment "
PLIST_SUB+= DS390=""
.endif
-.if defined(WITHOUT_PIC)
+.if defined(WITHOUT_PIC14)
CONFIGURE_ARGS+= --disable-pic14-port
PLIST_SUB+= PIC14="@comment "
.else
-BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+BUILD_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC14=""
.endif
@@ -93,17 +85,11 @@ PLIST_SUB+= PIC14=""
CONFIGURE_ARGS+= --disable-pic16-port
PLIST_SUB+= PIC16="@comment "
.else
-BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+BUILD_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC16=""
.endif
-.if defined(WITHOUT_XA51)
-PLIST_SUB+= XA51="@comment "
-.else
-CONFIGURE_ARGS+= --enable-xa51-port --enable-xa
-PLIST_SUB+= XA51=""
-.endif
-
.if defined(WITHOUT_HC08)
CONFIGURE_ARGS+= --disable-hc08-port --disable-hc08
PLIST_SUB+= HC08="@comment "
@@ -127,18 +113,7 @@ LIBTOOLFILES= sim/ucsim/configure
PLIST_SUB+= UCSIM=""
.endif
-.if defined(WITHOUT_PACKIHX)
-CONFIGURE_ARGS+= --disable-packihx
-PLIST_SUB+= PACKIHX="@comment "
-.else
-PLIST_SUB+= PACKIHX=""
-.endif
-
post-patch:
- @${REINPLACE_CMD} 's,ARCH,PICARCH,g' \
- ${WRKSRC}/device/lib/pic14/Makefile.common.in \
- ${WRKSRC}/device/lib/pic14/Makefile.rules \
- ${WRKSRC}/device/lib/pic16/configure
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} 's, [a-z-]*doc,,' \
${WRKSRC}/Makefile.in \