aboutsummaryrefslogtreecommitdiff
path: root/lang/sdcc/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-18 17:05:16 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2012-01-18 17:05:16 +0000
commitcca4fd07a8a987b39470f9e877d792fce1174b36 (patch)
treed633fc24b1cf4b92ee1bd3eee10d62dde58fc845 /lang/sdcc/Makefile
parent52958d07bf8d0e522d0b07f9362e17612264e2df (diff)
downloadports-cca4fd07a8a987b39470f9e877d792fce1174b36.tar.gz
ports-cca4fd07a8a987b39470f9e877d792fce1174b36.zip
Notes
Diffstat (limited to 'lang/sdcc/Makefile')
-rw-r--r--lang/sdcc/Makefile67
1 files changed, 20 insertions, 47 deletions
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index 0eda26a727e0..36b5439578b9 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdcc
-PORTVERSION= 3.0.0
+PORTVERSION= 3.1.0
DISTVERSIONPREFIX= src-
CATEGORIES= lang
MASTER_SITES= SF
@@ -14,6 +14,10 @@ MASTER_SITES= SF
MAINTAINER= tijl@coosemans.org
COMMENT= Small Device C Compiler
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/graph/adjacency_list.hpp:${PORTSDIR}/devel/boost-libs
+
WRKSRC= ${WRKDIR}/sdcc
GNU_CONFIGURE= yes
@@ -21,27 +25,21 @@ USE_BZIP2= yes
USE_GMAKE= yes
OPTIONS= MCS51 "Intel 8051 port" on \
- Z80 "Zilog Z80 port" on \
- AVR "AVR port" on \
+ Z80 "Zilog Z80/Z180, Rabbit 2000 port" on \
DS390 "Maxim 80DS390/DS400 port" on \
- PIC "Microchip PIC16 series port" on \
+ PIC14 "Microchip PIC16 series port" on \
PIC16 "Microchip PIC18 series port" on \
- XA51 "Philips XA51 port" on \
HC08 "Motorola 68HC08 port" on \
DEVLIB "Device libraries" on \
- UCSIM "The ucSim simulator" on \
- PACKIHX "A tool to pack (compress) Intel hex files" on
+ UCSIM "The ucSim simulator" on
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --disable-avr --docdir=${DOCSDIR} --enable-new-pics
+CONFIGURE_ENV= ARCH=""
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
.if defined(WITHOUT_MCS51) && defined(WITHOUT_DS390)
CONFIGURE_ARGS+= --disable-51
PLIST_SUB+= MCS51DS390="@comment "
@@ -58,20 +56,13 @@ PLIST_SUB+= MCS51=""
.endif
.if defined(WITHOUT_Z80)
-CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port --disable-z80
+CONFIGURE_ARGS+= --disable-gbz80-port --disable-r2k-port \
+ --disable-z180-port --disable-z80-port --disable-z80
PLIST_SUB+= Z80="@comment "
.else
PLIST_SUB+= Z80=""
.endif
-.if defined(WITHOUT_AVR)
-CONFIGURE_ARGS+= --disable-avr
-PLIST_SUB+= AVR="@comment "
-.else
-CONFIGURE_ARGS+= --enable-avr-port
-PLIST_SUB+= AVR=""
-.endif
-
.if defined(WITHOUT_DS390)
CONFIGURE_ARGS+= --disable-ds390-port --disable-ds400-port
PLIST_SUB+= DS390="@comment "
@@ -79,31 +70,24 @@ PLIST_SUB+= DS390="@comment "
PLIST_SUB+= DS390=""
.endif
-.if defined(WITHOUT_PIC)
-CONFIGURE_ARGS+= --disable-pic-port
-PLIST_SUB+= PIC="@comment "
+.if defined(WITHOUT_PIC14)
+CONFIGURE_ARGS+= --disable-pic14-port
+PLIST_SUB+= PIC14="@comment "
.else
-BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-RUN_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-PLIST_SUB+= PIC=""
+BUILD_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
+PLIST_SUB+= PIC14=""
.endif
.if defined(WITHOUT_PIC16)
CONFIGURE_ARGS+= --disable-pic16-port
PLIST_SUB+= PIC16="@comment "
.else
-BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-RUN_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+BUILD_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
+RUN_DEPENDS+= gputils>=0.14.1:${PORTSDIR}/devel/gputils
PLIST_SUB+= PIC16=""
.endif
-.if defined(WITHOUT_XA51)
-PLIST_SUB+= XA51="@comment "
-.else
-CONFIGURE_ARGS+= --enable-xa51-port --enable-xa
-PLIST_SUB+= XA51=""
-.endif
-
.if defined(WITHOUT_HC08)
CONFIGURE_ARGS+= --disable-hc08-port --disable-hc08
PLIST_SUB+= HC08="@comment "
@@ -127,18 +111,7 @@ LIBTOOLFILES= sim/ucsim/configure
PLIST_SUB+= UCSIM=""
.endif
-.if defined(WITHOUT_PACKIHX)
-CONFIGURE_ARGS+= --disable-packihx
-PLIST_SUB+= PACKIHX="@comment "
-.else
-PLIST_SUB+= PACKIHX=""
-.endif
-
post-patch:
- @${REINPLACE_CMD} 's,ARCH,PICARCH,g' \
- ${WRKSRC}/device/lib/pic/Makefile.common.in \
- ${WRKSRC}/device/lib/pic/Makefile.rules \
- ${WRKSRC}/device/lib/pic16/configure
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} 's, [a-z-]*doc,,' \
${WRKSRC}/Makefile.in \