aboutsummaryrefslogtreecommitdiff
path: root/lang/sdcc/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-11 20:28:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-11 20:28:52 +0000
commit163632704cdac915d7d9a5acc8ae45bbf87766c7 (patch)
tree0cba0f4f40c55e381e02cdc3de05209d850435e3 /lang/sdcc/Makefile
parent675559011454942923a65b91da019917f6b966e3 (diff)
downloadports-163632704cdac915d7d9a5acc8ae45bbf87766c7.tar.gz
ports-163632704cdac915d7d9a5acc8ae45bbf87766c7.zip
Notes
Diffstat (limited to 'lang/sdcc/Makefile')
-rw-r--r--lang/sdcc/Makefile48
1 files changed, 33 insertions, 15 deletions
diff --git a/lang/sdcc/Makefile b/lang/sdcc/Makefile
index e3ca05e41a37..c365e346907e 100644
--- a/lang/sdcc/Makefile
+++ b/lang/sdcc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdcc
-PORTVERSION= 2.5.0
+PORTVERSION= 2.6.0
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= sdcc
@@ -19,21 +19,26 @@ WRKSRC= ${WRKDIR}/sdcc
GNU_CONFIGURE= yes
USE_GMAKE= yes
-OPTIONS= MCS51 "Intel mcs51 port" on \
- Z80 "Z80 port" on \
+OPTIONS= MCS51 "Intel 8051 port" on \
+ Z80 "Zilog Z80 port" on \
AVR "AVR port" on \
- DS390 "DS390/DS400 port" on \
- PIC "PIC port" on \
- PIC16 "PIC16 port" on \
- XA51 "XA51 port" on \
- HC08 "HC08 port" on \
+ DS390 "Maxim 80DS390/DS400 port" on \
+ PIC "Microchip PIC16 series port" on \
+ PIC16 "Microchip PIC18 series port" on \
+ XA51 "Philips XA51 port" on \
+ HC08 "Motorola 68HC08 port" on \
+ DEVLIB "Device libraries" on \
UCSIM "The ucSim simulator" on \
PACKIHX "A tool to pack (compress) Intel hex files" on
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha"
-USE_GCC= 3.2+
+.if defined(WITHOUT_MCS51) && defined(WITHOUT_DS390)
+CONFIGURE_ARGS+= --disable-51
+PLIST_SUB+= MCS51DS390="@comment "
+.else
+USE_AUTOTOOLS+= autoconf:259
+PLIST_SUB+= MCS51DS390=""
.endif
.if defined(WITHOUT_MCS51)
@@ -44,14 +49,17 @@ PLIST_SUB+= MCS51=""
.endif
.if defined(WITHOUT_Z80)
-CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port
+CONFIGURE_ARGS+= --disable-gbz80-port --disable-z80-port --disable-z80
PLIST_SUB+= Z80="@comment "
.else
PLIST_SUB+= Z80=""
.endif
.if defined(WITHOUT_AVR)
-CONFIGURE_ARGS+= --disable-avr-port
+CONFIGURE_ARGS+= --disable-avr-port --disable-avr
+PLIST_SUB+= AVR="@comment "
+.else
+PLIST_SUB+= AVR=""
.endif
.if defined(WITHOUT_DS390)
@@ -63,6 +71,10 @@ PLIST_SUB+= DS390=""
.if defined(WITHOUT_PIC)
CONFIGURE_ARGS+= --disable-pic-port
+PLIST_SUB+= PIC="@comment "
+.else
+BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
+PLIST_SUB+= PIC=""
.endif
.if defined(WITHOUT_PIC16)
@@ -70,7 +82,6 @@ CONFIGURE_ARGS+= --disable-pic16-port
PLIST_SUB+= PIC16="@comment "
.else
BUILD_DEPENDS+= gpasm:${PORTSDIR}/devel/gputils
-USE_AUTOTOOLS= autoconf:259
PLIST_SUB+= PIC16=""
.endif
@@ -79,18 +90,25 @@ CONFIGURE_ARGS+= --disable-xa51-port
.endif
.if defined(WITHOUT_HC08)
-CONFIGURE_ARGS+= --disable-hc08-port
+CONFIGURE_ARGS+= --disable-hc08-port --disable-hc08
PLIST_SUB+= HC08="@comment "
.else
PLIST_SUB+= HC08=""
.endif
+.if defined(WITHOUT_DEVLIB)
+CONFIGURE_ARGS+= --disable-device-lib
+PLIST_SUB+= DEVLIB="@comment "
+.else
+PLIST_SUB+= DEVLIB=""
+.endif
+
.if defined(WITHOUT_UCSIM)
CONFIGURE_ARGS+= --disable-ucsim
PLIST_SUB+= UCSIM="@comment "
.else
USE_AUTOTOOLS+= libtool:15
-LIBTOOLFILES= sim/ucsim/aclocal.m4
+LIBTOOLFILES= sim/ucsim/configure
PLIST_SUB+= UCSIM=""
.endif