aboutsummaryrefslogtreecommitdiff
path: root/lang/see-devel/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-09 17:11:13 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2008-05-09 17:11:13 +0000
commit430838889b08d39c15f52756f11acd02cfbb26dc (patch)
tree77c2d8d92862a9b898f25f1e085b545964883940 /lang/see-devel/Makefile
parent395271795ce992eaa505ba52c7294872a79d293a (diff)
downloadports-430838889b08d39c15f52756f11acd02cfbb26dc.tar.gz
ports-430838889b08d39c15f52756f11acd02cfbb26dc.zip
Notes
Diffstat (limited to 'lang/see-devel/Makefile')
-rw-r--r--lang/see-devel/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/lang/see-devel/Makefile b/lang/see-devel/Makefile
index 3f9857e3a411..765b611585e1 100644
--- a/lang/see-devel/Makefile
+++ b/lang/see-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= see
PORTVERSION= 3.0.1376
+PORTREVISION= 1
CATEGORIES= lang devel
MASTER_SITES= http://www.evolane.com/download/mirror/etcl/ \
http://www.evolane.fr/download/mirror/etcl/
@@ -17,7 +18,8 @@ COMMENT= Simple ECMAScript Engine (SEE)
OPTIONS= GC "Use Boehm-Weiser garbage collection package" on \
OPTIMIZED_CFLAGS "Enable some additional optimizations" off \
- SEE_DEBUG "Internal SEE library debugging" off
+ SEE_DEBUG "Internal SEE library debugging" off \
+ MULTIPLE_THREADS "Enable thread-safety" on
CONFLICTS= see-[0-9]*
@@ -32,6 +34,10 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
+.if defined(WITH_MULTIPLE_THREADS)
+CFLAGS+= -DMULTIPLE_THREADS
+.endif
+
.if !defined(WITH_SEE_DEBUG)
CFLAGS+= -DNDEBUG
.endif
@@ -44,9 +50,11 @@ CFLAGS+= -O3 -fomit-frame-pointer
LIB_DEPENDS+= gc:${PORTSDIR}/devel/boehm-gc
.else
CONFIGURE_ARGS+= --without-boehm-gc
+.if !defined(WITH_MULTIPLE_THREADS)
PTHREAD_CFLAGS=
PTHREAD_LIBS=
.endif
+.endif
post-patch:
@${REINPLACE_CMD} -e "s|PACKAGE_BUGREPORT='leonard@users|PACKAGE_BUGREPORT='leonard\\\@users|" \