aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-02-05 16:31:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-02-05 16:31:10 +0000
commit5c86446f9898dc95909546c706178f511182de4e (patch)
tree87305d67170ddc2f3ce594dcf0256d58b5e8aa27 /lang/seed7
parent15ee5d55177357e0ee1d071eb456ed89ad7535df (diff)
downloadports-5c86446f9898dc95909546c706178f511182de4e.tar.gz
ports-5c86446f9898dc95909546c706178f511182de4e.zip
lang/seed7: take back this port, update to 05_20160130.
Notes
Notes: svn path=/head/; revision=408218
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile9
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-heaputl.c10
-rw-r--r--lang/seed7/pkg-plist15
4 files changed, 32 insertions, 6 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index 26d5a91d6c71..a7f63e2edfc9 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,13 +2,12 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20140907
+DISTVERSION= 05_20160130
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
-EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= High-level, extensible programming language
# The language libraries are licensed under the LGPL21 license. Starting from
@@ -19,10 +18,12 @@ LICENSE_COMB= multi
OPTIONS_DEFINE= DOCS EXAMPLES
+USES= tar:tgz
USE_XORG= x11
ONLY_FOR_ARCHS= i386 amd64 sparc64
+TEST_TARGET= do-test
WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
MAKE_ENV+= S7_LIB_DIR=${S7_LIB_DIR} \
@@ -75,7 +76,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../doc/s7.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/../doc/s7c.1 ${STAGEDIR}${PREFIX}/man/man1
-regression-test: build
+do-test:
cd ${WRKSRC} && ${MAKE} -f ${MAKEFILE} test
.include <bsd.port.mk>
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 1c7c33004a7c..8a931188a5e6 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20140907.tgz) = 0f573dac0f23f6b6a4cc47202b2819f75cf1c9d6a7e5795815d6d444929069a0
-SIZE (seed7_05_20140907.tgz) = 2222067
+SHA256 (seed7_05_20160130.tgz) = 654a938a385b2969b78d7b1f37c3b8c6eda532e746f5a275cc846b32be042771
+SIZE (seed7_05_20160130.tgz) = 2591149
diff --git a/lang/seed7/files/patch-heaputl.c b/lang/seed7/files/patch-heaputl.c
new file mode 100644
index 000000000000..dd0d6ed1cc42
--- /dev/null
+++ b/lang/seed7/files/patch-heaputl.c
@@ -0,0 +1,10 @@
+--- heaputl.c.orig 2016-02-05 14:25:17 UTC
++++ heaputl.c
+@@ -36,6 +36,7 @@
+
+ #include "stdlib.h"
+ #include "stdio.h"
++#include "stdint.h"
+ #if HAS_GETRLIMIT && defined STACK_SIZE
+ #include "sys/resource.h"
+ #endif
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index f581fa82c898..b5cc38da585e 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -5,6 +5,7 @@ lib/seed7/bin/s7_con.a
lib/seed7/bin/s7_data.a
lib/seed7/bin/s7_draw.a
lib/seed7/bin/seed7_05.a
+lib/seed7/lib/aes.s7i
lib/seed7/lib/arc4.s7i
lib/seed7/lib/array.s7i
lib/seed7/lib/asn1.s7i
@@ -12,26 +13,32 @@ lib/seed7/lib/bigfile.s7i
lib/seed7/lib/bigint.s7i
lib/seed7/lib/bigrat.s7i
lib/seed7/lib/bin32.s7i
+lib/seed7/lib/bin64.s7i
+lib/seed7/lib/bitdata.s7i
lib/seed7/lib/bitmapfont.s7i
lib/seed7/lib/bitset.s7i
lib/seed7/lib/bitsetof.s7i
lib/seed7/lib/boolean.s7i
+lib/seed7/lib/browser.s7i
lib/seed7/lib/bstring.s7i
lib/seed7/lib/bytedata.s7i
lib/seed7/lib/cards.s7i
lib/seed7/lib/category.s7i
lib/seed7/lib/cc_conf.s7i
lib/seed7/lib/cgi.s7i
+lib/seed7/lib/cgidialog.s7i
lib/seed7/lib/char.s7i
lib/seed7/lib/charsets.s7i
lib/seed7/lib/chartype.s7i
lib/seed7/lib/cipher.s7i
+lib/seed7/lib/cli_cmds.s7i
lib/seed7/lib/clib_file.s7i
lib/seed7/lib/color.s7i
lib/seed7/lib/comp/act_act.s7i
lib/seed7/lib/comp/action.s7i
lib/seed7/lib/comp/arr_act.s7i
lib/seed7/lib/comp/big_act.s7i
+lib/seed7/lib/comp/bin_act.s7i
lib/seed7/lib/comp/bln_act.s7i
lib/seed7/lib/comp/bst_act.s7i
lib/seed7/lib/comp/chr_act.s7i
@@ -58,6 +65,7 @@ lib/seed7/lib/comp/itf_act.s7i
lib/seed7/lib/comp/kbd_act.s7i
lib/seed7/lib/comp/library.s7i
lib/seed7/lib/comp/literal.s7i
+lib/seed7/lib/comp/pcs_act.s7i
lib/seed7/lib/comp/pol_act.s7i
lib/seed7/lib/comp/prc_act.s7i
lib/seed7/lib/comp/prg_act.s7i
@@ -66,6 +74,7 @@ lib/seed7/lib/comp/rfl_act.s7i
lib/seed7/lib/comp/sct_act.s7i
lib/seed7/lib/comp/set_act.s7i
lib/seed7/lib/comp/soc_act.s7i
+lib/seed7/lib/comp/sql_act.s7i
lib/seed7/lib/comp/stat.s7i
lib/seed7/lib/comp/str_act.s7i
lib/seed7/lib/comp/tim_act.s7i
@@ -109,6 +118,7 @@ lib/seed7/lib/hashsetof.s7i
lib/seed7/lib/hmac.s7i
lib/seed7/lib/html.s7i
lib/seed7/lib/html_ent.s7i
+lib/seed7/lib/httpserv.s7i
lib/seed7/lib/idxarray.s7i
lib/seed7/lib/image.s7i
lib/seed7/lib/inflate.s7i
@@ -119,6 +129,7 @@ lib/seed7/lib/keydescr.s7i
lib/seed7/lib/line.s7i
lib/seed7/lib/listener.s7i
lib/seed7/lib/lower.s7i
+lib/seed7/lib/lzw.s7i
lib/seed7/lib/mahjng32.s7i
lib/seed7/lib/make.s7i
lib/seed7/lib/makedata.s7i
@@ -148,9 +159,11 @@ lib/seed7/lib/scanstri.s7i
lib/seed7/lib/seed7_05.s7i
lib/seed7/lib/set.s7i
lib/seed7/lib/shell.s7i
+lib/seed7/lib/smtp.s7i
lib/seed7/lib/sockbase.s7i
lib/seed7/lib/socket.s7i
lib/seed7/lib/sokoban1.s7i
+lib/seed7/lib/sql_base.s7i
lib/seed7/lib/stars.s7i
lib/seed7/lib/stdfont10.s7i
lib/seed7/lib/stdfont12.s7i
@@ -175,11 +188,13 @@ lib/seed7/lib/text.s7i
lib/seed7/lib/time.s7i
lib/seed7/lib/tls.s7i
lib/seed7/lib/unicode.s7i
+lib/seed7/lib/unionfnd.s7i
lib/seed7/lib/upper.s7i
lib/seed7/lib/utf16.s7i
lib/seed7/lib/utf8.s7i
lib/seed7/lib/vecfont10.s7i
lib/seed7/lib/vecfont18.s7i
+lib/seed7/lib/vector3d.s7i
lib/seed7/lib/vectorfont.s7i
lib/seed7/lib/window.s7i
lib/seed7/lib/wrinum.s7i