aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-11-28 14:18:12 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-11-28 14:18:12 +0000
commit43c0afa4d0e36a7caff6811fd79b106804762e9e (patch)
tree1f2622f451eb548dd375991d1efe33bb247b1864 /lang/seed7
parent44565aa37a2d00d69799a08a0767eb0f4fc82af0 (diff)
Notes
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile27
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-makefile20
-rw-r--r--lang/seed7/pkg-plist2
4 files changed, 29 insertions, 24 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index af095647ad93..c31b029ba6a4 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20121021
+DISTVERSION= 05_20121125
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -20,7 +20,11 @@ ONLY_FOR_ARCHS= i386 amd64 sparc64
WRKSRC= ${WRKDIR}/${PORTNAME}/src
MAKEFILE= makefile
-ALL_TARGET= hi
+MAKE_ENV+= S7_LIB_DIR=${PREFIX}/lib/seed7 \
+ SEED7_LIBRARY=${PREFIX}/lib/seed7 \
+ C_COMPILER=${CC} \
+ CPLUSPLUS_COMPILER=${CPP}
+ALL_TARGET= depend hi
.include <bsd.port.pre.mk>
@@ -29,15 +33,8 @@ BROKEN= does not compile
.endif
post-patch:
- ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;\
- s|`pwd`|${PREFIX}/lib/${PORTNAME}|g;\
- s|-lX11|$${LFLAGS} -lX11|g' \
- ${WRKSRC}/makefile
- ${REINPLACE_CMD} -i '' -e 's|./hi|${PREFIX}/bin/hi|g' \
- ${WRKSRC}/../prg/chk_all.sd7
-
-do-configure:
- (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} depend)
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/makefile
+ ${REINPLACE_CMD} -i '' -e 's|./hi|${PREFIX}/bin/hi|g' ${WRKSRC}/../prg/chk_all.sd7
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../bin/hi ${PREFIX}/bin
@@ -50,16 +47,22 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/../bin/seed7_05.a ${PREFIX}/lib/${PORTNAME}
post-install:
+# compile the seed7 compiler (needs the libraries to be installed)
+ cd ${WRKSRC}/../prg && ./hi comp -O2 comp
+ ${INSTALL_PROGRAM} ${WRKSRC}/../prg/comp ${PREFIX}/bin/hi_comp
+ ${RM} ${WRKSRC}/../prg/tmp_comp.c ${WRKSRC}/../prg/comp
+# install PORTDOCS
.if !defined(NOPORTDOCS)
${INSTALL} -d ${DOCSDIR}
(cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
+# install PORTEXAMPLES
.if !defined(NOPORTEXAMPLES)
${INSTALL} -d ${EXAMPLESDIR}
(cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
-test: install
+test: ${INSTALL_TARGET}
@echo ""
@echo "Testing the ${PORTNAME} installation"
@(cd ${WRKSRC}/../prg && ${PREFIX}/bin/hi chk_all)
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 7c891087ca10..1d60acf15292 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20121021.tgz) = 698f11a31d820c678ee54c1f013cb8538d37339898fc000d5ae4b8d4c2487d6b
-SIZE (seed7_05_20121021.tgz) = 1795775
+SHA256 (seed7_05_20121125.tgz) = 6d0d0e52e4f1150deefc036d782c5421ed00c20db00309bd4977c664435ba193
+SIZE (seed7_05_20121125.tgz) = 1800530
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
index bb0336a7c399..966804a1b6c0 100644
--- a/lang/seed7/files/patch-makefile
+++ b/lang/seed7/files/patch-makefile
@@ -1,23 +1,23 @@
---- makefile.orig 2012-10-18 14:42:29.000000000 +0200
-+++ makefile 2012-10-18 14:43:37.000000000 +0200
-@@ -12,14 +12,14 @@
+--- makefile.orig 2012-11-27 13:49:47.000000000 +0100
++++ makefile 2012-11-27 13:50:36.000000000 +0100
+@@ -12,7 +12,7 @@
# CFLAGS = -O2 -fomit-frame-pointer -Wall -Wextra -Wswitch-default -Wcast-qual -Waggregate-return -Wwrite-strings -Winline -Wconversion -Wshadow -Wpointer-arith -Wmissing-noreturn -Wno-multichar
# CFLAGS = -O2 -g -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -ftrapv
# CFLAGS = -O2 -g -x c++ -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
-CFLAGS = -O2 -g -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
-+CFLAGS += -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
++CFLAGS = -ffunction-sections -fdata-sections -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith -I%%LOCALBASE%%/include
+ # CFLAGS = -O2 -g -ffunction-sections -fdata-sections -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -std=c99 -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
- # CFLAGS = -O2 -g -Wall
- # CFLAGS = -O2 -g -pg -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
+@@ -21,6 +21,7 @@
# CFLAGS = -O2 -fomit-frame-pointer -funroll-loops -Wall
# CFLAGS = -O2 -funroll-loops -Wall -pg
--LDFLAGS = -Wl,--gc-sections
-+LDFLAGS += -L%%LOCALBASE%%/lib
+ LDFLAGS = -Wl,--gc-sections
++LDFLAGS = -Wl,--gc-sections -L%%LOCALBASE%%/lib
# LDFLAGS = -pg
# LDFLAGS = -pg -lc_p
SYSTEM_LIBS = -lm
-@@ -38,7 +38,7 @@
+@@ -39,7 +40,7 @@
COMPILER_LIB = s7_comp.a
ALL_S7_LIBS = ../bin/$(COMPILER_LIB) ../bin/$(COMP_DATA_LIB) ../bin/$(DRAW_LIB) ../bin/$(CONSOLE_LIB) ../bin/$(SEED7_LIB)
# CC = g++
@@ -26,7 +26,7 @@
GET_CC_VERSION_INFO = $(CC) --version >
BIGINT_LIB_DEFINE = USE_BIG_RTL_LIBRARY
-@@ -112,6 +112,7 @@
+@@ -113,6 +114,7 @@
COMP_DATA_LIB_SRC = typ_data.c rfl_data.c ref_data.c listutl.c flistutl.c typeutl.c datautl.c
COMPILER_LIB_SRC = $(PSRC1) $(LSRC1) $(LSRC2) $(LSRC3) $(ESRC1) $(ASRC1) $(ASRC2) $(ASRC3) $(GSRC1) $(GSRC2)
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index 98ccfa6d2f31..41ae70bbf2d5 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -1,4 +1,5 @@
bin/hi
+bin/hi_comp
lib/seed7/COPYING
lib/seed7/LGPL
lib/seed7/array.s7i
@@ -32,6 +33,7 @@ lib/seed7/enable_input.s7i
lib/seed7/enable_io.s7i
lib/seed7/enable_output.s7i
lib/seed7/encoding.s7i
+lib/seed7/environment.s7i
lib/seed7/external_file.s7i
lib/seed7/field.s7i
lib/seed7/file.s7i