aboutsummaryrefslogtreecommitdiff
path: root/lang/seed7
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-01-09 16:48:22 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-01-09 16:48:22 +0000
commit03cbe8187325cccf563fc287785019224293c7e2 (patch)
tree82d5bef4edd9e7a1674049706a33dcb50624b6c8 /lang/seed7
parentc20c2afd9822d23a018acd9444556fa0bda379ef (diff)
downloadports-03cbe8187325cccf563fc287785019224293c7e2.tar.gz
ports-03cbe8187325cccf563fc287785019224293c7e2.zip
Notes
Diffstat (limited to 'lang/seed7')
-rw-r--r--lang/seed7/Makefile16
-rw-r--r--lang/seed7/distinfo4
-rw-r--r--lang/seed7/files/patch-makefile12
-rw-r--r--lang/seed7/pkg-plist2
4 files changed, 14 insertions, 20 deletions
diff --git a/lang/seed7/Makefile b/lang/seed7/Makefile
index d41e432ce50f..57e686fe3340 100644
--- a/lang/seed7/Makefile
+++ b/lang/seed7/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seed7
-DISTVERSION= 05_20121212
+DISTVERSION= 05_20130105
CATEGORIES= lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}/
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -24,7 +24,7 @@ MAKE_ENV+= S7_LIB_DIR=${S7_LIB_DIR} \
SEED7_LIBRARY=${SEED7_LIBRARY} \
C_COMPILER=${CC} \
CPLUSPLUS_COMPILER=${CPP}
-ALL_TARGET= depend hi
+ALL_TARGET= depend s7
SEED7_LIBRARY= ${PREFIX}/lib/${PORTNAME}/lib
S7_LIB_DIR= ${PREFIX}/lib/${PORTNAME}/bin
@@ -33,6 +33,8 @@ S7_LIBS= s7_comp.a s7_con.a s7_draw.a s7_data.a seed7_05.a
PORTEXAMPLES= *
PORTDOCS= *
+.include <bsd.port.options.mk>
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800000
@@ -42,11 +44,11 @@ BROKEN= does not compile
post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g;' ${WRKSRC}/makefile
${REINPLACE_CMD} -e '/FLOATTYPE_DOUBLE/s|undef|define|' ${WRKSRC}/config.h
- ${REINPLACE_CMD} -i '' -e 's|./hi|${PREFIX}/bin/hi|g' ${WRKSRC}/../prg/chk_all.sd7
+ ${REINPLACE_CMD} -i '' -e 's|./s7|${PREFIX}/bin/s7|g' ${WRKSRC}/../prg/chk_all.sd7
do-install:
# install interpreter
- ${INSTALL_PROGRAM} ${WRKSRC}/../bin/hi ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/../bin/s7 ${PREFIX}/bin
# install seed7 library
${INSTALL} -d ${SEED7_LIBRARY}
cd ${WRKSRC}/../lib && ${COPYTREE_SHARE} '*.s7i' ${SEED7_LIBRARY}
@@ -60,7 +62,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/../prg/s7c ${PREFIX}/bin/s7c
${RM} ${WRKSRC}/../prg/tmp_s7c.c ${WRKSRC}/../prg/s7c
# install PORTDOCS
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${INSTALL} -d ${DOCSDIR}
cd ${WRKSRC}/../doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
@@ -70,9 +72,9 @@ do-install:
cd ${WRKSRC}/../prg && ${COPYTREE_SHARE} '*.dna *.sd7 *.dat *.s7i' ${EXAMPLESDIR}
.endif
-regression-test: install
+regression-test: ${INSTALL_TARGET}
@echo ""
@echo "Testing the ${PORTNAME} installation"
- @(cd ${WRKSRC}/../prg && ${PREFIX}/bin/hi chk_all)
+ @(cd ${WRKSRC}/../prg && ${PREFIX}/bin/s7 chk_all)
.include <bsd.port.post.mk>
diff --git a/lang/seed7/distinfo b/lang/seed7/distinfo
index 3baef662a245..684952da5539 100644
--- a/lang/seed7/distinfo
+++ b/lang/seed7/distinfo
@@ -1,2 +1,2 @@
-SHA256 (seed7_05_20121212.tgz) = d4f23d71e3f86ea81ff404e52a803f644d8fa505cde0da62895941c8ad73c67a
-SIZE (seed7_05_20121212.tgz) = 1801593
+SHA256 (seed7_05_20130105.tgz) = 72c166e1854acc4b424b512a44793c8f7ad392e710274a44aacbd2dcc9f5f28b
+SIZE (seed7_05_20130105.tgz) = 1806154
diff --git a/lang/seed7/files/patch-makefile b/lang/seed7/files/patch-makefile
index 084912c0754a..76026d4d3f84 100644
--- a/lang/seed7/files/patch-makefile
+++ b/lang/seed7/files/patch-makefile
@@ -9,10 +9,10 @@
# CFLAGS = -O2 -g -ffunction-sections -fdata-sections -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -std=c99 -Wall -Wstrict-prototypes -Winline -Wconversion -Wshadow -Wpointer-arith
# CFLAGS = -O2 -g -Wall -Winline -Wconversion -Wshadow -Wpointer-arith
-@@ -21,6 +21,7 @@
+@@ -21,6 +21,6 @@
# CFLAGS = -O2 -fomit-frame-pointer -funroll-loops -Wall
# CFLAGS = -O2 -funroll-loops -Wall -pg
- LDFLAGS = -Wl,--gc-sections
+-LDFLAGS = -Wl,--gc-sections
+LDFLAGS = -Wl,--gc-sections -L%%LOCALBASE%%/lib
# LDFLAGS = -pg
# LDFLAGS = -pg -lc_p
@@ -26,11 +26,3 @@
GET_CC_VERSION_INFO = $(CC) --version >
BIGINT_LIB_DEFINE = USE_BIG_RTL_LIBRARY
-@@ -113,6 +114,7 @@
- COMP_DATA_LIB_SRC = typ_data.c rfl_data.c ref_data.c listutl.c flistutl.c typeutl.c datautl.c
- COMPILER_LIB_SRC = $(PSRC1) $(LSRC1) $(LSRC2) $(LSRC3) $(ESRC1) $(ASRC1) $(ASRC2) $(ASRC3) $(GSRC1) $(GSRC2)
-
-+.PHONY: hi
- hi: ../bin/hi ../prg/hi
- ../bin/hi level
-
diff --git a/lang/seed7/pkg-plist b/lang/seed7/pkg-plist
index 09eb82196c85..068d73c6d5aa 100644
--- a/lang/seed7/pkg-plist
+++ b/lang/seed7/pkg-plist
@@ -1,4 +1,4 @@
-bin/hi
+bin/s7
bin/s7c
lib/seed7/bin/s7_comp.a
lib/seed7/bin/s7_con.a