aboutsummaryrefslogtreecommitdiff
path: root/lang/sketchy
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-07-06 07:54:14 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-07-06 07:54:14 +0000
commit30947d67039d03f6938d3976f16294d9fa082d32 (patch)
treefb213e1895f3ed27000867fe88bfc297c39eeef7 /lang/sketchy
parentaf4c603949b5b2d80ed84d1c416398f1b60e3dd1 (diff)
downloadports-30947d67039d03f6938d3976f16294d9fa082d32.tar.gz
ports-30947d67039d03f6938d3976f16294d9fa082d32.zip
Notes
Diffstat (limited to 'lang/sketchy')
-rw-r--r--lang/sketchy/Makefile2
-rw-r--r--lang/sketchy/distinfo4
-rw-r--r--lang/sketchy/pkg-plist111
3 files changed, 91 insertions, 26 deletions
diff --git a/lang/sketchy/Makefile b/lang/sketchy/Makefile
index 0a656ee32fca..292304b39295 100644
--- a/lang/sketchy/Makefile
+++ b/lang/sketchy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sketchy
-PORTVERSION= 20050526
+PORTVERSION= 20050705
CATEGORIES= lang devel lisp
MASTER_SITES= http://www.t3x.org/sketchy/
diff --git a/lang/sketchy/distinfo b/lang/sketchy/distinfo
index 837a08eecac3..1897a62c7336 100644
--- a/lang/sketchy/distinfo
+++ b/lang/sketchy/distinfo
@@ -1,2 +1,2 @@
-MD5 (sketchy-20050526.tar.gz) = 7bebc0bc13671e6a29a4843f7fbdb21d
-SIZE (sketchy-20050526.tar.gz) = 132032
+MD5 (sketchy-20050705.tar.gz) = d5fb9c50ecfab59e2028c7ab12d44f76
+SIZE (sketchy-20050705.tar.gz) = 151582
diff --git a/lang/sketchy/pkg-plist b/lang/sketchy/pkg-plist
index 7bacaee54f7a..f48534b9e5cc 100644
--- a/lang/sketchy/pkg-plist
+++ b/lang/sketchy/pkg-plist
@@ -7,9 +7,26 @@ bin/sk_install
%%DATADIR%%/lib/assoc.l
%%DATADIR%%/lib/assq.l
%%DATADIR%%/lib/booleanp.l
+%%DATADIR%%/lib/c-alphabeticp.l
+%%DATADIR%%/lib/c-cieqp.l
+%%DATADIR%%/lib/c-cigep.l
+%%DATADIR%%/lib/c-cigtp.l
+%%DATADIR%%/lib/c-cilep.l
+%%DATADIR%%/lib/c-ciltp.l
+%%DATADIR%%/lib/c-downcase.l
+%%DATADIR%%/lib/c-lower-casep.l
+%%DATADIR%%/lib/c-numericp.l
+%%DATADIR%%/lib/c-upcase.l
+%%DATADIR%%/lib/c-upper-casep.l
+%%DATADIR%%/lib/c-whitespacep.l
%%DATADIR%%/lib/caaaar.l
%%DATADIR%%/lib/caaar.l
%%DATADIR%%/lib/caar.l
+%%DATADIR%%/lib/ceqp.l
+%%DATADIR%%/lib/cgep.l
+%%DATADIR%%/lib/cgtp.l
+%%DATADIR%%/lib/clep.l
+%%DATADIR%%/lib/cltp.l
%%DATADIR%%/lib/count.l
%%DATADIR%%/lib/depth.l
%%DATADIR%%/lib/digits.l
@@ -18,6 +35,7 @@ bin/sk_install
%%DATADIR%%/lib/equalp.l
%%DATADIR%%/lib/evenp.l
%%DATADIR%%/lib/everyp.l
+%%DATADIR%%/lib/explode.l
%%DATADIR%%/lib/expt.l
%%DATADIR%%/lib/fact.l
%%DATADIR%%/lib/filter.l
@@ -27,6 +45,7 @@ bin/sk_install
%%DATADIR%%/lib/headp.l
%%DATADIR%%/lib/hyper.l
%%DATADIR%%/lib/id.l
+%%DATADIR%%/lib/implode.l
%%DATADIR%%/lib/insert.l
%%DATADIR%%/lib/integer.l
%%DATADIR%%/lib/intersection.l
@@ -39,8 +58,8 @@ bin/sk_install
%%DATADIR%%/lib/less.l
%%DATADIR%%/lib/list-ref.l
%%DATADIR%%/lib/list-tail.l
+%%DATADIR%%/lib/list.l
%%DATADIR%%/lib/listp.l
-%%DATADIR%%/lib/listtonumber.l
%%DATADIR%%/lib/logand.l
%%DATADIR%%/lib/logeqv.l
%%DATADIR%%/lib/lognand.l
@@ -62,9 +81,9 @@ bin/sk_install
%%DATADIR%%/lib/natural.l
%%DATADIR%%/lib/naturalp.l
%%DATADIR%%/lib/ndivide.l
+%%DATADIR%%/lib/neqp.l
%%DATADIR%%/lib/negate.l
%%DATADIR%%/lib/negativep.l
-%%DATADIR%%/lib/neqp.l
%%DATADIR%%/lib/nexpt.l
%%DATADIR%%/lib/ngreater.l
%%DATADIR%%/lib/ngteq.l
@@ -79,7 +98,7 @@ bin/sk_install
%%DATADIR%%/lib/nquotient.l
%%DATADIR%%/lib/nremainder.l
%%DATADIR%%/lib/ntimes.l
-%%DATADIR%%/lib/numbertolist.l
+%%DATADIR%%/lib/numtostr.l
%%DATADIR%%/lib/oddp.l
%%DATADIR%%/lib/onep.l
%%DATADIR%%/lib/orderedp.l
@@ -95,16 +114,31 @@ bin/sk_install
%%DATADIR%%/lib/remainder.l
%%DATADIR%%/lib/remove.l
%%DATADIR%%/lib/reverse.l
+%%DATADIR%%/lib/s-append.l
+%%DATADIR%%/lib/s-cieqp.l
+%%DATADIR%%/lib/s-cigep.l
+%%DATADIR%%/lib/s-cigtp.l
+%%DATADIR%%/lib/s-cilep.l
+%%DATADIR%%/lib/s-ciltp.l
+%%DATADIR%%/lib/s-length.l
+%%DATADIR%%/lib/s-ref.l
+%%DATADIR%%/lib/seqp.l
+%%DATADIR%%/lib/sgep.l
+%%DATADIR%%/lib/sgtp.l
%%DATADIR%%/lib/sketchy-ext.l
%%DATADIR%%/lib/sketchy.l
+%%DATADIR%%/lib/slep.l
+%%DATADIR%%/lib/sltp.l
%%DATADIR%%/lib/some.l
%%DATADIR%%/lib/sort.l
%%DATADIR%%/lib/sqrt.l
+%%DATADIR%%/lib/string.l
+%%DATADIR%%/lib/strtonum.l
%%DATADIR%%/lib/sublist.l
%%DATADIR%%/lib/subst.l
+%%DATADIR%%/lib/substring.l
%%DATADIR%%/lib/succ.l
%%DATADIR%%/lib/sum.l
-%%DATADIR%%/lib/symbolp.l
%%DATADIR%%/lib/tailp.l
%%DATADIR%%/lib/times.l
%%DATADIR%%/lib/union.l
@@ -118,11 +152,6 @@ bin/sk_install
%%DATADIR%%/src/hanoi.l
%%DATADIR%%/src/infix.l
%%DATADIR%%/src/lvrename.l
-%%DATADIR%%/src/mexpr-append.m
-%%DATADIR%%/src/mexpr-fac.m
-%%DATADIR%%/src/mexpr-hanoi.m
-%%DATADIR%%/src/mexpr-queens.m
-%%DATADIR%%/src/mexprc.l
%%DATADIR%%/src/prefix.l
%%DATADIR%%/src/prolog.l
%%DATADIR%%/src/queens.l
@@ -137,9 +166,26 @@ bin/sk_install
%%DOCSDIR%%/library/assoc.html
%%DOCSDIR%%/library/assq.html
%%DOCSDIR%%/library/booleanp.html
+%%DOCSDIR%%/library/c-alphabeticp.html
+%%DOCSDIR%%/library/c-cieqp.html
+%%DOCSDIR%%/library/c-cigep.html
+%%DOCSDIR%%/library/c-cigtp.html
+%%DOCSDIR%%/library/c-cilep.html
+%%DOCSDIR%%/library/c-ciltp.html
+%%DOCSDIR%%/library/c-downcase.html
+%%DOCSDIR%%/library/c-lower-casep.html
+%%DOCSDIR%%/library/c-numericp.html
+%%DOCSDIR%%/library/c-upcase.html
+%%DOCSDIR%%/library/c-upper-casep.html
+%%DOCSDIR%%/library/c-whitespacep.html
%%DOCSDIR%%/library/caaaar.html
%%DOCSDIR%%/library/caaar.html
%%DOCSDIR%%/library/caar.html
+%%DOCSDIR%%/library/ceqp.html
+%%DOCSDIR%%/library/cgep.html
+%%DOCSDIR%%/library/cgtp.html
+%%DOCSDIR%%/library/clep.html
+%%DOCSDIR%%/library/cltp.html
%%DOCSDIR%%/library/count.html
%%DOCSDIR%%/library/depth.html
%%DOCSDIR%%/library/digits.html
@@ -148,6 +194,7 @@ bin/sk_install
%%DOCSDIR%%/library/equalp.html
%%DOCSDIR%%/library/evenp.html
%%DOCSDIR%%/library/everyp.html
+%%DOCSDIR%%/library/explode.html
%%DOCSDIR%%/library/expt.html
%%DOCSDIR%%/library/fact.html
%%DOCSDIR%%/library/filter.html
@@ -157,6 +204,7 @@ bin/sk_install
%%DOCSDIR%%/library/headp.html
%%DOCSDIR%%/library/hyper.html
%%DOCSDIR%%/library/id.html
+%%DOCSDIR%%/library/implode.html
%%DOCSDIR%%/library/index.html
%%DOCSDIR%%/library/insert.html
%%DOCSDIR%%/library/integer.html
@@ -170,8 +218,8 @@ bin/sk_install
%%DOCSDIR%%/library/less.html
%%DOCSDIR%%/library/list-ref.html
%%DOCSDIR%%/library/list-tail.html
+%%DOCSDIR%%/library/list.html
%%DOCSDIR%%/library/listp.html
-%%DOCSDIR%%/library/listtonumber.html
%%DOCSDIR%%/library/logand.html
%%DOCSDIR%%/library/logeqv.html
%%DOCSDIR%%/library/lognand.html
@@ -181,8 +229,8 @@ bin/sk_install
%%DOCSDIR%%/library/logor.html
%%DOCSDIR%%/library/lteq.html
%%DOCSDIR%%/library/map.html
-%%DOCSDIR%%/library/maplist.html
%%DOCSDIR%%/library/max.html
+%%DOCSDIR%%/library/maplist.html
%%DOCSDIR%%/library/member.html
%%DOCSDIR%%/library/memberp.html
%%DOCSDIR%%/library/memq.html
@@ -210,7 +258,7 @@ bin/sk_install
%%DOCSDIR%%/library/nquotient.html
%%DOCSDIR%%/library/nremainder.html
%%DOCSDIR%%/library/ntimes.html
-%%DOCSDIR%%/library/numbertolist.html
+%%DOCSDIR%%/library/numtostr.html
%%DOCSDIR%%/library/oddp.html
%%DOCSDIR%%/library/onep.html
%%DOCSDIR%%/library/orderedp.html
@@ -226,16 +274,31 @@ bin/sk_install
%%DOCSDIR%%/library/remainder.html
%%DOCSDIR%%/library/remove.html
%%DOCSDIR%%/library/reverse.html
+%%DOCSDIR%%/library/s-append.html
+%%DOCSDIR%%/library/s-cieqp.html
+%%DOCSDIR%%/library/s-cigep.html
+%%DOCSDIR%%/library/s-cigtp.html
+%%DOCSDIR%%/library/s-cilep.html
+%%DOCSDIR%%/library/s-ciltp.html
+%%DOCSDIR%%/library/s-length.html
+%%DOCSDIR%%/library/s-ref.html
+%%DOCSDIR%%/library/seqp.html
+%%DOCSDIR%%/library/sgep.html
+%%DOCSDIR%%/library/sgtp.html
%%DOCSDIR%%/library/sketchy-ext.html
%%DOCSDIR%%/library/sketchy.html
+%%DOCSDIR%%/library/slep.html
+%%DOCSDIR%%/library/sltp.html
%%DOCSDIR%%/library/some.html
%%DOCSDIR%%/library/sort.html
%%DOCSDIR%%/library/sqrt.html
+%%DOCSDIR%%/library/string.html
+%%DOCSDIR%%/library/strtonum.html
%%DOCSDIR%%/library/sublist.html
%%DOCSDIR%%/library/subst.html
+%%DOCSDIR%%/library/substring.html
%%DOCSDIR%%/library/succ.html
%%DOCSDIR%%/library/sum.html
-%%DOCSDIR%%/library/symbolp.html
%%DOCSDIR%%/library/tailp.html
%%DOCSDIR%%/library/times.html
%%DOCSDIR%%/library/union.html
@@ -243,16 +306,18 @@ bin/sk_install
%%DOCSDIR%%/library/unsort.html
%%DOCSDIR%%/library/zerop.html
%%DOCSDIR%%/index.html
-%%DOCSDIR%%/sketchy1.html
-%%DOCSDIR%%/sketchy10.html
-%%DOCSDIR%%/sketchy2.html
-%%DOCSDIR%%/sketchy3.html
-%%DOCSDIR%%/sketchy4.html
-%%DOCSDIR%%/sketchy5.html
-%%DOCSDIR%%/sketchy6.html
-%%DOCSDIR%%/sketchy7.html
-%%DOCSDIR%%/sketchy8.html
-%%DOCSDIR%%/sketchy9.html
+%%DOCSDIR%%/ndx.html
+%%DOCSDIR%%/sk01.html
+%%DOCSDIR%%/sk02.html
+%%DOCSDIR%%/sk03.html
+%%DOCSDIR%%/sk04.html
+%%DOCSDIR%%/sk05.html
+%%DOCSDIR%%/sk06.html
+%%DOCSDIR%%/sk06b.html
+%%DOCSDIR%%/sk07.html
+%%DOCSDIR%%/sk08.html
+%%DOCSDIR%%/sk09.html
+%%DOCSDIR%%/toc.html
%%DOCSDIR%%/sketchy.css
@dirrm %%DATADIR%%/lib
@dirrm %%DATADIR%%/src