aboutsummaryrefslogtreecommitdiff
path: root/lang/sketchy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-05-26 20:00:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-05-26 20:00:59 +0000
commit5a7a609e67fc87e247a0200004b8c7d666a2083c (patch)
tree560c00e912cca9d176dac4b11adab0b74c114952 /lang/sketchy
parentb60280b9cff12e2b5872086413a259961b6081ba (diff)
downloadports-5a7a609e67fc87e247a0200004b8c7d666a2083c.tar.gz
ports-5a7a609e67fc87e247a0200004b8c7d666a2083c.zip
Notes
Diffstat (limited to 'lang/sketchy')
-rw-r--r--lang/sketchy/Makefile4
-rw-r--r--lang/sketchy/distinfo3
-rw-r--r--lang/sketchy/pkg-descr12
-rw-r--r--lang/sketchy/pkg-plist28
4 files changed, 28 insertions, 19 deletions
diff --git a/lang/sketchy/Makefile b/lang/sketchy/Makefile
index 892632a1da05..0a656ee32fca 100644
--- a/lang/sketchy/Makefile
+++ b/lang/sketchy/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= sketchy
-PORTVERSION= 20050512
+PORTVERSION= 20050526
CATEGORIES= lang devel lisp
MASTER_SITES= http://www.t3x.org/sketchy/
MAINTAINER= nmh@t3x.org
-COMMENT= An interpreter for purely symbolic LISP that smells like Scheme
+COMMENT= An interpreter for a purely applicative dialect of Scheme
BUILD_DEPENDS= tx:${PORTSDIR}/lang/t3x
diff --git a/lang/sketchy/distinfo b/lang/sketchy/distinfo
index febee6c3e6b0..837a08eecac3 100644
--- a/lang/sketchy/distinfo
+++ b/lang/sketchy/distinfo
@@ -1 +1,2 @@
-MD5 (sketchy-20050512.tar.gz) = f15834fb57011ca04510001b1dc5936c
+MD5 (sketchy-20050526.tar.gz) = 7bebc0bc13671e6a29a4843f7fbdb21d
+SIZE (sketchy-20050526.tar.gz) = 132032
diff --git a/lang/sketchy/pkg-descr b/lang/sketchy/pkg-descr
index 4a47bdbe1bdc..8afbce5df1e4 100644
--- a/lang/sketchy/pkg-descr
+++ b/lang/sketchy/pkg-descr
@@ -1,9 +1,11 @@
-SketchyLISP is a small, tail-recursive, lexically scoped interpreter for
-purely symbolic dialect of LISP that smells like Scheme. It may be considered
-an implementation of pure LISP plus DEFINE and CALL/CC.
+SketchyLISP is a small, tail-recursive, lexically scoped
+interpreter for a purely applicative dialect of Scheme.
+It may be considered an implementation of pure LISP plus
+global definitions (DEFINE) and first-class continuations
+(CALL/CC).
-This package contains the SketchyLISP interpreter and library, the reference
-manual, and example programs.
+This package contains the SketchyLISP interpreter and library,
+the reference manual, and example programs.
WWW: http://www.t3x.org/sketchy/
diff --git a/lang/sketchy/pkg-plist b/lang/sketchy/pkg-plist
index bc9f0c20dd63..7bacaee54f7a 100644
--- a/lang/sketchy/pkg-plist
+++ b/lang/sketchy/pkg-plist
@@ -28,10 +28,11 @@ bin/sk_install
%%DATADIR%%/lib/hyper.l
%%DATADIR%%/lib/id.l
%%DATADIR%%/lib/insert.l
-%%DATADIR%%/lib/iota.l
%%DATADIR%%/lib/integer.l
%%DATADIR%%/lib/intersection.l
+%%DATADIR%%/lib/iota.l
%%DATADIR%%/lib/isort.l
+%%DATADIR%%/lib/iterate.l
%%DATADIR%%/lib/last.l
%%DATADIR%%/lib/lcm.l
%%DATADIR%%/lib/length.l
@@ -39,6 +40,7 @@ bin/sk_install
%%DATADIR%%/lib/list-ref.l
%%DATADIR%%/lib/list-tail.l
%%DATADIR%%/lib/listp.l
+%%DATADIR%%/lib/listtonumber.l
%%DATADIR%%/lib/logand.l
%%DATADIR%%/lib/logeqv.l
%%DATADIR%%/lib/lognand.l
@@ -49,17 +51,18 @@ bin/sk_install
%%DATADIR%%/lib/lteq.l
%%DATADIR%%/lib/map.l
%%DATADIR%%/lib/maplist.l
-%%DATADIR%%/lib/max-list.l
+%%DATADIR%%/lib/max.l
%%DATADIR%%/lib/member.l
%%DATADIR%%/lib/memberp.l
%%DATADIR%%/lib/memq.l
%%DATADIR%%/lib/memqp.l
-%%DATADIR%%/lib/min-list.l
+%%DATADIR%%/lib/min.l
%%DATADIR%%/lib/minus.l
%%DATADIR%%/lib/modulo.l
%%DATADIR%%/lib/natural.l
%%DATADIR%%/lib/naturalp.l
%%DATADIR%%/lib/ndivide.l
+%%DATADIR%%/lib/negate.l
%%DATADIR%%/lib/negativep.l
%%DATADIR%%/lib/neqp.l
%%DATADIR%%/lib/nexpt.l
@@ -68,6 +71,7 @@ bin/sk_install
%%DATADIR%%/lib/nless.l
%%DATADIR%%/lib/nlteq.l
%%DATADIR%%/lib/nminus.l
+%%DATADIR%%/lib/non-negativep.l
%%DATADIR%%/lib/normalize.l
%%DATADIR%%/lib/not-equalp.l
%%DATADIR%%/lib/not.l
@@ -75,7 +79,7 @@ bin/sk_install
%%DATADIR%%/lib/nquotient.l
%%DATADIR%%/lib/nremainder.l
%%DATADIR%%/lib/ntimes.l
-%%DATADIR%%/lib/numberp.l
+%%DATADIR%%/lib/numbertolist.l
%%DATADIR%%/lib/oddp.l
%%DATADIR%%/lib/onep.l
%%DATADIR%%/lib/orderedp.l
@@ -84,7 +88,6 @@ bin/sk_install
%%DATADIR%%/lib/plus.l
%%DATADIR%%/lib/positivep.l
%%DATADIR%%/lib/pred.l
-%%DATADIR%%/lib/procedurep.l
%%DATADIR%%/lib/product.l
%%DATADIR%%/lib/quicksort.l
%%DATADIR%%/lib/quotient.l
@@ -97,7 +100,7 @@ bin/sk_install
%%DATADIR%%/lib/some.l
%%DATADIR%%/lib/sort.l
%%DATADIR%%/lib/sqrt.l
-%%DATADIR%%/lib/sublis.l
+%%DATADIR%%/lib/sublist.l
%%DATADIR%%/lib/subst.l
%%DATADIR%%/lib/succ.l
%%DATADIR%%/lib/sum.l
@@ -160,6 +163,7 @@ bin/sk_install
%%DOCSDIR%%/library/intersection.html
%%DOCSDIR%%/library/iota.html
%%DOCSDIR%%/library/isort.html
+%%DOCSDIR%%/library/iterate.html
%%DOCSDIR%%/library/last.html
%%DOCSDIR%%/library/lcm.html
%%DOCSDIR%%/library/length.html
@@ -167,6 +171,7 @@ bin/sk_install
%%DOCSDIR%%/library/list-ref.html
%%DOCSDIR%%/library/list-tail.html
%%DOCSDIR%%/library/listp.html
+%%DOCSDIR%%/library/listtonumber.html
%%DOCSDIR%%/library/logand.html
%%DOCSDIR%%/library/logeqv.html
%%DOCSDIR%%/library/lognand.html
@@ -177,17 +182,18 @@ bin/sk_install
%%DOCSDIR%%/library/lteq.html
%%DOCSDIR%%/library/map.html
%%DOCSDIR%%/library/maplist.html
-%%DOCSDIR%%/library/max-list.html
+%%DOCSDIR%%/library/max.html
%%DOCSDIR%%/library/member.html
%%DOCSDIR%%/library/memberp.html
%%DOCSDIR%%/library/memq.html
%%DOCSDIR%%/library/memqp.html
-%%DOCSDIR%%/library/min-list.html
+%%DOCSDIR%%/library/min.html
%%DOCSDIR%%/library/minus.html
%%DOCSDIR%%/library/modulo.html
%%DOCSDIR%%/library/natural.html
%%DOCSDIR%%/library/naturalp.html
%%DOCSDIR%%/library/ndivide.html
+%%DOCSDIR%%/library/negate.html
%%DOCSDIR%%/library/negativep.html
%%DOCSDIR%%/library/neqp.html
%%DOCSDIR%%/library/nexpt.html
@@ -196,6 +202,7 @@ bin/sk_install
%%DOCSDIR%%/library/nless.html
%%DOCSDIR%%/library/nlteq.html
%%DOCSDIR%%/library/nminus.html
+%%DOCSDIR%%/library/non-negativep.html
%%DOCSDIR%%/library/normalize.html
%%DOCSDIR%%/library/not-equalp.html
%%DOCSDIR%%/library/not.html
@@ -203,7 +210,7 @@ bin/sk_install
%%DOCSDIR%%/library/nquotient.html
%%DOCSDIR%%/library/nremainder.html
%%DOCSDIR%%/library/ntimes.html
-%%DOCSDIR%%/library/numberp.html
+%%DOCSDIR%%/library/numbertolist.html
%%DOCSDIR%%/library/oddp.html
%%DOCSDIR%%/library/onep.html
%%DOCSDIR%%/library/orderedp.html
@@ -212,7 +219,6 @@ bin/sk_install
%%DOCSDIR%%/library/plus.html
%%DOCSDIR%%/library/positivep.html
%%DOCSDIR%%/library/pred.html
-%%DOCSDIR%%/library/procedurep.html
%%DOCSDIR%%/library/product.html
%%DOCSDIR%%/library/quicksort.html
%%DOCSDIR%%/library/quotient.html
@@ -225,7 +231,7 @@ bin/sk_install
%%DOCSDIR%%/library/some.html
%%DOCSDIR%%/library/sort.html
%%DOCSDIR%%/library/sqrt.html
-%%DOCSDIR%%/library/sublis.html
+%%DOCSDIR%%/library/sublist.html
%%DOCSDIR%%/library/subst.html
%%DOCSDIR%%/library/succ.html
%%DOCSDIR%%/library/sum.html