aboutsummaryrefslogtreecommitdiff
path: root/lang/sketchy
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 21:46:43 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-16 21:46:43 +0000
commit62f1cf76577924cce867adf95c023f6cba10c0f4 (patch)
tree24147e0d969bbe1ca8992d9db39eaf2bc90ca5d8 /lang/sketchy
parent0dea95832588cdd9eb38b5115b1781944da580e0 (diff)
downloadports-62f1cf76577924cce867adf95c023f6cba10c0f4.tar.gz
ports-62f1cf76577924cce867adf95c023f6cba10c0f4.zip
Notes
Diffstat (limited to 'lang/sketchy')
-rw-r--r--lang/sketchy/Makefile25
-rw-r--r--lang/sketchy/distinfo1
-rw-r--r--lang/sketchy/pkg-descr11
-rw-r--r--lang/sketchy/pkg-plist255
4 files changed, 292 insertions, 0 deletions
diff --git a/lang/sketchy/Makefile b/lang/sketchy/Makefile
new file mode 100644
index 000000000000..892632a1da05
--- /dev/null
+++ b/lang/sketchy/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: SketchyLISP
+# Date created: 12 May 2005
+# Whom: Nils M Holm <nmh@t3x.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sketchy
+PORTVERSION= 20050512
+CATEGORIES= lang devel lisp
+MASTER_SITES= http://www.t3x.org/sketchy/
+
+MAINTAINER= nmh@t3x.org
+COMMENT= An interpreter for purely symbolic LISP that smells like Scheme
+
+BUILD_DEPENDS= tx:${PORTSDIR}/lang/t3x
+
+MAN7= sketchy.7
+
+MAKE_ENV+= T3XDIR=${LOCALBASE}/t3x/r8 \
+ BINOWN=${BINOWN} \
+ BINGRP=${BINGRP} \
+ PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/lang/sketchy/distinfo b/lang/sketchy/distinfo
new file mode 100644
index 000000000000..febee6c3e6b0
--- /dev/null
+++ b/lang/sketchy/distinfo
@@ -0,0 +1 @@
+MD5 (sketchy-20050512.tar.gz) = f15834fb57011ca04510001b1dc5936c
diff --git a/lang/sketchy/pkg-descr b/lang/sketchy/pkg-descr
new file mode 100644
index 000000000000..4a47bdbe1bdc
--- /dev/null
+++ b/lang/sketchy/pkg-descr
@@ -0,0 +1,11 @@
+SketchyLISP is a small, tail-recursive, lexically scoped interpreter for
+purely symbolic dialect of LISP that smells like Scheme. It may be considered
+an implementation of pure LISP plus DEFINE and CALL/CC.
+
+This package contains the SketchyLISP interpreter and library, the reference
+manual, and example programs.
+
+WWW: http://www.t3x.org/sketchy/
+
+- Nils M Holm
+nmh@t3x.org
diff --git a/lang/sketchy/pkg-plist b/lang/sketchy/pkg-plist
new file mode 100644
index 000000000000..bc9f0c20dd63
--- /dev/null
+++ b/lang/sketchy/pkg-plist
@@ -0,0 +1,255 @@
+bin/Sk
+bin/sketchy
+bin/sk_install
+%%DATADIR%%/lib/abs.l
+%%DATADIR%%/lib/anyp.l
+%%DATADIR%%/lib/append.l
+%%DATADIR%%/lib/assoc.l
+%%DATADIR%%/lib/assq.l
+%%DATADIR%%/lib/booleanp.l
+%%DATADIR%%/lib/caaaar.l
+%%DATADIR%%/lib/caaar.l
+%%DATADIR%%/lib/caar.l
+%%DATADIR%%/lib/count.l
+%%DATADIR%%/lib/depth.l
+%%DATADIR%%/lib/digits.l
+%%DATADIR%%/lib/divide.l
+%%DATADIR%%/lib/equal.l
+%%DATADIR%%/lib/equalp.l
+%%DATADIR%%/lib/evenp.l
+%%DATADIR%%/lib/everyp.l
+%%DATADIR%%/lib/expt.l
+%%DATADIR%%/lib/fact.l
+%%DATADIR%%/lib/filter.l
+%%DATADIR%%/lib/gcd.l
+%%DATADIR%%/lib/greater.l
+%%DATADIR%%/lib/gteq.l
+%%DATADIR%%/lib/headp.l
+%%DATADIR%%/lib/hyper.l
+%%DATADIR%%/lib/id.l
+%%DATADIR%%/lib/insert.l
+%%DATADIR%%/lib/iota.l
+%%DATADIR%%/lib/integer.l
+%%DATADIR%%/lib/intersection.l
+%%DATADIR%%/lib/isort.l
+%%DATADIR%%/lib/last.l
+%%DATADIR%%/lib/lcm.l
+%%DATADIR%%/lib/length.l
+%%DATADIR%%/lib/less.l
+%%DATADIR%%/lib/list-ref.l
+%%DATADIR%%/lib/list-tail.l
+%%DATADIR%%/lib/listp.l
+%%DATADIR%%/lib/logand.l
+%%DATADIR%%/lib/logeqv.l
+%%DATADIR%%/lib/lognand.l
+%%DATADIR%%/lib/logneqv.l
+%%DATADIR%%/lib/lognor.l
+%%DATADIR%%/lib/lognot.l
+%%DATADIR%%/lib/logor.l
+%%DATADIR%%/lib/lteq.l
+%%DATADIR%%/lib/map.l
+%%DATADIR%%/lib/maplist.l
+%%DATADIR%%/lib/max-list.l
+%%DATADIR%%/lib/member.l
+%%DATADIR%%/lib/memberp.l
+%%DATADIR%%/lib/memq.l
+%%DATADIR%%/lib/memqp.l
+%%DATADIR%%/lib/min-list.l
+%%DATADIR%%/lib/minus.l
+%%DATADIR%%/lib/modulo.l
+%%DATADIR%%/lib/natural.l
+%%DATADIR%%/lib/naturalp.l
+%%DATADIR%%/lib/ndivide.l
+%%DATADIR%%/lib/negativep.l
+%%DATADIR%%/lib/neqp.l
+%%DATADIR%%/lib/nexpt.l
+%%DATADIR%%/lib/ngreater.l
+%%DATADIR%%/lib/ngteq.l
+%%DATADIR%%/lib/nless.l
+%%DATADIR%%/lib/nlteq.l
+%%DATADIR%%/lib/nminus.l
+%%DATADIR%%/lib/normalize.l
+%%DATADIR%%/lib/not-equalp.l
+%%DATADIR%%/lib/not.l
+%%DATADIR%%/lib/nplus.l
+%%DATADIR%%/lib/nquotient.l
+%%DATADIR%%/lib/nremainder.l
+%%DATADIR%%/lib/ntimes.l
+%%DATADIR%%/lib/numberp.l
+%%DATADIR%%/lib/oddp.l
+%%DATADIR%%/lib/onep.l
+%%DATADIR%%/lib/orderedp.l
+%%DATADIR%%/lib/pair.l
+%%DATADIR%%/lib/permute.l
+%%DATADIR%%/lib/plus.l
+%%DATADIR%%/lib/positivep.l
+%%DATADIR%%/lib/pred.l
+%%DATADIR%%/lib/procedurep.l
+%%DATADIR%%/lib/product.l
+%%DATADIR%%/lib/quicksort.l
+%%DATADIR%%/lib/quotient.l
+%%DATADIR%%/lib/reduce.l
+%%DATADIR%%/lib/remainder.l
+%%DATADIR%%/lib/remove.l
+%%DATADIR%%/lib/reverse.l
+%%DATADIR%%/lib/sketchy-ext.l
+%%DATADIR%%/lib/sketchy.l
+%%DATADIR%%/lib/some.l
+%%DATADIR%%/lib/sort.l
+%%DATADIR%%/lib/sqrt.l
+%%DATADIR%%/lib/sublis.l
+%%DATADIR%%/lib/subst.l
+%%DATADIR%%/lib/succ.l
+%%DATADIR%%/lib/sum.l
+%%DATADIR%%/lib/symbolp.l
+%%DATADIR%%/lib/tailp.l
+%%DATADIR%%/lib/times.l
+%%DATADIR%%/lib/union.l
+%%DATADIR%%/lib/unique.l
+%%DATADIR%%/lib/unsort.l
+%%DATADIR%%/lib/zerop.l
+%%DATADIR%%/src/bottles.l
+%%DATADIR%%/src/bubblesort.l
+%%DATADIR%%/src/date.l
+%%DATADIR%%/src/evaluate.l
+%%DATADIR%%/src/hanoi.l
+%%DATADIR%%/src/infix.l
+%%DATADIR%%/src/lvrename.l
+%%DATADIR%%/src/mexpr-append.m
+%%DATADIR%%/src/mexpr-fac.m
+%%DATADIR%%/src/mexpr-hanoi.m
+%%DATADIR%%/src/mexpr-queens.m
+%%DATADIR%%/src/mexprc.l
+%%DATADIR%%/src/prefix.l
+%%DATADIR%%/src/prolog.l
+%%DATADIR%%/src/queens.l
+%%DATADIR%%/src/tree.l
+%%DATADIR%%/src/unlabel.l
+%%DATADIR%%/src/xeval.l
+%%DATADIR%%/sketchy.image
+%%DATADIR%%/LICENSE
+%%DOCSDIR%%/library/abs.html
+%%DOCSDIR%%/library/anyp.html
+%%DOCSDIR%%/library/append.html
+%%DOCSDIR%%/library/assoc.html
+%%DOCSDIR%%/library/assq.html
+%%DOCSDIR%%/library/booleanp.html
+%%DOCSDIR%%/library/caaaar.html
+%%DOCSDIR%%/library/caaar.html
+%%DOCSDIR%%/library/caar.html
+%%DOCSDIR%%/library/count.html
+%%DOCSDIR%%/library/depth.html
+%%DOCSDIR%%/library/digits.html
+%%DOCSDIR%%/library/divide.html
+%%DOCSDIR%%/library/equal.html
+%%DOCSDIR%%/library/equalp.html
+%%DOCSDIR%%/library/evenp.html
+%%DOCSDIR%%/library/everyp.html
+%%DOCSDIR%%/library/expt.html
+%%DOCSDIR%%/library/fact.html
+%%DOCSDIR%%/library/filter.html
+%%DOCSDIR%%/library/gcd.html
+%%DOCSDIR%%/library/greater.html
+%%DOCSDIR%%/library/gteq.html
+%%DOCSDIR%%/library/headp.html
+%%DOCSDIR%%/library/hyper.html
+%%DOCSDIR%%/library/id.html
+%%DOCSDIR%%/library/index.html
+%%DOCSDIR%%/library/insert.html
+%%DOCSDIR%%/library/integer.html
+%%DOCSDIR%%/library/intersection.html
+%%DOCSDIR%%/library/iota.html
+%%DOCSDIR%%/library/isort.html
+%%DOCSDIR%%/library/last.html
+%%DOCSDIR%%/library/lcm.html
+%%DOCSDIR%%/library/length.html
+%%DOCSDIR%%/library/less.html
+%%DOCSDIR%%/library/list-ref.html
+%%DOCSDIR%%/library/list-tail.html
+%%DOCSDIR%%/library/listp.html
+%%DOCSDIR%%/library/logand.html
+%%DOCSDIR%%/library/logeqv.html
+%%DOCSDIR%%/library/lognand.html
+%%DOCSDIR%%/library/logneqv.html
+%%DOCSDIR%%/library/lognor.html
+%%DOCSDIR%%/library/lognot.html
+%%DOCSDIR%%/library/logor.html
+%%DOCSDIR%%/library/lteq.html
+%%DOCSDIR%%/library/map.html
+%%DOCSDIR%%/library/maplist.html
+%%DOCSDIR%%/library/max-list.html
+%%DOCSDIR%%/library/member.html
+%%DOCSDIR%%/library/memberp.html
+%%DOCSDIR%%/library/memq.html
+%%DOCSDIR%%/library/memqp.html
+%%DOCSDIR%%/library/min-list.html
+%%DOCSDIR%%/library/minus.html
+%%DOCSDIR%%/library/modulo.html
+%%DOCSDIR%%/library/natural.html
+%%DOCSDIR%%/library/naturalp.html
+%%DOCSDIR%%/library/ndivide.html
+%%DOCSDIR%%/library/negativep.html
+%%DOCSDIR%%/library/neqp.html
+%%DOCSDIR%%/library/nexpt.html
+%%DOCSDIR%%/library/ngreater.html
+%%DOCSDIR%%/library/ngteq.html
+%%DOCSDIR%%/library/nless.html
+%%DOCSDIR%%/library/nlteq.html
+%%DOCSDIR%%/library/nminus.html
+%%DOCSDIR%%/library/normalize.html
+%%DOCSDIR%%/library/not-equalp.html
+%%DOCSDIR%%/library/not.html
+%%DOCSDIR%%/library/nplus.html
+%%DOCSDIR%%/library/nquotient.html
+%%DOCSDIR%%/library/nremainder.html
+%%DOCSDIR%%/library/ntimes.html
+%%DOCSDIR%%/library/numberp.html
+%%DOCSDIR%%/library/oddp.html
+%%DOCSDIR%%/library/onep.html
+%%DOCSDIR%%/library/orderedp.html
+%%DOCSDIR%%/library/pair.html
+%%DOCSDIR%%/library/permute.html
+%%DOCSDIR%%/library/plus.html
+%%DOCSDIR%%/library/positivep.html
+%%DOCSDIR%%/library/pred.html
+%%DOCSDIR%%/library/procedurep.html
+%%DOCSDIR%%/library/product.html
+%%DOCSDIR%%/library/quicksort.html
+%%DOCSDIR%%/library/quotient.html
+%%DOCSDIR%%/library/reduce.html
+%%DOCSDIR%%/library/remainder.html
+%%DOCSDIR%%/library/remove.html
+%%DOCSDIR%%/library/reverse.html
+%%DOCSDIR%%/library/sketchy-ext.html
+%%DOCSDIR%%/library/sketchy.html
+%%DOCSDIR%%/library/some.html
+%%DOCSDIR%%/library/sort.html
+%%DOCSDIR%%/library/sqrt.html
+%%DOCSDIR%%/library/sublis.html
+%%DOCSDIR%%/library/subst.html
+%%DOCSDIR%%/library/succ.html
+%%DOCSDIR%%/library/sum.html
+%%DOCSDIR%%/library/symbolp.html
+%%DOCSDIR%%/library/tailp.html
+%%DOCSDIR%%/library/times.html
+%%DOCSDIR%%/library/union.html
+%%DOCSDIR%%/library/unique.html
+%%DOCSDIR%%/library/unsort.html
+%%DOCSDIR%%/library/zerop.html
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/sketchy1.html
+%%DOCSDIR%%/sketchy10.html
+%%DOCSDIR%%/sketchy2.html
+%%DOCSDIR%%/sketchy3.html
+%%DOCSDIR%%/sketchy4.html
+%%DOCSDIR%%/sketchy5.html
+%%DOCSDIR%%/sketchy6.html
+%%DOCSDIR%%/sketchy7.html
+%%DOCSDIR%%/sketchy8.html
+%%DOCSDIR%%/sketchy9.html
+%%DOCSDIR%%/sketchy.css
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/src
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/library
+@dirrm %%DOCSDIR%%