aboutsummaryrefslogtreecommitdiff
path: root/lang/smalltalk/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2008-03-07 14:02:11 +0000
committerJohan van Selst <johans@FreeBSD.org>2008-03-07 14:02:11 +0000
commit63fe61d1783052ac8034f34a2f74ab053b85ae24 (patch)
tree7f2b62043a42659be3a9f467b823a76842039d92 /lang/smalltalk/Makefile
parent34f886dcca7cc0b37c822cf572e24f08ce5520e4 (diff)
downloadports-63fe61d1783052ac8034f34a2f74ab053b85ae24.tar.gz
ports-63fe61d1783052ac8034f34a2f74ab053b85ae24.zip
Notes
Diffstat (limited to 'lang/smalltalk/Makefile')
-rw-r--r--lang/smalltalk/Makefile19
1 files changed, 16 insertions, 3 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 8a9dc46f1ea6..96d1e219b089 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smalltalk
-PORTVERSION= 2.3.6
+PORTVERSION= 3.0.2
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,15 +14,18 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= johans@stack.nl
COMMENT= GNU Smalltalk
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
execinfo.1:${PORTSDIR}/devel/libexecinfo
-OPTIONS= TCLTK "Enable Tcl/Tk binding" on
+OPTIONS= TCLTK "Enable Tcl/Tk binding" on \
+ PGSQL "PostgreSQL binding" on
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig
USE_GCC= 3.4+
USE_ICONV= yes
+USE_SQLITE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
@@ -34,7 +37,9 @@ CONFIGURE_ARGS= --enable-generational-gc=no \
USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
-MAN1= gst.1
+MAN1= gst.1 gst-load.1 gst-package.1 gst-sunit.1 gst-config.1 \
+ gst-convert.1 gst-doc.1
+MLINKS= gst-load.1 gst-reload.1
INFO= gst gst-base gst-libs
CPPFLAGS= -I${LOCALBASE}/include
@@ -56,6 +61,14 @@ CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
PLIST_SUB+= TCLTK=""
.endif
+.if defined(WITHOUT_PGSQL)
+PLIST_SUB+= PGSQL="@comment "
+.else
+USE_PGSQL= yes
+.include "${PORTSDIR}/Mk/bsd.database.mk"
+PLIST_SUB+= PGSQL=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
-e 's/ia64-\*-\* /&|amd64-*-* /' \