aboutsummaryrefslogtreecommitdiff
path: root/lang/smalltalk/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2009-10-08 19:41:01 +0000
committerJohan van Selst <johans@FreeBSD.org>2009-10-08 19:41:01 +0000
commita2333d301394678b70c8fc4d7fd0e74b73d02f68 (patch)
tree5d9683442d07f15ff8d06924d78ee9fa67f6f3c8 /lang/smalltalk/Makefile
parent261782ff60f3503d31b0fb66ee61b6791db7be59 (diff)
downloadports-a2333d301394678b70c8fc4d7fd0e74b73d02f68.tar.gz
ports-a2333d301394678b70c8fc4d7fd0e74b73d02f68.zip
Notes
Diffstat (limited to 'lang/smalltalk/Makefile')
-rw-r--r--lang/smalltalk/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 1081e6632c55..ff95c33227a1 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smalltalk
-PORTVERSION= 3.0.5
+PORTVERSION= 3.1
CATEGORIES= lang
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +16,19 @@ COMMENT= GNU Smalltalk
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
- execinfo.1:${PORTSDIR}/devel/libexecinfo
+ execinfo.1:${PORTSDIR}/devel/libexecinfo \
+ cairo.2:${PORTSDIR}/graphics/cairo
OPTIONS= TCLTK "Enable Tcl/Tk binding" on \
- PGSQL "PostgreSQL binding" on
+ PGSQL "PostgreSQL binding" on \
+ SDL "SDL binding" on
USE_AUTOTOOLS= libtool:22
-USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GNOME= gnomehack gnometarget pkgconfig pango
USE_ICONV= yes
USE_SQLITE= yes
USE_GMAKE= yes
+USE_GL= gl glut
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
ac_cv_prog_EMACS=no
@@ -68,6 +71,13 @@ USE_PGSQL= yes
PLIST_SUB+= PGSQL=""
.endif
+.if defined(WITHOUT_SDL)
+PLIST_SUB+= SDL="@comment "
+.else
+USE_SDL= image mixer sdl sound ttf
+PLIST_SUB+= SDL=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
-e 's/ia64-\*-\* /&|amd64-*-* /' \