aboutsummaryrefslogtreecommitdiff
path: root/lang/smalltalk/files
diff options
context:
space:
mode:
authorJames Raynard <jraynard@FreeBSD.org>1997-11-29 14:15:44 +0000
committerJames Raynard <jraynard@FreeBSD.org>1997-11-29 14:15:44 +0000
commitbf196288127a1a2b035c921dd50aff0cdeffb538 (patch)
tree878bb2fbc2a838d0d7babcf43aa7ca5eeca5b5df /lang/smalltalk/files
parent3fee04a75afc7daa01803c88f34a6cb35391dbd1 (diff)
downloadports-bf196288127a1a2b035c921dd50aff0cdeffb538.tar.gz
ports-bf196288127a1a2b035c921dd50aff0cdeffb538.zip
Notes
Diffstat (limited to 'lang/smalltalk/files')
-rw-r--r--lang/smalltalk/files/patch-aa83
-rw-r--r--lang/smalltalk/files/patch-ad42
-rw-r--r--lang/smalltalk/files/patch-ae94
3 files changed, 91 insertions, 128 deletions
diff --git a/lang/smalltalk/files/patch-aa b/lang/smalltalk/files/patch-aa
index b38a71d58c1b..e0fb50c6b2cc 100644
--- a/lang/smalltalk/files/patch-aa
+++ b/lang/smalltalk/files/patch-aa
@@ -1,68 +1,15 @@
-*** /dev/null Thu Feb 2 13:59:15 1995
---- mstpaths.h Thu Feb 2 14:43:38 1995
-***************
-*** 0 ****
---- 1,63 ----
-+ /***********************************************************************
-+ *
-+ * Definitions for various path related things. These are compiled into
-+ * the GNU Smalltalk interpreter and are used for finding various files
-+ * (the image file, the kernel .st files, etc.).
-+ *
-+ ***********************************************************************/
-+
-+
-+ /***********************************************************************
-+ *
-+ * Copyright (C) 1990, 1991 Free Software Foundation, Inc.
-+ * Written by Steve Byrne.
-+ *
-+ * This file is part of GNU Smalltalk.
-+ *
-+ * GNU Smalltalk is free software; you can redistribute it and/or modify it
-+ * under the terms of the GNU General Public License as published by the Free
-+ * Software Foundation; either version 1, or (at your option) any later
-+ * version.
-+ *
-+ * GNU Smalltalk is distributed in the hope that it will be useful, but WITHOUT
-+ * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-+ * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
-+ * more details.
-+ *
-+ * You should have received a copy of the GNU General Public License along with
-+ * GNU Smalltalk; see the file COPYING. If not, write to the Free Software
-+ * Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
-+ *
-+ ***********************************************************************/
-+
-+
-+
-+ /*
-+ * Change Log
-+ * ============================================================================
-+ * Author Date Change
-+ * sbyrne 15 Oct 89 Created.
-+ *
-+ */
-+
-+
-+ /***********************************************************************
-+ *
-+ * You'll need to change these definitions if you do not install GNU
-+ * Smalltalk in the standard place (which, as defined here, is
-+ * /usr/local/smalltalk). You should save this file as mstpaths.h and
-+ * leave mstpaths.h-dist in its original form.
-+ *
-+ ***********************************************************************/
-+
-+
-+ #ifndef __MSTPATHS__
-+ #define __MSTPATHS__
-+
-+ /* This defines where the kernel smalltalk (.st) files can be found */
-+ #define KERNEL_PATH "/usr/local/lib/smalltalk"
-+
-+ /* This defines where to search for the saved binary image */
-+ #define IMAGE_PATH "/usr/local/lib/smalltalk"
-+
-+ #endif /* __MSTPATHS__ */
+--- lib/gst.h.orig Fri Nov 28 21:37:24 1997
++++ lib/gst.h Fri Nov 28 21:38:09 1997
+@@ -135,10 +135,12 @@
+ * define __STDC__ */
+ #if (defined (__STDC__) && __STDC__) || defined(_ANSI_C_SOURCE) || defined (__cplusplus) || defined(_WIN32)
+
++#ifndef __FreeBSD__
+ #define __P(args) args
+ #define __const const
+ #define __signed signed
+ #define __volatile volatile
++#endif
+ #define __DOTS , ...
+
+ #else /* Not ANSI C or C++. */
diff --git a/lang/smalltalk/files/patch-ad b/lang/smalltalk/files/patch-ad
index 5a3ee7d693ec..93fbaae13724 100644
--- a/lang/smalltalk/files/patch-ad
+++ b/lang/smalltalk/files/patch-ad
@@ -1,23 +1,19 @@
-*** ymakefile.orig Sun Dec 10 17:56:09 1995
---- ymakefile Sun Dec 10 17:57:22 1995
-***************
-*** 121,130 ****
- /* Compilation flags definitions */
- CFLAGS_NORMAL = -g EXTRA_CC_FLAGS
- CFLAGS_PROFILE = -g -pg -DUSE_MONCONTROL EXTRA_CC_FLAGS
- CFLAGS_OPTIMIZE = -O -DOPTIMIZE EXTRA_CC_FLAGS
-
- /* Actual compilation flags and compiler definition */
-! CFLAGS = $(CFLAGS_NORMAL) $(READLINEDEF)
-
-
-
---- 121,130 ----
- /* Compilation flags definitions */
- CFLAGS_NORMAL = -g EXTRA_CC_FLAGS
- CFLAGS_PROFILE = -g -pg -DUSE_MONCONTROL EXTRA_CC_FLAGS
- CFLAGS_OPTIMIZE = -O -DOPTIMIZE EXTRA_CC_FLAGS
-
- /* Actual compilation flags and compiler definition */
-! CFLAGS = $(CFLAGS_OPTIMIZE) $(READLINEDEF)
-
+--- lib/Makefile.in.orig Fri Nov 28 22:28:12 1997
++++ lib/Makefile.in Fri Nov 28 23:19:37 1997
+@@ -73,7 +73,7 @@
+ LIB=@LIB_EXTENSION@
+
+ # optimization flag -- may become host dependent
+-OPT_FLAG = -O
++#OPT_FLAG = -O
+ CDEBUG = @CDEBUG@
+ USER_OBJECTS = @USER_OBJECTS@
+
+@@ -195,7 +195,6 @@
+ $(INSTALL_DATA) libgst.$(LIB) $(smlibdir)/libgst.$(LIB)
+ $(INSTALL_DATA) gst.h $(includedir)/gst.h
+ $(INSTALL_DATA) gstpub.h $(includedir)/gstpub.h
+- $(INSTALL_DATA) config.h $(includedir)/config.h
+
+ uninstall:
+
diff --git a/lang/smalltalk/files/patch-ae b/lang/smalltalk/files/patch-ae
index 67d84717dccb..d4e7fdcf68b4 100644
--- a/lang/smalltalk/files/patch-ae
+++ b/lang/smalltalk/files/patch-ae
@@ -1,37 +1,57 @@
-
-*** stix/Makefile.orig Thu Sep 12 15:11:30 1991
---- stix/Makefile Sun Jun 2 17:51:14 1996
-***************
-*** 56,62 ****
- CPP = cc -E
-
- # Uncomment this line to enable the ultra-winning readline-reader
-! #READLINE = -DUSE_READLINE
-
- ######################################################################
- ######################################################################
---- 56,62 ----
- CPP = cc -E
-
- # Uncomment this line to enable the ultra-winning readline-reader
-! READLINE = -DUSE_READLINE
-
- ######################################################################
- ######################################################################
-***************
-*** 88,94 ****
-
- # Edit this to reflect the path on your system where the X include files
- # may be found.
-! XINCLUDE = /usr/include/X11
-
- socket.o: socket.c
- $(CC) -I$(XINCLUDE) $(CFLAGS) -DUNIXCONN -c socket.c
---- 88,94 ----
-
- # Edit this to reflect the path on your system where the X include files
- # may be found.
-! XINCLUDE = /usr/X11R6/include
-
- socket.o: socket.c
- $(CC) -I$(XINCLUDE) $(CFLAGS) -DUNIXCONN -c socket.c
+--- Makefile.in.orig Sun Sep 17 11:49:10 1995
++++ Makefile.in Sat Nov 29 01:33:15 1997
+@@ -70,7 +70,7 @@
+ COMPLETE_MAKE=@COMPLETE_MAKE@
+
+ # optimization flag -- may become host dependent
+-OPT_FLAG = -O
++#OPT_FLAG = -O
+ CDEBUG = @CDEBUG@
+ USER_OBJECTS = @USER_OBJECTS@
+
+@@ -90,7 +90,7 @@
+ # Where to put the system-wide image file
+ libdir = $(prefix)/lib
+ smlibdir = $(libdir)/smalltalk
+-stdir = $(prefix)/smalltalk
++stdir = $(libdir)/smalltalk
+
+ ## Where to put the manual pages.
+ #mandir = $(prefix)/man
+@@ -160,12 +160,12 @@
+ Makefile.defs.in Makefile.rules \
+ blox/Makefile.body \
+ stix/Makefile.body tcp/Makefile.body test/Makefile.body \
+- cxtnsn/Makefile.body examples/Makefile.body contrib/Makefile.body \
++ examples/Makefile.body contrib/Makefile.body \
+ info/Makefile.body
+
+
+ # Subdirectories to run make in for the primary targets.
+-SUBDIRS = lib stix blox info examples contrib cxtnsn test tcp
++SUBDIRS = lib stix blox info examples contrib test tcp
+
+ # Only make TAGS/tags files in these directories, in this order
+ ###TSUBDIRS= src lib
+@@ -197,7 +197,7 @@
+ $(RM) gst
+ $(CC) $(LDFLAGS) $(LDPATH) $(BINDING) -o $@ $(CFLAGS) $(CDEBUG) \
+ $(OBJECTS) lib/libgst.a $(LIBS)
+- $(COMPLETE_MAKE)
++# $(COMPLETE_MAKE)
+
+ # A hack to force this directory to be reevaluated.
+ libgst.a:
+@@ -219,8 +219,10 @@
+ # $(RM) junk.c xmakefile
+
+ installdirs:
+- $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(smlibdir) $(infodir) \
+- $(stdir)
++ if [ ! -d $(smlibdir) ]; then \
++ $(SHELL) $(srcdir)/mkinstalldirs $(bindir) $(smlibdir) $(infodir) \
++ $(stdir); \
++ fi
+
+ install:: installdirs all
+ $(INSTALL_PROGRAM) gst $(bindir)/$(binprefix)gst