aboutsummaryrefslogtreecommitdiff
path: root/lang/smalltalk
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-07-26 15:50:19 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-07-26 15:50:19 +0000
commit89edd69cb278111fedbf148f924d3e9473b00a1e (patch)
tree8c82e1d3cc7509e0582e05b4e6f60aa1a9fbc62e /lang/smalltalk
parent321b6869764c34f3e951ec5af56720a812dcbcf4 (diff)
- Add dependency on devel/libexecinfo for missing backtrace_*() symbols
- Use OPTIONS and enable Tcl/Tk by default [me] PR: ports/83905 Submitted by: Konstantin Belousov
Notes
Notes: svn path=/head/; revision=140163
Diffstat (limited to 'lang/smalltalk')
-rw-r--r--lang/smalltalk/Makefile9
-rw-r--r--lang/smalltalk/files/patch-libgst_Makefile.in14
2 files changed, 20 insertions, 3 deletions
diff --git a/lang/smalltalk/Makefile b/lang/smalltalk/Makefile
index 351f896b0eae..e5582426cfbd 100644
--- a/lang/smalltalk/Makefile
+++ b/lang/smalltalk/Makefile
@@ -15,7 +15,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= GNU Smalltalk
-LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm \
+ execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+OPTIONS= TCLTK "Enable Tcl/Tk binding" on
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -32,6 +35,8 @@ INFO= gst gst-base gst-libs
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+.include <bsd.port.pre.mk>
+
.if defined(WITH_TCLTK)
LIB_DEPENDS+= tk84.1:${PORTSDIR}/x11-toolkits/tk84
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
@@ -42,8 +47,6 @@ CONFIGURE_ARGS+= --with-tcl=no
PLIST_SUB+= TCLTK="@comment "
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} != "i386" && ${ARCH} != "alpha"
BROKEN= "Does not compile on !i386 and !alpha"
.endif
diff --git a/lang/smalltalk/files/patch-libgst_Makefile.in b/lang/smalltalk/files/patch-libgst_Makefile.in
new file mode 100644
index 000000000000..b91c25fd3fe0
--- /dev/null
+++ b/lang/smalltalk/files/patch-libgst_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- libgst/Makefile.in.orig
++++ libgst/Makefile.in
+@@ -212,7 +212,7 @@
+
+ # definitions for libgst.la
+ libgst_la_LIBADD = $(top_builddir)/lib-src/library.la $(LIBSIGSEGV) \
+- @LIBLTDL@ @LIBSNPRINTFV@ @LIBREADLINE@ @LIBGMP@
++ @LIBLTDL@ @LIBSNPRINTFV@ @LIBREADLINE@ @LIBGMP@ -lexecinfo
+
+
+ libgst_la_LDFLAGS = -version-info $(VERSION_INFO)