aboutsummaryrefslogtreecommitdiff
path: root/lang/sml-nj/Makefile
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>1998-11-20 08:14:12 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>1998-11-20 08:14:12 +0000
commit190c2427ea2fe89ca2a3b6aaa4ea17dc9a0b8d81 (patch)
treea8964850342d50945e9a72ed3a1533ae94df21d6 /lang/sml-nj/Makefile
parent09ae5a3b638b58661adba5e90d8196c2f1ce0764 (diff)
downloadports-190c2427ea2fe89ca2a3b6aaa4ea17dc9a0b8d81.tar.gz
ports-190c2427ea2fe89ca2a3b6aaa4ea17dc9a0b8d81.zip
Notes
Diffstat (limited to 'lang/sml-nj/Makefile')
-rw-r--r--lang/sml-nj/Makefile63
1 files changed, 40 insertions, 23 deletions
diff --git a/lang/sml-nj/Makefile b/lang/sml-nj/Makefile
index 9a20dc500de8..0c88dcaec814 100644
--- a/lang/sml-nj/Makefile
+++ b/lang/sml-nj/Makefile
@@ -3,53 +3,70 @@
# Date created: 7 July 1998
# Whom: jkoshy
#
-# $Id: Makefile,v 1.1.1.1 1998/07/15 10:05:42 jkoshy Exp $
+# $Id: Makefile,v 1.2 1998/07/20 07:56:58 jkoshy Exp $
#
-DISTNAME= 110-bin.x86-unix
-PKGNAME= smlnj-110
+DISTNAME= 110.9.1-bin.x86-unix
+PKGNAME= smlnj-110.9.1
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.research.bell-labs.com/dist/smlnj/release/110/ \
- ftp://rodin.stanford.edu/pub/smlnj/release/110/ \
- ftp://flint.cs.yale.edu/pub/smlnj/release/110/ \
- ftp://ftp.diku.dk/pub/smlnj/release/110/ \
- ftp://ftp.cl.cam.ac.uk/MIRRORED/smlnj/release/110/ \
- ftp://sunsite.doc.ic.ac.uk/computing/programming/languages/ml/smlnj/release/110/ \
- ftp://ftp.ntua.gr/pub/lang/smlnj/release/110/ \
- ftp://compiler.kaist.ac.kr/pub/sml/release/110/
-DISTFILES= 110-bin.x86-unix.tar.Z 110-cm.tar.Z 110-cml.tar.Z \
- 110-config.tar.Z 110-eXene.tar.Z \
- 110-ml-burg.tar.Z 110-ml-lex.tar.Z 110-ml-yacc.tar.Z \
- 110-runtime.tar.Z 110-sml-nj.tar.Z 110-smlnj-c.tar.Z \
- 110-smlnj-lib.tar.Z
+MASTER_SITES= ftp://ftp.research.bell-labs.com/dist/smlnj/working/110.9.1/ \
+ ftp://rodin.stanford.edu/pub/smlnj/working/110.9.1/ \
+ ftp://flint.cs.yale.edu/pub/smlnj/working/110.9.1/ \
+ ftp://ftp.diku.dk/pub/smlnj/working/110.9.1/ \
+ ftp://ftp.cl.cam.ac.uk/MIRRORED/smlnj/working/110.9.1/ \
+ ftp://sunsite.doc.ic.ac.uk/computing/programming/languages/ml/smlnj/working/110.9.1/ \
+ ftp://ftp.ntua.gr/pub/lang/smlnj/working/110.9.1/ \
+ ftp://compiler.kaist.ac.kr/pub/sml/working/110.9.1/
+DISTFILES= 110.9.1-bin.x86-unix.tar.Z 110.9.1-cm.tar.Z 110.9.1-cml.tar.Z \
+ 110.9.1-config.tar.Z 110.9.1-eXene.tar.Z \
+ 110.9.1-ml-burg.tar.Z 110.9.1-ml-lex.tar.Z 110.9.1-ml-yacc.tar.Z \
+ 110.9.1-runtime.tar.Z 110.9.1-smlnj-c.tar.Z \
+ 110.9.1-smlnj-lib.tar.Z
MAINTAINER= jkoshy@freebsd.org
DIST_SUBDIR= sml-nj
NO_WRKSUBDIR= yes
-EXTRACT_ONLY= 110-config.tar.Z
+EXTRACT_ONLY= 110.9.1-config.tar.Z
USE_GMAKE= yes
SML_BASE= ${PREFIX}/lib/sml-nj
SML_LIBDIR= ${SML_BASE}/lib
SML_BINDIR= ${SML_BASE}/bin
SML_SRCDIR= ${SML_BASE}/src
-SML_EXES= ml-burg ml-lex ml-yacc sml sml-cm
+SML_EXES= ml-burg ml-lex ml-yacc sml
-BROKEN= Need to install documentation and library sources.
+# make symlinks to the dist files
+post-extract:
+ cd ${WRKDIR} && ${LN} -sf ${_DISTDIR}/* .
# The build target needs to run $WRKDIR/config/install.sh
do-build:
- cd ${WRKDIR} && ./config/install.sh
+ cd ${WRKDIR} && unset PWD && ./config/install.sh
+# install target
+# 1. create installation directories
+# 2. copy the ./bin directory across
+# 3. edit bin/.run_sml to override BIN_DIR
+# 4. copy all .stable files in CM/ directories
+# 5. find all .cm files reachable from $WRKDIR/lib and copy them across
+# 6. copy the aliases in ./lib changing WRKDIR to SML_LIBDIR
+# 7. install links to executables in $PREFIX/bin
do-install:
- ${MKDIR} ${SML_BASE}
- ${MKDIR} ${SML_BINDIR}
+ ${MKDIR} ${SML_BASE} ${SML_BINDIR} ${SML_LIBDIR}
tar -C ${WRKDIR} -cf - bin | tar -C ${SML_BASE} -xf -
- ${RM} ${SML_BINDIR}/.run-sml
+ ${RM} -f ${SML_BINDIR}/.run-sml
${SED} -e "s,^BIN_DIR=.*\$$,BIN_DIR=${SML_BINDIR}," \
< ${WRKDIR}/bin/.run-sml > ${SML_BINDIR}/.run-sml
chmod 755 ${SML_BINDIR}/.run-sml
+ cd ${WRKDIR} && tar -cf - `find . -name '*.stable' | ${GREP} CM` | \
+ tar -C ${SML_BASE} -xf -
+ cd ${WRKDIR} && tar -cf - `${SCRIPTDIR}/get-cm ${WRKDIR}` | \
+ tar -C ${SML_BASE} -xf -
+ for file in ${WRKDIR}/lib/*; do\
+ ${SED} -e "s,${WRKDIR},${SML_BASE}," < $$file > \
+ ${SML_LIBDIR}/`basename $$file`; \
+ done
.for file in ${SML_EXES}
-${LN} -s ${SML_BINDIR}/${file} ${PREFIX}/bin/${file}
.endfor