aboutsummaryrefslogtreecommitdiff
path: root/lang/smlnj
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-11-05 12:36:25 +0000
commit065c026fe5e21a269bbaae0ce69307c7308acbea (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /lang/smlnj
parent6d6314e20da82ad66b7b278eee92373caa9ab746 (diff)
downloadports-065c026fe5e21a269bbaae0ce69307c7308acbea.tar.gz
ports-065c026fe5e21a269bbaae0ce69307c7308acbea.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Notes
Notes: svn path=/head/; revision=400848
Diffstat (limited to 'lang/smlnj')
-rw-r--r--lang/smlnj/Makefile44
1 files changed, 22 insertions, 22 deletions
diff --git a/lang/smlnj/Makefile b/lang/smlnj/Makefile
index 12932ce4576f..a87154c0ef49 100644
--- a/lang/smlnj/Makefile
+++ b/lang/smlnj/Makefile
@@ -139,7 +139,7 @@ pre-fetch:
# make symlinks to the dist files
post-extract:
- cd ${WRKDIR} && ${LN} -sf ${_DISTDIR}/* .
+ cd ${WRKSRC} && ${LN} -sf ${_DISTDIR}/* .
# Configuring is done by uncommenting the appropriate #request
# lines of config/targets. Dependency details are handled by
@@ -152,7 +152,7 @@ do-configure:
.for t in ${MLTARGETS}
${ECHO_CMD} '/^#request[ ]+${t}$$/s/^#//' >> "${WRKDIR}/.tmp.sed"
.endfor
- ${SED} -i .default -E -f "${WRKDIR}/.tmp.sed" "${WRKDIR}/config/targets"
+ ${SED} -i .default -E -f "${WRKDIR}/.tmp.sed" "${WRKSRC}/config/targets"
.endif
# Recompilation requires ml-lex and ml-yacc. All requested targets
# will be built later using the recompiled core system after
@@ -162,7 +162,7 @@ do-configure:
${ECHO_CMD} "request ml-lex" && \
${ECHO_CMD} "request ml-lex-mllex-tool" && \
${ECHO_CMD} "request src-smlnj" ) \
- > "${WRKDIR}/config/targets.customized"
+ > "${WRKSRC}/config/targets.customized"
.endif
# The build target patches, builds, and installs the system within WRKDIR.
@@ -203,7 +203,7 @@ MLSOURCEPATCHES_CMD= ${TRUE}
.endif
do-build:
- cd ${WRKDIR} && unset PWD && \
+ cd ${WRKSRC} && unset PWD && \
FILESDIR="${FILESDIR}" PATCH="${PATCH}" PATCH_ARGS="${PATCH_ARGS}" \
MLNORUNTIMECLEAN=yes \
MLRUNTIMEPATCHES=`${MLRUNTIMEPATCHES_CMD}` \
@@ -213,26 +213,26 @@ do-build:
CFLAGS='${CFLAGS}' AS='${AS}' EXTRA_DEFS='${EXTRA_DEFS}' \
./config/install.sh
.if defined(ML_RECOMPILE)
- -${RM} ${WRKDIR}/config/targets.customized
+ -${RM} ${WRKSRC}/config/targets.customized
@${ECHO} '(* Recompiling the core system: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && ( \
+ cd ${WRKSRC}/${RECOMPILEDIR} && ( \
${ECHO_CMD} 'CM.autoload "$$smlnj/cmb.cm";' ; \
${ECHO_CMD} ${CMB_COMMAND} ; \
${ECHO_CMD} 'CMB.make ();' ) | \
../../bin/sml
@${ECHO} '(* Building the recompiled heap: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && \
+ cd ${WRKSRC}/${RECOMPILEDIR} && \
./makeml
@${ECHO} '(* Removing old libs and heaps: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && \
+ cd ${WRKSRC}/${RECOMPILEDIR} && \
${RM} -rf ../../lib && ${MKDIR} ../../lib && \
${FIND} ../../bin/.heap -name '*.${MLARCH}-bsd' \
\! -name 'sml.${MLARCH}-bsd' -delete -print
@${ECHO} '(* Installing the recompiled libs and heap: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && \
+ cd ${WRKSRC}/${RECOMPILEDIR} && \
./installml
@${ECHO} '(* Building requested targets: *)'
- cd ${WRKDIR} && unset PWD && \
+ cd ${WRKSRC} && unset PWD && \
FILESDIR="${FILESDIR}" PATCH="${PATCH}" PATCH_ARGS="${PATCH_ARGS}" \
MLNORUNTIMECLEAN=yes RECOMPILEDIR="${RECOMPILEDIR}" \
CFLAGS='${CFLAGS}' AS='${AS}' EXTRA_DEFS='${EXTRA_DEFS}' \
@@ -243,14 +243,14 @@ do-build:
# then we have to remove them at several points during the
# installation process. This is no longer necessary with FreeBSD 10
# as it uses libarchive 3.x (via bsdtar), but earlier versions
-# don't ignore such resource files and hence WRKDIR and STAGEDIR
+# don't ignore such resource files and hence WRKSRC and STAGEDIR
# are full of them. Once FreeBSD 9 will be out of service, all
# lines in this Makefile can be removed which contain a pattern
# for the prefix "._" of the resource files. Background information:
# <https://github.com/libarchive/libarchive/wiki/TarExtendedAttributes#Apple_tar>
post-build:
- ${FIND} ${WRKDIR} -type f -name '\._*' -delete
+ ${FIND} ${WRKSRC} -type f -name '\._*' -delete
# Nowadays PLIST has to be computed before installation. We do it in
# "pre-install" because source extraction happens during "build".
@@ -273,7 +273,7 @@ MLPATCHPATHREGEX= -E -e 's%(^|[^_])_([^_]|$$)%\1/\2%g' \
pre-install:
.if defined(ML_EVERYTHING)
@${ECHO} -n '(* Computing package list ...'
- @${TAR} -tzf ${WRKDIR}/runtime.tgz | \
+ @${TAR} -tzf ${WRKSRC}/runtime.tgz | \
${GREP} -E -v '(^|/)\._.*' | \
${SED} -E -n -e 's%^(.*[^/])$$%${MLROOTRELATIVE}/base/\1%p' \
> ${MLRUNTIMEPLIST}
@@ -288,7 +288,7 @@ pre-install:
${SED} ${MLPATCHPATHREGEX} | \
${SED} -E -e 's%^(do|extra)-patch-(base/.*)%${MLROOTRELATIVE}/\2.orig%' \
>> ${MLRUNTIMEPLIST}
- @cd "${WRKDIR}" && ( \
+ @cd "${WRKSRC}" && ( \
( ${FIND} -s -d ${MLSRCDIRS} \! -type d | \
${AWK} '{ print "${MLROOTRELATIVE}/" $$0 }' ) ; \
( ${FIND} -s -d ${MLSRCDIRS} -type d -empty | \
@@ -333,7 +333,7 @@ MLSRCEXCLUDES+= --exclude "${excl}"
do-install:
${MKDIR} "${STAGEDIR}${MLROOT}"
.if ! defined(ML_RECOMPILE)
- cd ${WRKDIR} && unset PWD && \
+ cd ${WRKSRC} && unset PWD && \
FILESDIR="${FILESDIR}" PATCH="${PATCH}" PATCH_ARGS="${PATCH_ARGS}" \
STAGEDIR="${STAGEDIR}" MLLIB="${MLLIB}" \
INSTALLDIR="${STAGEDIR}${MLROOT}" \
@@ -341,16 +341,16 @@ do-install:
./config/install.sh
.else
@${ECHO} '(* Rebuilding the recompiled libs: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && ( \
+ cd ${WRKSRC}/${RECOMPILEDIR} && ( \
${ECHO_CMD} 'CM.autoload "$$smlnj/cmb.cm";' ; \
${ECHO_CMD} ${CMB_COMMAND} ; \
${ECHO_CMD} 'CMB.make ();' ) | \
../../bin/sml
@${ECHO} '(* Rebuilding the recompiled heap: *)'
- cd ${WRKDIR}/${RECOMPILEDIR} && \
+ cd ${WRKSRC}/${RECOMPILEDIR} && \
./makeml
@${ECHO} '(* Installing into ${MLROOT}: *)'
- cd ${WRKDIR} && unset PWD && \
+ cd ${WRKSRC} && unset PWD && \
FILESDIR="${FILESDIR}" PATCH="${PATCH}" PATCH_ARGS="${PATCH_ARGS}" \
STAGEDIR="${STAGEDIR}" MLLIB="${MLLIB}" \
INSTALLDIR="${STAGEDIR}${MLROOT}" RECOMPILEDIR="${RECOMPILEDIR}" \
@@ -361,8 +361,8 @@ do-install:
${FIND} ${STAGEDIR} -type f -name '\._*' -delete
@${ECHO} '(* Installing man pages. *)'
.for mansect in 1 2 3 4 5 6 7 8 9
- @[ ! -d ${WRKDIR}/doc/man/man${mansect} ] || \
- { cd ${WRKDIR}/doc/man/man${mansect} && ls *.${mansect} | \
+ @[ ! -d ${WRKSRC}/doc/man/man${mansect} ] || \
+ { cd ${WRKSRC}/doc/man/man${mansect} && ls *.${mansect} | \
${XARGS} -J % \
${INSTALL_MAN} % ${STAGEDIR}${MANPREFIX}/man/man${mansect} ; }
.endfor
@@ -373,9 +373,9 @@ do-install:
"${STAGEDIR}${MLBIN}/.run/run.$${ARCH}-$${OPSYS}.so" )
.if defined(ML_EVERYTHING)
@${ECHO} '(* Cleaning base/runtime: *)'
- cd ${WRKDIR}/base/runtime/objs && ${MAKE_CMD} clean
+ cd ${WRKSRC}/base/runtime/objs && ${MAKE_CMD} clean
@${ECHO} -n '(* Installing sources into ${STAGEDIR}${MLROOT} ...'
- @cd ${WRKDIR} && ${TAR} -cf - ${MLSRCEXCLUDES} ${MLSRCDIRS} | \
+ @cd ${WRKSRC} && ${TAR} -cf - ${MLSRCEXCLUDES} ${MLSRCDIRS} | \
${TAR} -xf - -C "${STAGEDIR}${MLROOT}"
@${ECHO} ' done. *)'
.endif