aboutsummaryrefslogtreecommitdiff
path: root/lang/snobol4/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-25 12:51:30 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-02-25 12:51:30 +0000
commit4b8b16c513c008d6d42e661d8ef9b9e0377dd7af (patch)
treed344cdd6dd6eb1b8f37b8c1e9ffa40fdc6449622 /lang/snobol4/Makefile
parentc9f846b0ba93cb55d27eee401f9a48d5746abb45 (diff)
downloadports-4b8b16c513c008d6d42e661d8ef9b9e0377dd7af.tar.gz
ports-4b8b16c513c008d6d42e661d8ef9b9e0377dd7af.zip
Notes
Diffstat (limited to 'lang/snobol4/Makefile')
-rw-r--r--lang/snobol4/Makefile57
1 files changed, 36 insertions, 21 deletions
diff --git a/lang/snobol4/Makefile b/lang/snobol4/Makefile
index c8724c0f1c07..731778d18bb6 100644
--- a/lang/snobol4/Makefile
+++ b/lang/snobol4/Makefile
@@ -2,38 +2,53 @@
# $FreeBSD$
PORTNAME= snobol4
-PORTVERSION= 2.1.6
-PORTREVISION= 1
+PORTVERSION= 2.2.1
CATEGORIES= lang
-MASTER_SITES= ftp://ftp.ultimate.com/snobol/
+MASTER_SITES= ftp://ftp.snobol4.org/snobol/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Port of Macro SNOBOL4, supports full SNOBOL4 plus SPITBOL
+MAINTAINER= phil@snobol4.org
+COMMENT= Full SNOBOL4 language with SPITBOL, BLOCKS, and other extensions
LICENSE= BSD2CLAUSE
-LICENSE_FILE= ${PATCHDIR}/LICENSE
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+
+# will also use libedit, but poundriere tests fail.
+USES= readline ssl
-USES= gmake libedit
HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --prefix=${PREFIX} \
- --snolibdir=${PREFIX}/lib/${PORTNAME}
-CONFIGURE_ENV+= DL_EXT=".so"
-ALL_TARGET= xsnobol4
-LDFLAGS+= -L${PREFIX}/lib
+CONFIGURE_ARGS= --prefix=${PREFIX}
+
+MAKE_JOBS_UNSAFE=yes
+ALL_TARGET= build_all
+INSTALL_TARGET= install_notiming
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
PLIST_SUB+= VERSION=${PORTVERSION}
-PORTDOCS= *
-OPTIONS_DEFINE= DOCS
+# openssl in base system?
+
+# NOTE! configure detects necessary libraries for extension modules
+# and will build them without these options enabled (and there aren't
+# (currently) any --without options to disable them)
+#
+# It's possible to build the extension modules independently of the
+# main distribution, so there could be snobol4-ffi, snobol4-sqlite3
+# ports, BUT you need to cd to a subdir before running make.
+#
+# Not including Tcl, would need a RADIO selector for tcl version, and
+# configure would need to be run with --with-tcl=/path/to/tclConfig.sh
+
+OPTIONS_DEFINE= FFI SQLITE3 DOCS
+OPTIONS_DEFAULT= FFI SQLITE3 DOCS
+
+FFI_DESC= Foreign Function Interface module
+SQLITE3_DESC= SQLite version 3 module
+
+DOCS_CONFIGURE_WITH= docs
+FFI_LIB_DEPENDS= libffi.so:devel/libffi
+SQLITE3_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
post-patch:
- @${REINPLACE_CMD} 's:[^=]*\.tmp$$:${WRKSRC}/&:' ${WRKSRC}/configure
- @${REINPLACE_CMD} 's:../snobol4:../xsnobol4:' \
- ${WRKSRC}/doc/Makefile ${WRKSRC}/modules/*/Makefile
- @${REINPLACE_CMD} -e 's:<BINDIR>:${PREFIX}/bin:' \
- -e 's:<SNOLIB_LIB>:${PREFIX}/lib/${PORTNAME}:' \
- ${WRKSRC}/snopea.in ${WRKSRC}/sdb.sh
+ @${REINPLACE_CMD} 's/CFLAGS /CFLAGS $$CPPFLAGS /' ${WRKSRC}/config/check
.include <bsd.port.mk>